Bug 147555 - Fatal Python error: could not import gnomevfs
Fatal Python error: could not import gnomevfs
Status: CLOSED DUPLICATE of bug 149085
Product: Fedora
Classification: Fedora
Component: gnome-python2 (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks: FC4Blocker
  Show dependency treegraph
 
Reported: 2005-02-09 02:52 EST by H. van de Kolk
Modified: 2013-03-13 00:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-19 15:03:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description H. van de Kolk 2005-02-09 02:52:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041228 Firefox/1.0 Fedora/1.0-8

Description of problem:
Up2date after applying the updates from developement 8-febr-2005
the next error appeared after running up2date:

Fatal Python error: could not import gnomevfs
Geannuleerd

Version-Release number of selected component (if applicable):
up2date-4.3.69-1

How reproducible:
Always

Steps to Reproduce:
1.run up2date from bash
2.
3.
    

Actual Results:  Fatal Python error: could not import gnomevfs
Geannuleerd

Expected Results:  gui from up2date

Additional info:
Comment 1 scott white 2005-02-09 15:55:16 EST
trying to run system-config-network I get the same error:

Fatal Python error: could not import gnomevfs

running fedora rawhide

# rpm -qa | grep vfs
gnome-vfs-1.0.5-21
gnome-vfs2-smb-2.9.90-1
gnome-vfs-extras-0.2.0-9
gnome-vfs2-2.9.90-1
gnome-vfs2-devel-2.9.90-1

# rpm -qa | grep python
gnome-python2-canvas-2.9.4-2
dbus-python-0.23-4
gnome-python2-gtkhtml2-2.9.3-1
python-2.4-3
gnome-python2-gconf-2.9.4-2
gnome-python2-extras-2.9.3-1
rpm-python-4.3.3-8
libxml2-python-2.6.17-1
python-devel-2.4-3
mod_python-3.1.3-8
gnome-python2-bonobo-2.9.4-2
gnome-python2-2.9.4-2

# rpm -q system-config-network
system-config-network-1.3.22-1

also, system-config-printer does the same, and I suspect others as well

--scott

Comment 2 Jef Spaleta 2005-02-09 23:51:55 EST
I think i found the underlying error in the ui.so file provided by 
gnome-python2-2.9.4-2 package

strings /usr/lib/python2.4/site-packages/gtk-2.0/gnome/ui.so |grep
gnomevfs
libgnomevfs-2.so.0
could not import gnomevfs


start up the python shell and try this
>>> from gnome.ui import *
Fatal Python error: could not import gnomevfs
Aborted

This probably needs to be reassigned to gnome-python2 package.

-jef
Comment 3 Jef Spaleta 2005-02-10 00:09:52 EST
okay i just confirmed it... i hacked up a rebuild of the gnome-python2
in fc3 against python2.4 and install those packages.

I can now get python based applications to work again including 
up2date and system-config-network 

The 'could not import gnomevfs' is almost certaintly in the ui.so from
gnome-python2 in the development tree but i don't know exactly whats
wrong with it.

This really should be refiled against gnome-python2
-jef
Comment 4 Clyde E. Kunkel 2005-02-15 16:27:28 EST
yum install gnome-python2-gnomevfs from rawhide

fixed the problem for me.
Comment 5 H. van de Kolk 2005-02-16 05:45:26 EST
the problem is indeed solved by installing gnome-python-gnomevfs from
rawhide.
This rpm should have been installed as a dependancy. 
Comment 6 John (J5) Palmieri 2005-05-19 15:03:55 EDT
This has been fixed for awhile:

Requires: gnome-python2-gnomevfs

is in the 2.10.0-1 spec file.



*** This bug has been marked as a duplicate of 149085 ***

Note You need to log in before you can comment on or make changes to this bug.