Bug 1475710 - [abrt] ibus: bus_dbus_impl_connection_filter_cb(): ibus-daemon killed by signal 6
[abrt] ibus: bus_dbus_impl_connection_filter_cb(): ibus-daemon killed by sign...
Status: CLOSED DUPLICATE of bug 1350291
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
26
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:b24defc317ee932c47b15b9c24c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-27 04:14 EDT by Gwendal
Modified: 2017-07-27 05:05 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-27 05:05:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (17.94 KB, text/plain)
2017-07-27 04:14 EDT, Gwendal
no flags Details
File: cgroup (195 bytes, text/plain)
2017-07-27 04:14 EDT, Gwendal
no flags Details
File: core_backtrace (11.38 KB, text/plain)
2017-07-27 04:14 EDT, Gwendal
no flags Details
File: cpuinfo (1.72 KB, text/plain)
2017-07-27 04:14 EDT, Gwendal
no flags Details
File: dso_list (2.36 KB, text/plain)
2017-07-27 04:14 EDT, Gwendal
no flags Details
File: environ (1.56 KB, text/plain)
2017-07-27 04:14 EDT, Gwendal
no flags Details
File: limits (1.29 KB, text/plain)
2017-07-27 04:14 EDT, Gwendal
no flags Details
File: maps (11.68 KB, text/plain)
2017-07-27 04:14 EDT, Gwendal
no flags Details
File: open_fds (2.16 KB, text/plain)
2017-07-27 04:14 EDT, Gwendal
no flags Details
File: proc_pid_status (1.28 KB, text/plain)
2017-07-27 04:14 EDT, Gwendal
no flags Details
File: var_log_messages (28 bytes, text/plain)
2017-07-27 04:14 EDT, Gwendal
no flags Details

  None (edit)
Description Gwendal 2017-07-27 04:14:02 EDT
Version-Release number of selected component:
ibus-1.5.16-4.fc26

Additional info:
reporter:       libreport-2.9.1
backtrace_rating: 4
cmdline:        ibus-daemon --xim --panel disable
crash_function: bus_dbus_impl_connection_filter_cb
executable:     /usr/bin/ibus-daemon
journald_cursor: s=976ceac0a19546fe967615f8e533c44a;i=4f2cf;b=73b5f0ebb3b44587aea0f5d446501fe5;m=179fd775e;t=5554809ef57f5;x=12a23f6072d45643
kernel:         4.11.11-300.fc26.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Potential duplicate: bug 982836
Comment 1 Gwendal 2017-07-27 04:14:09 EDT
Created attachment 1305246 [details]
File: backtrace
Comment 2 Gwendal 2017-07-27 04:14:10 EDT
Created attachment 1305247 [details]
File: cgroup
Comment 3 Gwendal 2017-07-27 04:14:12 EDT
Created attachment 1305248 [details]
File: core_backtrace
Comment 4 Gwendal 2017-07-27 04:14:14 EDT
Created attachment 1305249 [details]
File: cpuinfo
Comment 5 Gwendal 2017-07-27 04:14:16 EDT
Created attachment 1305250 [details]
File: dso_list
Comment 6 Gwendal 2017-07-27 04:14:17 EDT
Created attachment 1305251 [details]
File: environ
Comment 7 Gwendal 2017-07-27 04:14:19 EDT
Created attachment 1305252 [details]
File: limits
Comment 8 Gwendal 2017-07-27 04:14:21 EDT
Created attachment 1305253 [details]
File: maps
Comment 9 Gwendal 2017-07-27 04:14:23 EDT
Created attachment 1305254 [details]
File: open_fds
Comment 10 Gwendal 2017-07-27 04:14:26 EDT
Created attachment 1305255 [details]
File: proc_pid_status
Comment 11 Gwendal 2017-07-27 04:14:28 EDT
Created attachment 1305256 [details]
File: var_log_messages
Comment 12 fujiwara 2017-07-27 05:03:48 EDT
I cannot reproduce your backtrace.

(In reply to Gwendal from comment #1)
> Created attachment 1305246 [details]
> File: backtrace

#0  __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:51
#1  0x00007fa9cb83a470 in __GI_abort () at abort.c:89
#2  0x00007fa9cbe6270d in g_assertion_message (domain=domain@entry=0x55850b2f2dda "IBUS", file=file@entry=0x55850b2f3244 "dbusimpl.c", line=line@entry=1473, func=func@entry=0x55850b2f38c0 <__func__.26452> "bus_dbus_impl_connection_filter_cb", message=message@entry=0x7fa9b400e0f0 "assertion failed: (connection != NULL)") at gtestutils.c:2433
#3  0x00007fa9cbe6279a in g_assertion_message_expr (domain=domain@entry=0x55850b2f2dda "IBUS", file=file@entry=0x55850b2f3244 "dbusimpl.c", line=line@entry=1473, func=func@entry=0x55850b2f38c0 <__func__.26452> "bus_dbus_impl_connection_filter_cb", expr=expr@entry=0x55850b2f3291 "connection != NULL") at gtestutils.c:2456
#4  0x000055850b2e23b6 in bus_dbus_impl_connection_filter_cb (dbus_connection=<optimized out>, message=0x55850cd44d40, incoming=0, user_data=0x55850ca72830) at dbusimpl.c:1473
#5  0x00007fa9cc40e59e in on_worker_message_about_to_be_sent (worker=<optimized out>, message=0x55850cd44d40, user_data=0x7fa9b8005c90) at gdbusconnection.c:2347
#6  0x00007fa9cc42326e in _g_dbus_worker_emit_message_about_to_be_sent (message=0x55850cd44d40, worker=0x7fa9b800a2d0) at gdbusprivate.c:468
#7  continue_writing (worker=0x7fa9b800a2d0) at gdbusprivate.c:1459
#8  0x00007fa9cc42386f in write_message_cb (source_object=<optimized out>, res=<optimized out>, user_data=0x7fa9b4009b20) at gdbusprivate.c:1317
#9  0x00007fa9cc3e0534 in g_task_return_now (task=0x55850cafa5b0) at gtask.c:1145
#10 0x00007fa9cc3e0569 in complete_in_idle_cb (task=task@entry=0x55850cafa5b0) at gtask.c:1159
#11 0x00007fa9cbe38c27 in g_idle_dispatch (source=0x7fa9b4021390, callback=0x7fa9cc3e0560 <complete_in_idle_cb>, user_data=0x55850cafa5b0) at gmain.c:5586
#12 0x00007fa9cbe3c247 in g_main_dispatch (context=0x55850caf73a0) at gmain.c:3234
Comment 13 fujiwara 2017-07-27 05:05:07 EDT
Let's see if this bug is fixed with the latest ibus in f25 or later.

*** This bug has been marked as a duplicate of bug 1350291 ***

Note You need to log in before you can comment on or make changes to this bug.