Bug 1475780 - [RFE][scale] - Set "blkdiscard" as the default zero method
[RFE][scale] - Set "blkdiscard" as the default zero method
Status: CLOSED CURRENTRELEASE
Product: vdsm
Classification: oVirt
Component: RFEs (Show other bugs)
4.18.15
Unspecified Unspecified
low Severity medium (vote)
: ovirt-4.2.2
: ---
Assigned To: Idan Shaby
Kevin Alon Goldblatt
: FutureFeature, Performance
Depends On: 1327886 1367806
Blocks: wipe_disk_using_blkdiscard 1314382
  Show dependency treegraph
 
Reported: 2017-07-27 06:40 EDT by Idan Shaby
Modified: 2018-04-06 01:06 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
The default zeroing method has been changed from "dd" to "blkdiscard". The new default method performs significantly better than "dd", as it can use storage offloading (if it is supported by the storage array), and it consumes much less network bandwidth. If required, it is possible to locally set the zeroing method back to "dd" by changing the "zero_method" parameter in /etc/vdsm/vdsm.conf to "dd".
Story Points: ---
Clone Of: 1367806
Environment:
Last Closed: 2018-03-29 07:03:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
tnisan: ovirt‑4.2?
tnisan: exception?
ratamir: testing_plan_complete-
rule-engine: planning_ack?
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 85532 master MERGED blockdev: Use safe default value for zeroout 2018-03-15 20:38 EDT
oVirt gerrit 88026 master MERGED config: change default zero method to blkdiscard 2018-03-19 04:11 EDT
oVirt gerrit 89153 ovirt-4.2 MERGED config: change default zero method to blkdiscard 2018-03-20 03:29 EDT
oVirt gerrit 89155 ovirt-4.2 MERGED blockdev: Use safe default value for zeroout 2018-03-20 03:29 EDT

  None (edit)
Comment 1 Yaniv Kaul 2017-07-30 04:49:07 EDT
I think this is 'blkdiscard --zero' option here.
When we support just 'blkdiscard' (if the storage promises to return zeros on discarded blocks), it's a different option, no?
Comment 2 Idan Shaby 2017-07-30 05:09:09 EDT
Yes, but since we're talking about the config value "zero_method" (see Bug 1367806), the option name is "blkdiscard".

I will open a new BZ to track the second RFE you implied to, i.e when the user removes a disk with an intention to zero and discard it, and the underlying storage support discard_zeroes_data, then the disk is only discarded (and not wiped).
Comment 3 Allon Mureinik 2017-09-14 11:34:52 EDT
This depends on the scale's team ability to prove this method is safe.
Comment 9 Kevin Alon Goldblatt 2018-03-27 04:52:11 EDT
Verified with the following code:
----------------------------------------
ovirt-engine-4.2.2.5-0.1.el7.noarch
vdsm-4.20.23-1.el7ev.x86_64

Verified with the following scenario:
----------------------------------------
1. Created a VM with 10G iscsi disk
2. Started the VM and wrote a 3G of data to the disk
3. Stop the VM
4. Remove the disk
5. Calculated the time that passes between the log message "Zero volume thread started for volume <volume_id>" and the log message "Zero volume <volume_id> task <task_id> completed" >>>>> 4 seconds passed.


Moving to VERIFIED
Comment 10 Sandro Bonazzola 2018-03-29 07:03:36 EDT
This bugzilla is included in oVirt 4.2.2 release, published on March 28th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.2 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.