Bug 872530 (wipe_disk_using_blkdiscard) - [RFE][Tracker] - Wipe volumes using "blkdiscard" instead of "dd"
Summary: [RFE][Tracker] - Wipe volumes using "blkdiscard" instead of "dd"
Keywords:
Status: CLOSED ERRATA
Alias: wipe_disk_using_blkdiscard
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs
Version: 3.1.0
Hardware: All
OS: All
high
high
Target Milestone: ovirt-4.2.2
: ---
Assignee: Idan Shaby
QA Contact: Kevin Alon Goldblatt
URL:
Whiteboard:
: 1014324 (view as bug list)
Depends On: 1367806 1475780
Blocks: 1314382 CEECIR_RHV43_proposed
TreeView+ depends on / blocked
 
Reported: 2012-11-02 11:05 UTC by Andrew Cathrow
Modified: 2021-05-01 16:43 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
The default zeroing method has been changed from "dd" to "blkdiscard", which allows storage offloading, if supported by the storage array, and consumes much less network bandwidth. The zeroing method can be reverted by adding "zero_method = dd" to /etc/vdsm/vdsm.conf.
Clone Of:
Environment:
Last Closed: 2018-05-15 17:35:57 UTC
oVirt Team: Storage
Target Upstream Version:
sherold: Triaged+
ratamir: testing_plan_complete-


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 981626 0 high CLOSED [RFE] Send discard when deleting virtual disks from block based storage domain to regain space in thin provisioned stora... 2021-08-30 11:49:57 UTC
Red Hat Bugzilla 1200428 0 high CLOSED [RFE] disk clone: if xcopy (RFE bug 1069557) is not available, use sg_dd (better performance than 'dd') 2021-02-22 00:41:40 UTC
Red Hat Product Errata RHEA-2018:1488 0 None None None 2018-05-15 17:37:49 UTC
oVirt gerrit 88026 0 'None' 'MERGED' 'config: change default zero method to blkdiscard' 2019-11-23 14:00:42 UTC
oVirt gerrit 89153 0 'None' 'MERGED' 'config: change default zero method to blkdiscard' 2019-11-23 14:00:43 UTC

Internal Links: 981626 1200428

Description Andrew Cathrow 2012-11-02 11:05:43 UTC
oVirt includes an option to wipe a disk after it is deleted to securely erase the disk image.

To perform this we do a simple overwrite, however we may need to perform a more secure erasure for security and compliance reasons. (eg. PCI compliance etc)


We should mirror the work performed by the libvirt team in which they provide a number of algorithms to use when wiping an image.

http://www.redhat.com/archives/libvir-list/2012-January/msg00070.html

Comment 6 Andrew Cathrow 2013-10-10 15:32:11 UTC
*** Bug 1014324 has been marked as a duplicate of this bug. ***

Comment 10 wiley crider 2014-04-22 17:26:27 UTC
The customer requested a status as this is dependent on a VDI implementation.

Comment 24 Yaniv Kaul 2016-04-26 14:23:18 UTC
*** Bug 981626 has been marked as a duplicate of this bug. ***

Comment 25 Allon Mureinik 2016-06-16 08:31:51 UTC
This is an RFE targeted for 4.1.
Idan is working on it, but the work is being done on the code, not on bugzilla, so there aren't too many updates here.

Reducing priority to HIGH to avoid nagging emails from nagging whines.

Comment 26 Yaniv Lavi 2017-07-31 08:26:26 UTC
Moving to MODIFIED as BZ #1367806 upstream is already being tested.

Comment 27 Idan Shaby 2017-07-31 08:30:32 UTC
Yaniv, please note that Bug 1367806 only adds blkdiscard as an option to wipe volumes, but it is not the default option.
BZ 1475780 is responsible for making it the default wiping method.

Comment 29 Allon Mureinik 2017-08-06 06:10:37 UTC
Yaniv - please see comment 27 (was missing a needinfo, probably). I think this should be moved back to ASSIGNED.

Comment 30 Allon Mureinik 2017-09-14 12:50:39 UTC
ATM, this is an available via optional configuration. Setting it to the default is pending the scale's team help on verifying it's usefulness/safety.

Comment 34 Kevin Alon Goldblatt 2018-03-27 08:54:32 UTC
https://bugzilla.redhat.com/show_bug.cgi?id=1475780 - VERIFIED

Used the XtremIO storage provider:

XtremIO Storage Management Application
© Copyright 2009-2016 XtremIO. All rights reserved.

Version: 4.2.1 build 7

Moving to VERIFIED

Comment 37 errata-xmlrpc 2018-05-15 17:35:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:1488

Comment 38 Franta Kust 2019-05-16 13:07:12 UTC
BZ<2>Jira Resync


Note You need to log in before you can comment on or make changes to this bug.