Bug 147603 - Desktop Does Not Refresh When It Should and Icons Don't Arrange Themselves Properly
Desktop Does Not Refresh When It Should and Icons Don't Arrange Themselves Pr...
Status: CLOSED DUPLICATE of bug 133665
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
3
All Linux
medium Severity high
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-09 13:24 EST by Juan C Nuno
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:08:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juan C Nuno 2005-02-09 13:24:59 EST
Description of problem:

When I download stuff to the desktop, it doesn't show up until I hit
Ctrl+R to refresh it.  I wish I wouldn't have to do that.

And when new stuff does show up, it doesn't automatically arrange
itself in the proper order.  Newly mounted disks and created folders
pop up in seemingly random locations, sometimes overlapping other
icons.  So then I have to right click on the desktop and select Clean
Up by Name.  Again, I wish that was automatic.

Only the desktop seems to have this problem.  Nautilus browser windows
 behave exactly as they should.

Version-Release number of selected component (if applicable):

Help - About gives me Nautilus 2.8.1.

How reproducible:

Often.

Steps to Reproduce:

Download something with Firefox.  Insert a CD or have a program create
a folder (I just ripped a CD with Sound Juicer).

Actual results:

Stuff you download doesn't show up until you hit Ctrl+R.  New icons
pop up in seemingly random locations, sometimes even overlapping old
ones.  A right click and a Clean Up by Name sorts everything nicely.

Expected results:

Desktop refresh and sort should happen automatically.  I don't want to
keep hitting Ctrl+R and right-clicking to manually sort things. 
Nautilus browser windows don't seem to have this problem, only the
desktop does.

Additional info:

I'm using the "Home as Desktop" GNOME hack so the contents of my home
directory are the contents of my desktop, and I've done away with the
Desktop directory.  This problem occurred before I did that, so I
don't think it has any bearing.
Comment 1 Alexander Larsson 2005-02-10 03:31:19 EST
This is a gamin bug, and the icon positioning is already reported in
bugzilla too.

*** This bug has been marked as a duplicate of 133665 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:08:09 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.