Bug 1476295 - md-cache uses incorrect xattr keynames for GF_POSIX_ACL keys
md-cache uses incorrect xattr keynames for GF_POSIX_ACL keys
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: md-cache (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Guenther Deschner
:
Depends On:
Blocks: 1499889 1499890
  Show dependency treegraph
 
Reported: 2017-07-28 10:28 EDT by Guenther Deschner
Modified: 2017-12-08 12:35 EST (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.13.0
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1499889 1499890 (view as bug list)
Environment:
Last Closed: 2017-12-08 12:35:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Guenther Deschner 2017-07-28 10:28:13 EDT
Description of problem:

The caching of GF_POSIX_ACL_DEFAULT and GF_POSIX_ACL_ACCESS keys is not done correctly because mdc_key_load_set() tries to enable the caching with an inappropriate prefix.

"glusterfs.posix_acl." does not match "glusterfs.posix.acl" nor "glusterfs.posix.default_acl"

Version-Release number of selected component (if applicable):
3.8
Comment 1 Worker Ant 2017-07-28 10:28:45 EDT
REVIEW: https://review.gluster.org/17909 (md-cache: Use correct xattr keynames for virtual glusterfs ACLs.) posted (#1) for review on master by Günther Deschner (gd@samba.org)
Comment 2 Worker Ant 2017-07-29 16:54:29 EDT
COMMIT: https://review.gluster.org/17909 committed in master by Jeff Darcy (jeff@pl.atyp.us) 
------
commit 5fe8555800cbc9818e7c976f63499795a378cd8d
Author: Günther Deschner <gd@samba.org>
Date:   Wed Jul 26 18:10:33 2017 +0200

    md-cache: Use correct xattr keynames for virtual glusterfs ACLs.
    
    The "glusterfs.posix_acl." prefix does not catch the glusterfs posix acl
    xattr keynames which are
    
    	* "glusterfs.posix.acl" and
    	* "glusterfs.posix.default_acl"
    
    Using the GF_POSIX_ACL_ACCESS and GF_POSIX_ACL_DEFAULT defines directly
    is the savest option.
    
    Guenther
    
    Change-Id: I5aba64b26b6cbec850ea02316dd9f069400e857f
    BUG: 1476295
    Signed-off-by: Guenther Deschner <gd@samba.org>
    Reviewed-on: https://review.gluster.org/17909
    Reviewed-by: Michael Adam <obnox@samba.org>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Tested-by: Niels de Vos <ndevos@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
Comment 3 Shyamsundar 2017-12-08 12:35:59 EST
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.13.0, please open a new bug report.

glusterfs-3.13.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-December/000087.html
[2] https://www.gluster.org/pipermail/gluster-users/

Note You need to log in before you can comment on or make changes to this bug.