Bug 1476549 - [abrt] dnfdragora-gui: _on_status_icon_popup_menu(): _gtk.py:70:_on_status_icon_popup_menu:AttributeError: 'Icon' object has no attribute '_menu_handle'
Summary: [abrt] dnfdragora-gui: _on_status_icon_popup_menu(): _gtk.py:70:_on_status_ic...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnfdragora
Version: 26
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Björn 'besser82' Esser
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:636dff394eb900736b57839dfe6...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-07-30 07:26 UTC by NGupton98
Modified: 2018-01-01 22:10 UTC (History)
19 users (show)

Fixed In Version: dnfdragora-1.0.1-8.git20171229.24e4647.fc27 dnfdragora-1.0.1-8.git20171229.24e4647.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-31 21:27:20 UTC


Attachments (Terms of Use)
File: backtrace (530 bytes, text/plain)
2017-07-30 07:26 UTC, NGupton98
no flags Details
File: cgroup (289 bytes, text/plain)
2017-07-30 07:26 UTC, NGupton98
no flags Details
File: cpuinfo (1.14 KB, text/plain)
2017-07-30 07:27 UTC, NGupton98
no flags Details
File: environ (1.29 KB, text/plain)
2017-07-30 07:27 UTC, NGupton98
no flags Details
File: mountinfo (3.20 KB, text/plain)
2017-07-30 07:27 UTC, NGupton98
no flags Details
File: namespaces (102 bytes, text/plain)
2017-07-30 07:27 UTC, NGupton98
no flags Details
File: open_fds (1.04 KB, text/plain)
2017-07-30 07:27 UTC, NGupton98
no flags Details

Description NGupton98 2017-07-30 07:26:53 UTC
Description of problem:
Was trying to update via dnf

Version-Release number of selected component:
dnfdragora-gui-1.0.1-5.git20170505.2a3b056.fc26

Additional info:
reporter:       libreport-2.9.1
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: _on_status_icon_popup_menu
exception_type: AttributeError
executable:     /usr/bin/dnfdragora-updater
kernel:         4.11.10-300.fc26.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
_gtk.py:70:_on_status_icon_popup_menu:AttributeError: 'Icon' object has no attribute '_menu_handle'

Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/pystray/_gtk.py", line 70, in _on_status_icon_popup_menu
    if self._menu_handle:
AttributeError: 'Icon' object has no attribute '_menu_handle'

Local variables in innermost frame:
activate_time: 93986
button: 3
status_icon: <Gtk.StatusIcon object at 0x7f806a747090 (GtkStatusIcon at 0x555e185cae60)>
self: <pystray._gtk.Icon object at 0x7f806a73cb38>

Potential duplicate: bug 1473434

Comment 1 NGupton98 2017-07-30 07:26:58 UTC
Created attachment 1306511 [details]
File: backtrace

Comment 2 NGupton98 2017-07-30 07:26:59 UTC
Created attachment 1306512 [details]
File: cgroup

Comment 3 NGupton98 2017-07-30 07:27:00 UTC
Created attachment 1306513 [details]
File: cpuinfo

Comment 4 NGupton98 2017-07-30 07:27:01 UTC
Created attachment 1306514 [details]
File: environ

Comment 5 NGupton98 2017-07-30 07:27:02 UTC
Created attachment 1306515 [details]
File: mountinfo

Comment 6 NGupton98 2017-07-30 07:27:03 UTC
Created attachment 1306516 [details]
File: namespaces

Comment 7 NGupton98 2017-07-30 07:27:04 UTC
Created attachment 1306517 [details]
File: open_fds

Comment 8 xactivist 2017-07-31 10:04:53 UTC
*** Bug 1476733 has been marked as a duplicate of this bug. ***

Comment 9 Will Watson 2017-08-16 12:13:23 UTC
*** Bug 1482077 has been marked as a duplicate of this bug. ***

Comment 10 Anoop Nair 2017-08-20 16:54:22 UTC
*** Bug 1483337 has been marked as a duplicate of this bug. ***

Comment 11 Peter Hull 2017-08-30 11:10:44 UTC
Similar problem has been detected:

Right click on dnfdragora to update the system

reporter:       libreport-2.9.1
cmdline:        /usr/bin/python3 /bin/dnfdragora-updater
crash_function: _on_status_icon_popup_menu
exception_type: AttributeError
executable:     /bin/dnfdragora-updater
kernel:         4.12.5-300.fc26.x86_64
package:        dnfdragora-gui-1.0.1-5.git20170505.2a3b056.fc26
reason:         _gtk.py:70:_on_status_icon_popup_menu:AttributeError: 'Icon' object has no attribute '_menu_handle'
runlevel:       N 5
type:           Python3
uid:            1000

Comment 12 al morris 2017-09-05 03:25:44 UTC
*** Bug 1488286 has been marked as a duplicate of this bug. ***

Comment 13 Jonathon Poppleton 2017-09-26 11:57:57 UTC
*** Bug 1495781 has been marked as a duplicate of this bug. ***

Comment 14 Paulo H Caldas 2017-10-18 22:08:37 UTC
Similar problem has been detected:

Ao ligar o sistema e efetuar o longin, está me mostrando o erro de fechamento inesperado do dnfdragora. 

reporter:       libreport-2.9.1
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: _on_status_icon_popup_menu
exception_type: AttributeError
executable:     /usr/bin/dnfdragora-updater
kernel:         4.13.5-200.fc26.x86_64
package:        dnfdragora-gui-1.0.1-5.git20170505.2a3b056.fc26
reason:         _gtk.py:70:_on_status_icon_popup_menu:AttributeError: 'Icon' object has no attribute '_menu_handle'
runlevel:       N 5
type:           Python3
uid:            1000

Comment 15 Vardan Gevorgyan 2017-10-23 06:49:52 UTC
*** Bug 1505248 has been marked as a duplicate of this bug. ***

Comment 16 Jean-Philippe 2017-11-01 18:53:17 UTC
*** Bug 1508604 has been marked as a duplicate of this bug. ***

Comment 17 Paulim_hed 2017-11-03 00:11:37 UTC
*** Bug 1509089 has been marked as a duplicate of this bug. ***

Comment 18 David Poulsen 2017-11-14 12:13:21 UTC
Similar problem has been detected:

Updates pending

reporter:       libreport-2.9.1
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: _on_status_icon_popup_menu
exception_type: AttributeError
executable:     /usr/bin/dnfdragora-updater
kernel:         4.13.10-200.fc26.x86_64
package:        dnfdragora-gui-1.0.1-5.git20170505.2a3b056.fc26
reason:         _gtk.py:70:_on_status_icon_popup_menu:AttributeError: 'Icon' object has no attribute '_menu_handle'
runlevel:       N 5
type:           Python3
uid:            1001

Comment 19 ssabchew 2017-11-15 12:44:07 UTC
*** Bug 1513458 has been marked as a duplicate of this bug. ***

Comment 20 miklos.karoly 2017-12-03 07:27:28 UTC
*** Bug 1520111 has been marked as a duplicate of this bug. ***

Comment 21 Fedora Update System 2017-12-29 23:21:32 UTC
dnfdaemon-0.3.18-5.fc27 dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-d66bd84f06

Comment 22 Fedora Update System 2017-12-29 23:26:54 UTC
dnfdaemon-0.3.18-5.fc26 dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-8caadb4a1b

Comment 23 Fedora Update System 2017-12-30 19:53:45 UTC
dnfdaemon-0.3.18-5.fc27, dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-d66bd84f06

Comment 24 Fedora Update System 2017-12-30 20:39:32 UTC
dnfdaemon-0.3.18-5.fc26, dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-8caadb4a1b

Comment 25 Fedora Update System 2017-12-31 21:27:20 UTC
dnfdaemon-0.3.18-5.fc27, dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 26 Fedora Update System 2018-01-01 22:10:57 UTC
dnfdaemon-0.3.18-5.fc26, dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.