Bug 1520111 - [abrt] dnfdragora-gui: _on_status_icon_popup_menu(): _gtk.py:70:_on_status_icon_popup_menu:AttributeError: 'Icon' object has no attribute '_menu_handle'
Summary: [abrt] dnfdragora-gui: _on_status_icon_popup_menu(): _gtk.py:70:_on_status_ic...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnfdragora
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Björn 'besser82' Esser
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:636dff394eb900736b57839dfe6...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-03 07:23 UTC by miklos.karoly
Modified: 2018-01-01 22:15 UTC (History)
4 users (show)

Fixed In Version: dnfdragora-1.0.1-8.git20171229.24e4647.fc27 dnfdragora-1.0.1-8.git20171229.24e4647.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-31 21:32:19 UTC


Attachments (Terms of Use)
File: backtrace (531 bytes, text/plain)
2017-12-03 07:23 UTC, miklos.karoly
no flags Details
File: cgroup (289 bytes, text/plain)
2017-12-03 07:23 UTC, miklos.karoly
no flags Details
File: cpuinfo (933 bytes, text/plain)
2017-12-03 07:23 UTC, miklos.karoly
no flags Details
File: environ (1.20 KB, text/plain)
2017-12-03 07:23 UTC, miklos.karoly
no flags Details
File: mountinfo (3.47 KB, text/plain)
2017-12-03 07:23 UTC, miklos.karoly
no flags Details
File: namespaces (129 bytes, text/plain)
2017-12-03 07:23 UTC, miklos.karoly
no flags Details
File: open_fds (1.10 KB, text/plain)
2017-12-03 07:23 UTC, miklos.karoly
no flags Details

Description miklos.karoly 2017-12-03 07:23:38 UTC
Description of problem:
No idea what exactly happened, I'm not even convinced that this is a bug. It was the first boot after a F27->rawhide upgrade. After I logged in to the LXDE environment, opened a terminal, entered 'su -', then 'dnf clean all ; dnf update'. The output was the following:

[root@pfed01 log]# dnf clean all ; dnf update
52 files removed
Waiting for process with pid 1757 to finish.
^CKeyboardInterrupt: Terminated.
[root@pfed01 log]# ^C
[root@pfed01 log]# ps -ef | grep 1757
root      1757     1 20 08:08 ?        00:00:14 /usr/bin/python3 /usr/share/dnfdaemon/dnfdaemon-system
root      1814  1768  0 08:09 pts/0    00:00:00 grep --color=auto 1757
[root@pfed01 log]# 

As you can see, I terminated it with ctrl+C after 3-5 seconds, then nearly the same time I checked what is 1757, the ABRT message popped up.

Version-Release number of selected component:
dnfdragora-gui-1.0.1-6.git20170505.2a3b056.fc27

Additional info:
reporter:       libreport-2.9.3
cmdline:        /usr/bin/python3 /bin/dnfdragora-updater
crash_function: _on_status_icon_popup_menu
exception_type: AttributeError
executable:     /bin/dnfdragora-updater
kernel:         4.15.0-0.rc1.git3.1.fc28.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
_gtk.py:70:_on_status_icon_popup_menu:AttributeError: 'Icon' object has no attribute '_menu_handle'

Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/pystray/_gtk.py", line 70, in _on_status_icon_popup_menu
    if self._menu_handle:
AttributeError: 'Icon' object has no attribute '_menu_handle'

Local variables in innermost frame:
activate_time: 170839
button: 3
status_icon: <Gtk.StatusIcon object at 0x7f01014c4318 (GtkStatusIcon at 0x556193c2b9c0)>
self: <pystray._gtk.Icon object at 0x7f01014b9f98>

Potential duplicate: bug 1476549

Comment 1 miklos.karoly 2017-12-03 07:23:44 UTC
Created attachment 1362167 [details]
File: backtrace

Comment 2 miklos.karoly 2017-12-03 07:23:45 UTC
Created attachment 1362168 [details]
File: cgroup

Comment 3 miklos.karoly 2017-12-03 07:23:47 UTC
Created attachment 1362169 [details]
File: cpuinfo

Comment 4 miklos.karoly 2017-12-03 07:23:49 UTC
Created attachment 1362171 [details]
File: environ

Comment 5 miklos.karoly 2017-12-03 07:23:50 UTC
Created attachment 1362172 [details]
File: mountinfo

Comment 6 miklos.karoly 2017-12-03 07:23:52 UTC
Created attachment 1362173 [details]
File: namespaces

Comment 7 miklos.karoly 2017-12-03 07:23:53 UTC
Created attachment 1362174 [details]
File: open_fds

Comment 8 miklos.karoly 2017-12-03 07:27:28 UTC
this is clearly a duplicate of 1476549, it should be closed.

*** This bug has been marked as a duplicate of bug 1476549 ***

Comment 9 Fedora Update System 2017-12-30 00:19:06 UTC
dnfdaemon-0.3.18-5.fc27 dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-d66bd84f06

Comment 10 Fedora Update System 2017-12-30 00:20:56 UTC
dnfdaemon-0.3.18-5.fc26 dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-8caadb4a1b

Comment 11 Fedora Update System 2017-12-30 19:58:16 UTC
dnfdaemon-0.3.18-5.fc27, dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-d66bd84f06

Comment 12 Fedora Update System 2017-12-30 20:44:10 UTC
dnfdaemon-0.3.18-5.fc26, dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-8caadb4a1b

Comment 13 Fedora Update System 2017-12-31 21:32:19 UTC
dnfdaemon-0.3.18-5.fc27, dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2018-01-01 22:15:44 UTC
dnfdaemon-0.3.18-5.fc26, dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.