Bug 1476834 - [abrt] dnf: arch(): config.py:908:arch:TypeError: unhashable type: 'list'
Summary: [abrt] dnf: arch(): config.py:908:arch:TypeError: unhashable type: 'list'
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf   
(Show other bugs)
Version: 26
Hardware: x86_64 Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaroslav Mracek
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:c940fdbaadf6cbb548b5eafaf42...
Keywords: Reopened, Triaged
: 1477261 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-07-31 14:51 UTC by Sandro Bonazzola
Modified: 2017-10-04 22:25 UTC (History)
7 users (show)

Fixed In Version: dnf-2.6.3-1.fc26 dnf-2.7.2-1.fc27 dnf-2.7.2-1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-04 14:23:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: _var_log_dnf.log (172.46 KB, text/plain)
2017-07-31 14:51 UTC, Sandro Bonazzola
no flags Details
File: _var_tmp_dnf-sbonazzo-u3ek1c9m_dnf.log (832.43 KB, text/plain)
2017-07-31 14:52 UTC, Sandro Bonazzola
no flags Details
File: _var_tmp_dnf-sbonazzo-u3ek1c9m_dnf.rpm.log (7.96 KB, text/plain)
2017-07-31 14:52 UTC, Sandro Bonazzola
no flags Details
File: _var_tmp_dnf-sbonazzo-u3ek1c9m_hawkey.log (865.45 KB, text/plain)
2017-07-31 14:52 UTC, Sandro Bonazzola
no flags Details
File: backtrace (1.07 KB, text/plain)
2017-07-31 14:52 UTC, Sandro Bonazzola
no flags Details
File: cgroup (355 bytes, text/plain)
2017-07-31 14:52 UTC, Sandro Bonazzola
no flags Details
File: cpuinfo (1.35 KB, text/plain)
2017-07-31 14:52 UTC, Sandro Bonazzola
no flags Details
File: dnf-makecache.log (259 bytes, text/plain)
2017-07-31 14:52 UTC, Sandro Bonazzola
no flags Details
File: environ (3.98 KB, text/plain)
2017-07-31 14:52 UTC, Sandro Bonazzola
no flags Details
File: mountinfo (3.66 KB, text/plain)
2017-07-31 14:52 UTC, Sandro Bonazzola
no flags Details
File: namespaces (102 bytes, text/plain)
2017-07-31 14:52 UTC, Sandro Bonazzola
no flags Details
File: open_fds (498 bytes, text/plain)
2017-07-31 14:52 UTC, Sandro Bonazzola
no flags Details
File: _var_tmp_dnf-sbonazzo-u3ek1c9m_dnf.librepo.log (12.68 MB, text/plain)
2017-07-31 14:56 UTC, Sandro Bonazzola
no flags Details

Description Sandro Bonazzola 2017-07-31 14:51:44 UTC
Description of problem:
Running dnf --refresh --arch=ppc64le repoclosure \
    --repofrompath=41candidate,https://cbs.centos.org/repos/virt7-ovirt-41-candidate/ppc64le/os/ --check=41candidate \
    --repofrompath=common_candidate,https://cbs.centos.org/repos/virt7-ovirt-common-candidate/ppc64le/os --check=common_candidate \
    --repofrompath=base_ppc,http://mirror.centos.org/altarch/7/os/ppc64le/ --repo=base_ppc \
    --repofrompath=extra_ppc,http://mirror.centos.org/altarch/7/extras/ppc64le/ --repo=extra_ppc \
    --repofrompath=c7updates_ppc,http://mirror.centos.org/altarch/7/updates/ppc64le/ --repo=c7updates_ppc \
    --repofrompath=qemu,https://cbs.centos.org/repos/virt7-kvm-common-candidate/ppc64le/os/ --check=qemu \
    --repofrompath=fluent,https://cbs.centos.org/repos/opstools7-fluentd-012-candidate/ppc64le/os/ --repo=fluent \
    --repofrompath=gluster,https://cbs.centos.org/repos/storage7-gluster-38-candidate/ppc64le/os/ --repo=gluster \
    --repofrompath=collectd,https://cbs.centos.org/repos/opstools7-perfmon-common-candidate/ppc64le/os/ --repo=collectd

from fc26 on x86_64.

Version-Release number of selected component:
dnf-2.6.2-1.fc26

Additional info:
reporter:       libreport-2.9.1
cmdline:        /usr/libexec/system-python /usr/bin/dnf --refresh --arch=ppc64le repoclosure --repofrompath=41candidate,https://cbs.centos.org/repos/virt7-ovirt-41-candidate/ppc64le/os/ --check=41candidate --repofrompath=common_candidate,https://cbs.centos.org/repos/virt7-ovirt-common-candidate/ppc64le/os --check=common_candidate --repofrompath=base_ppc,http://mirror.centos.org/altarch/7/os/ppc64le/ --repo=base_ppc --repofrompath=extra_ppc,http://mirror.centos.org/altarch/7/extras/ppc64le/ --repo=extra_ppc --repofrompath=c7updates_ppc,http://mirror.centos.org/altarch/7/updates/ppc64le/ --repo=c7updates_ppc --repofrompath=qemu,https://cbs.centos.org/repos/virt7-kvm-common-candidate/ppc64le/os/ --check=qemu --repofrompath=fluent,https://cbs.centos.org/repos/opstools7-fluentd-012-candidate/ppc64le/os/ --repo=fluent --repofrompath=gluster,https://cbs.centos.org/repos/storage7-gluster-38-candidate/ppc64le/os/ --repo=gluster --repofrompath=collectd,https://cbs.centos.org/repos/opstools7-perfmon-common-candidate/ppc64le/os/ --repo=collectd
crash_function: arch
exception_type: TypeError
executable:     /usr/bin/dnf
kernel:         4.11.11-300.fc26.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
config.py:908:arch:TypeError: unhashable type: 'list'

Traceback (most recent call last):
  File "/usr/bin/dnf", line 58, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.6/site-packages/dnf/cli/main.py", line 179, in user_main
    errcode = main(args)
  File "/usr/lib/python3.6/site-packages/dnf/cli/main.py", line 64, in main
    return _main(base, args, cli_class, option_parser_class)
  File "/usr/lib/python3.6/site-packages/dnf/cli/main.py", line 95, in _main
    cli.configure(list(map(ucd, args)), option_parser())
  File "/usr/lib/python3.6/site-packages/dnf/cli/cli.py", line 909, in configure
    self.base.conf._configure_from_options(opts)
  File "/usr/lib/python3.6/site-packages/dnf/conf/config.py", line 843, in _configure_from_options
    setattr(self, name, value)
  File "/usr/lib/python3.6/site-packages/dnf/conf/config.py", line 908, in arch
    assert(val in dnf.rpm._BASEARCH_MAP.keys())
TypeError: unhashable type: 'list'

Local variables in innermost frame:
val: ['ppc64le']
self: <dnf.conf.config.MainConf object at 0x7fb4336b55c0>

Comment 1 Sandro Bonazzola 2017-07-31 14:51:55 UTC
Created attachment 1307119 [details]
File: _var_log_dnf.log

Comment 2 Sandro Bonazzola 2017-07-31 14:52:10 UTC
Created attachment 1307120 [details]
File: _var_tmp_dnf-sbonazzo-u3ek1c9m_dnf.log

Comment 3 Sandro Bonazzola 2017-07-31 14:52:12 UTC
Created attachment 1307121 [details]
File: _var_tmp_dnf-sbonazzo-u3ek1c9m_dnf.rpm.log

Comment 4 Sandro Bonazzola 2017-07-31 14:52:28 UTC
Created attachment 1307122 [details]
File: _var_tmp_dnf-sbonazzo-u3ek1c9m_hawkey.log

Comment 5 Sandro Bonazzola 2017-07-31 14:52:29 UTC
Created attachment 1307123 [details]
File: backtrace

Comment 6 Sandro Bonazzola 2017-07-31 14:52:31 UTC
Created attachment 1307124 [details]
File: cgroup

Comment 7 Sandro Bonazzola 2017-07-31 14:52:32 UTC
Created attachment 1307125 [details]
File: cpuinfo

Comment 8 Sandro Bonazzola 2017-07-31 14:52:34 UTC
Created attachment 1307126 [details]
File: dnf-makecache.log

Comment 9 Sandro Bonazzola 2017-07-31 14:52:36 UTC
Created attachment 1307127 [details]
File: environ

Comment 10 Sandro Bonazzola 2017-07-31 14:52:37 UTC
Created attachment 1307128 [details]
File: mountinfo

Comment 11 Sandro Bonazzola 2017-07-31 14:52:39 UTC
Created attachment 1307129 [details]
File: namespaces

Comment 12 Sandro Bonazzola 2017-07-31 14:52:40 UTC
Created attachment 1307130 [details]
File: open_fds

Comment 13 Sandro Bonazzola 2017-07-31 14:56:16 UTC
Created attachment 1307145 [details]
File: _var_tmp_dnf-sbonazzo-u3ek1c9m_dnf.librepo.log

Comment 14 Daniel Mach 2017-08-02 11:09:55 UTC
*** Bug 1477261 has been marked as a duplicate of this bug. ***

Comment 15 Jaroslav Mracek 2017-08-02 14:28:55 UTC
I created two patches (https://github.com/rpm-software-management/dnf/pull/883 and https://github.com/rpm-software-management/dnf-plugins-core/pull/230) that should solve the problem.

Comment 16 Fedora Update System 2017-08-07 12:50:27 UTC
dnf-2.6.3-1.fc26 dnf-plugins-extras-2.0.2-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-4813633f96

Comment 17 Fedora Update System 2017-08-08 01:24:24 UTC
dnf-2.6.3-1.fc26, dnf-plugins-extras-2.0.2-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-4813633f96

Comment 18 Fedora Update System 2017-08-09 15:59:46 UTC
dnf-2.6.3-1.fc26, dnf-plugins-extras-2.0.2-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2017-10-02 10:33:49 UTC
dnf-plugins-extras-2.0.3-1.fc27 dnf-plugins-core-2.1.4-1.fc27 dnf-2.7.2-1.fc27 libdnf-0.10.1-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-faf235c683

Comment 20 Fedora Update System 2017-10-02 10:37:32 UTC
dnf-plugins-extras-2.0.3-1.fc26 dnf-plugins-core-2.1.4-1.fc26 dnf-2.7.2-1.fc26 libdnf-0.10.1-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-70a8618065

Comment 21 Fedora Update System 2017-10-02 20:28:17 UTC
dnf-2.7.2-1.fc26, dnf-plugins-core-2.1.4-1.fc26, dnf-plugins-extras-2.0.3-1.fc26, libdnf-0.10.1-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-70a8618065

Comment 22 Fedora Update System 2017-10-02 21:27:36 UTC
dnf-2.7.2-1.fc27, dnf-plugins-core-2.1.4-1.fc27, dnf-plugins-extras-2.0.3-1.fc27, libdnf-0.10.1-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-faf235c683

Comment 23 Fedora Update System 2017-10-04 14:23:10 UTC
dnf-2.7.2-1.fc27, dnf-plugins-core-2.1.4-1.fc27, dnf-plugins-extras-2.0.3-1.fc27, libdnf-0.10.1-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 24 Fedora Update System 2017-10-04 22:25:15 UTC
dnf-2.7.2-1.fc26, dnf-plugins-core-2.1.4-1.fc26, dnf-plugins-extras-2.0.3-1.fc26, libdnf-0.10.1-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.