Bug 1477261 - [abrt] dnf: arch(): config.py:908:arch:AssertionError
[abrt] dnf: arch(): config.py:908:arch:AssertionError
Status: CLOSED DUPLICATE of bug 1476834
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
26
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: rpm-software-management
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:4040626493792e6616040a16d0d...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-01 11:07 EDT by Zbigniew Jędrzejewski-Szmek
Modified: 2017-08-02 07:09 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-02 07:09:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: _var_log_dnf.log (592.19 KB, text/plain)
2017-08-01 11:07 EDT, Zbigniew Jędrzejewski-Szmek
no flags Details
File: backtrace (1.03 KB, text/plain)
2017-08-01 11:07 EDT, Zbigniew Jędrzejewski-Szmek
no flags Details
File: cgroup (385 bytes, text/plain)
2017-08-01 11:07 EDT, Zbigniew Jędrzejewski-Szmek
no flags Details
File: cpuinfo (1.17 KB, text/plain)
2017-08-01 11:07 EDT, Zbigniew Jędrzejewski-Szmek
no flags Details
File: dnf-makecache.log (570.43 KB, text/plain)
2017-08-01 11:07 EDT, Zbigniew Jędrzejewski-Szmek
no flags Details
File: environ (4.06 KB, text/plain)
2017-08-01 11:07 EDT, Zbigniew Jędrzejewski-Szmek
no flags Details
File: mountinfo (4.28 KB, text/plain)
2017-08-01 11:07 EDT, Zbigniew Jędrzejewski-Szmek
no flags Details
File: namespaces (102 bytes, text/plain)
2017-08-01 11:07 EDT, Zbigniew Jędrzejewski-Szmek
no flags Details
File: open_fds (504 bytes, text/plain)
2017-08-01 11:07 EDT, Zbigniew Jędrzejewski-Szmek
no flags Details

  None (edit)
Description Zbigniew Jędrzejewski-Szmek 2017-08-01 11:07:07 EDT
Description of problem:
"dnf repoquery --disablerepo=\* --enablerepo=fedora-source --arch=src --whatrequires db4-devel"

Version-Release number of selected component:
dnf-2.6.2-1.fc26

Additional info:
reporter:       libreport-2.9.1
cmdline:        /usr/libexec/system-python /usr/bin/dnf repoquery --disablerepo=* --enablerepo=fedora-source --arch=src --whatrequires db4-devel
crash_function: arch
exception_type: AssertionError
executable:     /usr/bin/dnf
kernel:         4.11.9-300.fc26.x86_64
runlevel:       N 5
type:           Python3
uid:            1001

Truncated backtrace:
config.py:908:arch:AssertionError

Traceback (most recent call last):
  File "/usr/bin/dnf", line 58, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.6/site-packages/dnf/cli/main.py", line 179, in user_main
    errcode = main(args)
  File "/usr/lib/python3.6/site-packages/dnf/cli/main.py", line 64, in main
    return _main(base, args, cli_class, option_parser_class)
  File "/usr/lib/python3.6/site-packages/dnf/cli/main.py", line 95, in _main
    cli.configure(list(map(ucd, args)), option_parser())
  File "/usr/lib/python3.6/site-packages/dnf/cli/cli.py", line 909, in configure
    self.base.conf._configure_from_options(opts)
  File "/usr/lib/python3.6/site-packages/dnf/conf/config.py", line 843, in _configure_from_options
    setattr(self, name, value)
  File "/usr/lib/python3.6/site-packages/dnf/conf/config.py", line 908, in arch
    assert(val in dnf.rpm._BASEARCH_MAP.keys())
AssertionError

Local variables in innermost frame:
val: 'src'
self: <dnf.conf.config.MainConf object at 0x7fbb67991630>
Comment 1 Zbigniew Jędrzejewski-Szmek 2017-08-01 11:07:15 EDT
Created attachment 1307696 [details]
File: _var_log_dnf.log
Comment 2 Zbigniew Jędrzejewski-Szmek 2017-08-01 11:07:16 EDT
Created attachment 1307697 [details]
File: backtrace
Comment 3 Zbigniew Jędrzejewski-Szmek 2017-08-01 11:07:18 EDT
Created attachment 1307698 [details]
File: cgroup
Comment 4 Zbigniew Jędrzejewski-Szmek 2017-08-01 11:07:19 EDT
Created attachment 1307699 [details]
File: cpuinfo
Comment 5 Zbigniew Jędrzejewski-Szmek 2017-08-01 11:07:21 EDT
Created attachment 1307700 [details]
File: dnf-makecache.log
Comment 6 Zbigniew Jędrzejewski-Szmek 2017-08-01 11:07:22 EDT
Created attachment 1307701 [details]
File: environ
Comment 7 Zbigniew Jędrzejewski-Szmek 2017-08-01 11:07:23 EDT
Created attachment 1307702 [details]
File: mountinfo
Comment 8 Zbigniew Jędrzejewski-Szmek 2017-08-01 11:07:25 EDT
Created attachment 1307703 [details]
File: namespaces
Comment 9 Zbigniew Jędrzejewski-Szmek 2017-08-01 11:07:26 EDT
Created attachment 1307704 [details]
File: open_fds
Comment 10 Daniel Mach 2017-08-02 07:09:55 EDT

*** This bug has been marked as a duplicate of bug 1476834 ***

Note You need to log in before you can comment on or make changes to this bug.