Bug 1476850 - Man page: Make auto.master 's summary findable via 'man -k autofs'
Man page: Make auto.master 's summary findable via 'man -k autofs'
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: autofs (Show other bugs)
7.3
x86_64 Linux
unspecified Severity low
: rc
: ---
Assigned To: Ian Kent
xiaoli feng
:
Depends On:
Blocks: 1568290
  Show dependency treegraph
 
Reported: 2017-07-31 11:22 EDT by Lev Ufimtsev
Modified: 2018-04-17 03:25 EDT (History)
2 users (show)

See Also:
Fixed In Version: autofs-5.0.7-70.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1568290 (view as bug list)
Environment:
Last Closed: 2018-04-10 14:17:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch - fix some man page problems (4.10 KB, patch)
2017-08-01 01:56 EDT, Ian Kent
no flags Details | Diff
Patch - fix typos in autofs man pages (1.45 KB, patch)
2017-10-02 03:07 EDT, Ian Kent
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0977 None None None 2018-04-10 14:18 EDT

  None (edit)
Description Lev Ufimtsev 2017-07-31 11:22:21 EDT
Description of problem:
- Continuation of issue reported in:
https://bugzilla.redhat.com/show_bug.cgi?id=560124

- When you do a 'man -k autofs', then "man 8 auto.master" is not listed. However, auto.master is a very important man page for autofs.

Current summary is:
auto.master (5)      - Master Map for automounter

Proposed (something like:
auto.master (5)      - Master Map for automounter consulted by autofs


Version-Release number of selected component (if applicable):
- RHEL 7.3, Fedora 26

How reproducible:
- "man -k autofs"


Actual results:
auto.master not listed

Expected results:
auto.master listed in results


Additional info:
- I observed this while taking the RHCSA course. Other canidates also had difficulties finding this man page.
Comment 2 Ian Kent 2017-08-01 01:51:18 EDT
This is definitely too late for 7.4.
Comment 3 Ian Kent 2017-08-01 01:56 EDT
Created attachment 1307367 [details]
Patch - fix some man page problems

Upstream patch, will need minor changes for RHEL.
Comment 4 Ian Kent 2017-08-01 02:01:52 EDT
(In reply to Lev Ufimtsev from comment #0)
> Description of problem:
> - Continuation of issue reported in:
> https://bugzilla.redhat.com/show_bug.cgi?id=560124
> 
> - When you do a 'man -k autofs', then "man 8 auto.master" is not listed.
> However, auto.master is a very important man page for autofs.
> 
> Current summary is:
> auto.master (5)      - Master Map for automounter
> 
> Proposed (something like:
> auto.master (5)      - Master Map for automounter consulted by autofs

Yes, I have done this with the above patch plus a couple
of other things.

> 
> 
> Version-Release number of selected component (if applicable):
> - RHEL 7.3, Fedora 26

I will be releasing autofs-5.1.4 fairly soon, it will
include this change. And I plan on upgrading the supported
Fedora releases when I do the upstream release.

Ian
Comment 5 Lev Ufimtsev 2017-08-01 10:30:00 EDT
Kewl
Comment 6 Ian Kent 2017-10-02 03:07 EDT
Created attachment 1333106 [details]
Patch - fix typos in autofs man pages

While we are at it.
Comment 7 Lev Ufimtsev 2017-10-03 10:19:11 EDT
Thanks for looking into this.
Comment 8 xiaoli feng 2017-10-10 04:38:05 EDT
Hello Ian,

  The config file /etc/sysconfig/autofs isn't also shown in "man -k autofs". Is it expected?
Comment 10 Ian Kent 2017-10-10 05:50:24 EDT
(In reply to xiaoli feng from comment #8)
> Hello Ian,
> 
>   The config file /etc/sysconfig/autofs isn't also shown in "man -k autofs".
> Is it expected?

I would say so as /etc/sysconfig/autofs isn't the configuration
file any more, it's now /etc/autofs.conf.

While the format looks a bit different to what is used in
/etc/sysconfig/autofs anything in their for equivalent config.
settings will override what is in /etc/autofs.conf for backward
compatibility.

But we should always be referring to /etc/autofs.conf as "the"
autofs configuration file now.

Ian
Comment 15 errata-xmlrpc 2018-04-10 14:17:12 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0977

Note You need to log in before you can comment on or make changes to this bug.