Bug 1477021 - [3.2] installer failed at "Grant the user access to the appropriate scc" task with ansible-2.3.1.0-3.el7.noarch
[3.2] installer failed at "Grant the user access to the appropriate scc" task...
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.2.1
Unspecified Unspecified
high Severity high
: ---
: 3.2.1
Assigned To: Scott Dodson
Gaoyun Pei
:
Depends On:
Blocks: 1477804
  Show dependency treegraph
 
Reported: 2017-08-01 01:39 EDT by Johnny Liu
Modified: 2017-08-16 03:59 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
A compatibility issue with Ansible 2.3 has been corrected.
Story Points: ---
Clone Of:
: 1477804 (view as bug list)
Environment:
Last Closed: 2017-08-16 03:59:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2482 normal SHIPPED_LIVE OpenShift Container Platform atomic-openshift-utils bug fix and enhancement 2017-08-16 07:58:57 EDT

  None (edit)
Description Johnny Liu 2017-08-01 01:39:09 EDT
Description of problem:
3.2 installer does not work with ansible 2.3

Version-Release number of the following components:
ansible-2.3.1.0-3.el7.noarch
openshift-ansible-3.2.61-1.git.0.4bf0fd2.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1. Prepare an inventory host file
2. install ansible-2.3.1.0-3.el7.noarch and openshift-ansible-3.2.61-1.git.0.4bf0fd2.el7.noarch
3. Trigger installation

Actual results:
TASK [openshift_serviceaccounts : Grant the user access to the appropriate scc] ***
Monday 31 July 2017  22:51:42 +0000 (0:00:01.106)       0:14:51.594 *********** 
 [WARNING]: when statements should not include jinja2 templating delimiters
such as {{ }} or {% %}. Found: {{ openshift.common.version_gte_3_2_or_1_2 }}

 [WARNING]: when statements should not include jinja2 templating delimiters
such as {{ }} or {% %}. Found: openshift.common.version_gte_3_1_or_1_1 and
item.1.rc == 0 and 'system:serviceaccount:{{
openshift_serviceaccounts_namespace }}:{{ item.0 }}' not in {{ (item.1.stdout |
from_yaml).users | default([]) }}

fatal: [openshift-125.lab.sjc.redhat.com]: FAILED! => {"failed": true, "msg": "The conditional check 'openshift.common.version_gte_3_1_or_1_1 and item.1.rc == 0 and 'system:serviceaccount:{{ openshift_serviceaccounts_namespace }}:{{ item.0 }}' not in {{ (item.1.stdout | from_yaml).users | default([]) }}' failed. The error was: Invalid conditional detected: invalid syntax (<unknown>, line 1)\n\nThe error appears to have been in '/home/slave3/workspace/Launch Environment Flexy/private-openshift-ansible/roles/openshift_serviceaccounts/tasks/main.yml': line 27, column 3, but may\nbe elsewhere in the file depending on the exact syntax problem.\n\nThe offending line appears to be:\n\n\n- name: Grant the user access to the appropriate scc\n  ^ here\n"}

Expected results:
3.2 installer should work fine with ansible 2.3.

Additional info:
downgrade ansible 2.3 to 2.2 (ansible-2.2.3.0-1.el7.noarch), installation is passed.
Comment 5 Gaoyun Pei 2017-08-09 04:29:35 EDT
Verify this bug with openshift-ansible-3.2.63-1.git.0.a21de5e.el7.noarch.rpm & ansible-2.3.1.0-3.el7.noarch.

No issue found in ocp-3.2 installation.
Comment 7 errata-xmlrpc 2017-08-16 03:59:16 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2482

Note You need to log in before you can comment on or make changes to this bug.