Bug 1477132 - [trello zoxUAO2w] no copy/paste on right-click menu for Debug Terminal
Summary: [trello zoxUAO2w] no copy/paste on right-click menu for Debug Terminal
Keywords:
Status: CLOSED DUPLICATE of bug 1278733
Alias: None
Product: OKD
Classification: Red Hat
Component: Management Console
Version: 3.x
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: ---
Assignee: Samuel Padgett
QA Contact: XiaochuanWang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-01 10:08 UTC by shahan
Modified: 2017-11-01 18:02 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-01 18:02:40 UTC
Target Upstream Version:


Attachments (Terms of Use)
right_border_goes_outside (70.04 KB, image/png)
2017-09-20 09:03 UTC, Xingxing Xia
no flags Details

Description shahan 2017-08-01 10:08:40 UTC
Description of problem:
  no copy/paste button on Right-click menu for Debug Terminal, OCP 3.6 has copy/paste buttons in right-click.

Version-Release number of selected component (if applicable):
  OpenShift Master:v3.6.0-rc.0+3994e0b-376
  Kubernetes Master:v1.7.0+695f48a16f 

How reproducible:
Always

Steps to Reproduce:
1 Login in web console, create crashing pod 
oc run run-once-pod --image=openshift/origin --command=true ls /abcd --restart=Never
2.On the crashing pod page, click Debug Terminal Link
3.Check Debug terminal 

Actual results:
 no copy/paste button on Right-click menu

Expected results:
 Should have these two button for copy/paste.

Additional info:
 target release:v3.7.0

Comment 1 Xingxing Xia 2017-09-20 09:03:15 UTC
Created attachment 1328332 [details]
right_border_goes_outside

Checked in v3.7.0-0.126.4. Comment 0's bug still exist. Besides, a new issue comes - the debug terminal's right border goes outside (only FF and Chrome are checked), see screenshot

Comment 2 Samuel Padgett 2017-09-20 12:09:41 UTC
> Created attachment 1328332 [details]
> right_border_goes_outside
> 
> Checked in v3.7.0-0.126.4. Comment 0's bug still exist. Besides, a new issue
> comes - the debug terminal's right border goes outside (only FF and Chrome
> are checked), see screenshot

Please open a separate bug for this since it's an unrelated problem. I ask because the original bug will probably require a fix in the upstream xterm.js dependency, whereas the new problem won't. It will be easier to track what is fixed and when if they are different bugs.

I'm moving this back to the original low severity since the new problem will be tracked separately.

Comment 3 Xingxing Xia 2017-09-21 02:05:29 UTC
Reasonable. Separate bug 1493827 is filed

Comment 4 Jessica Forrester 2017-11-01 18:02:40 UTC
This is the same underlying issue as bug 1278733

*** This bug has been marked as a duplicate of bug 1278733 ***


Note You need to log in before you can comment on or make changes to this bug.