Bug 1477569 - [REST] - It's impossible to add a network with characters in the range between 50 to 256 because that vNIC profile limited to 50 character
[REST] - It's impossible to add a network with characters in the range betwee...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network (Show other bugs)
4.2.0
x86_64 Linux
high Severity high (vote)
: ovirt-4.1.6
: ---
Assigned To: Leon Goldberg
Michael Burman
:
Depends On:
Blocks: 1458407
  Show dependency treegraph
 
Reported: 2017-08-02 07:59 EDT by Ori Ben Sasson
Modified: 2017-09-19 06:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-19 06:01:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.1+


Attachments (Terms of Use)
engine log (1.71 MB, application/zip)
2017-08-02 08:03 EDT, Ori Ben Sasson
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 80220 master MERGED packaging: dbscripts: Increase vnic_profile's name column to 256 bytes. 2017-08-17 04:43 EDT
oVirt gerrit 80811 ovirt-engine-4.1 MERGED packaging: dbscripts: Increase vnic_profile's name column to 256 bytes. 2017-08-21 04:02 EDT

  None (edit)
Description Ori Ben Sasson 2017-08-02 07:59:04 EDT
Description of problem:
It's impossible to add a network with characters in the range between 50 to 256 because that vNIC profile limited to 50 character.

I get an error from engine log 
ERROR: value too long for type character varying(50)


Version-Release number of selected component (if applicable):
ovirt-engine-4.2.0-0.0.master.20170801132145.git3e12cf0.el7.centos.noarch

How reproducible:
100

Steps to Reproduce:
1. Create a network name in the range between 50 to 256 characters via REST

Actual results:
Failed to add network with vNIC profile that the name is greater than 50 characters 

Expected results:
Should work as expected
Comment 1 Ori Ben Sasson 2017-08-02 08:03 EDT
Created attachment 1308160 [details]
engine log
Comment 3 Meni Yakove 2017-08-28 04:42:59 EDT
From time to time the vNIC profile failed to create automatically when creating the network with special characters.
Comment 4 Leon Goldberg 2017-08-28 05:09:41 EDT

(In reply to Meni Yakove from comment #3)
> From time to time the vNIC profile failed to create automatically when
> creating the network with special characters.

That is irrelevant to this patch. The profiles aren't created with short names as well. vNIC profiles are no longer limited to 50/ascii characters, so the bug is essentially solved IMO.


Another separate bug should be opened for what you've described (so far I can't reproduce the problem. I've tried several computers, but I'll keep investigating)
Comment 5 Michael Burman 2017-08-28 07:24:58 EDT
Even if not relevant to the patch. This can't be tested when sometimes the vNIC created or not. Will be tested only when we will have a fix to the vNIC profile creation. The verification of the this bug depends on the separate bug.
Comment 6 Dan Kenigsberg 2017-08-29 11:16:16 EDT
This bug can be tested by QA; if you are verifying this now, please note that the network name must be alphanumeric until bug 1485928 is ON_QA as well, and keyboard is used to confirm network creation (bug 1485927)
Comment 7 Michael Burman 2017-08-30 04:34:02 EDT
Verified on - 4.1.6-0.1.el7

Note You need to log in before you can comment on or make changes to this bug.