Bug 1458407 - [RFE] Logical Network name length needs to be 256 bytes
Summary: [RFE] Logical Network name length needs to be 256 bytes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: ovirt-4.2.0
: ---
Assignee: Leon Goldberg
QA Contact: Michael Burman
URL:
Whiteboard:
Depends On: 1477161 1477569 1478717 1478790 1483295
Blocks: 1477204
TreeView+ depends on / blocked
 
Reported: 2017-06-02 18:50 UTC by nenduri
Modified: 2019-05-16 13:06 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1477204 (view as bug list)
Environment:
Last Closed: 2018-05-15 17:43:21 UTC
oVirt Team: Network
Target Upstream Version:
gklein: testing_plan_complete+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:1488 0 None None None 2018-05-15 17:45:04 UTC
oVirt gerrit 79116 0 None MERGED backend: remove character restrictions from network names 2020-07-01 00:47:04 UTC
oVirt gerrit 79459 0 None MERGED frontned: remove ui network name/vnic profile restrictions 2020-07-01 00:47:04 UTC
oVirt gerrit 79971 0 None MERGED core: AddEmptyStoragePoolCommand: set vdsmName to default network 2020-07-01 00:47:03 UTC

Description nenduri 2017-06-02 18:50:01 UTC
Description of problem:

Current maximum logical network name length is 15 characters.

Typical Cisco ACI logical network names are much longer than 15 characters. 
It consists of tenant name, application name, and end point group name.
We need to support 256 characters long.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Yaniv Lavi 2017-06-07 15:14:33 UTC
Is this for external network or any network?

Comment 2 nenduri 2017-06-07 17:56:16 UTC
(In reply to Yaniv Lavi from comment #1)
> Is this for external network or any network?

We need this change for any network. 

we use internal networks in phase 1 and we plan to use external networks (without any network plumbing on rhev host) in phase 2.

Comment 3 Dan Kenigsberg 2017-06-18 12:40:38 UTC
Can you provide a sample network name? We consider whether we want to support unrestricted network names or to keep our current limitations on character types. (keeping the limitation may simplify and haste our implementation a bit)

Comment 4 nenduri 2017-06-20 00:02:16 UTC
(In reply to Dan Kenigsberg from comment #3)
> Can you provide a sample network name? We consider whether we want to
> support unrestricted network names or to keep our current limitations on
> character types. (keeping the limitation may simplify and haste our
> implementation a bit)

The ACI network names (EPG names) are in the following format.

TenantName|ApplicationName|EPGName

For example:

Coke|HumanResource|Epg1

The default delimiter is "|". But we do allow configuring delimiter too.

Comment 7 Michael Burman 2017-11-21 08:42:36 UTC
Verified on - 4.2.0-0.5.master.el7

Comment 10 errata-xmlrpc 2018-05-15 17:43:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:1488

Comment 11 Franta Kust 2019-05-16 13:06:09 UTC
BZ<2>Jira Resync


Note You need to log in before you can comment on or make changes to this bug.