Bug 1477574 - RHEL 7.3 -> 7.4 / rdma-core update pulls in 32-bit pkgs on 64-bit
Summary: RHEL 7.3 -> 7.4 / rdma-core update pulls in 32-bit pkgs on 64-bit
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: yum
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Michal Domonkos
QA Contact: Eva Mrakova
URL:
Whiteboard:
Depends On:
Blocks: 1546815 1549618
TreeView+ depends on / blocked
 
Reported: 2017-08-02 12:09 UTC by Marko Myllynen
Modified: 2018-10-30 14:49 UTC (History)
22 users (show)

Fixed In Version: yum-3.4.3-159.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 11:40:23 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3279 None None None 2018-10-30 11:41:17 UTC
Red Hat Bugzilla 488733 None CLOSED With both x86_64 and x86 repos enabled, yum wants to update anaconda.i586, not anaconda.x86_64 2019-04-17 13:35:18 UTC

Internal Links: 488733

Description Marko Myllynen 2017-08-02 12:09:26 UTC
Description of problem:
Blindly updating from RHEL 7.3 to RHEL 7.4 would pull in several 32-bit packages for no reason at all due to rdma.noarch being replaced by rdma-core.{i686,x86_64}.

# yum update
...
 rdma-core                                                        i686                              13-7.el7                                               repo                                      43 k
     replacing  rdma.noarch 7.3_4.7_rc2-6.el7_3
 rdma-core                                                        x86_64                            13-7.el7                                               repo                                      43 k
     replacing  rdma.noarch 7.3_4.7_rc2-6.el7_3

This can be avoided, for example, by doing "yum install rdma-core" first or with something like "yum update --exclude='*.i686'. However, the default is to install unnecessary 32-bit packages on 64-bit hardware which in 2017 is unhelpful.

Please see if rdma packaging could be adjusted to prevent the above. If that is not possible, please reassign to yum/rpm to see if the package manager could do the right thing by default.

Thanks.

Version-Release number of selected component (if applicable):
RHEL 7.3 / rdma-7.3_4.7_rc2-6.el7_3.noarch
RHEL 7.4 / rdma-core.x86_64 0:13-7.el7.x86_64

Comment 2 Jarod Wilson 2017-08-02 13:16:54 UTC
This was already looked into in the 7.4 devel cycle, there's a bug that was used to generate a knowledgebase entry. It's a known issue, and we have no good way around it from the rdma-core side. I'll reassign it to yum to get input there, I guess.

Comment 8 Eva Mrakova 2018-08-07 10:08:30 UTC
Hi Michal,

what behaviour is expected for update and multilib_policy=best when currently installed package is secondary arch (or noarch) and all variants of updates are available (primary, secondary and noarch)? Is it expected to preserve the current arch (e.g. secondary -> secondary) or update to primary arch (e.g. secondary -> primary)?
In yum.conf man page it is described expected behaviour only for installation (not for updating).

Comment 9 Michal Domonkos 2018-08-07 18:33:32 UTC
(In reply to Eva Mrakova from comment #8)
> Is it expected to preserve the current arch (e.g. secondary -> secondary)

Assuming that you're talking about regular (non-obsoleting) updates, then yes, this is what will (and should) happen.

Please note that this patch is supposed to impact obsoletion scenarios _only_ (more specifically, noarch -> arch obsoletions).

Comment 12 errata-xmlrpc 2018-10-30 11:40:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3279


Note You need to log in before you can comment on or make changes to this bug.