Bug 488733 - With both x86_64 and x86 repos enabled, yum wants to update anaconda.i586, not anaconda.x86_64
With both x86_64 and x86 repos enabled, yum wants to update anaconda.i586, no...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
: 488729 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-05 09:50 EST by Tom London
Modified: 2014-01-21 18:08 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-06 01:50:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
outpup of "yum -d7 --enablerepo=11koji32 -x plymouth\* update" (414.86 KB, text/plain)
2009-03-05 10:24 EST, Tom London
no flags Details

  None (edit)
Description Tom London 2009-03-05 09:50:40 EST
Description of problem:
I have a "pure" x86_64 system, but I had 32 bit repo enabled as well.

I have 64bit anaconda:

[root@tlondon ~]# rpm -qa anaconda\*
anaconda-yum-plugins-1.0-4.fc11.noarch
anaconda-11.5.0.23-3.x86_64
[root@tlondon ~]# 

Running with both 64 and 32 bit repos, yum wants to pull in the .i586 version, along with a host of i586 friends.....

[I've now disabled the 32 bit repo.]

[root@tlondon ~]# yum -x plymouth\* updateLoaded plugins: dellsysidplugin2, fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
 * rawhide: mirrors.kernel.org
Excluding Packages in global exclude list
Finished
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package NetworkManager.x86_64 1:0.7.0.99-1.fc11 set to be updated
---> Package NetworkManager-glib.x86_64 1:0.7.0.99-1.fc11 set to be updated
---> Package NetworkManager-gnome.x86_64 1:0.7.0.99-1.fc11 set to be updated
---> Package NetworkManager-vpnc.x86_64 1:0.7.0.99-1.fc11 set to be updated
---> Package anaconda.i586 0:11.5.0.24-3 set to be updated
--> Processing Dependency: python-cryptsetup >= 0.0.6 for package: anaconda
--> Processing Dependency: libblkid.so.1 for package: anaconda
--> Processing Dependency: libc.so.6(GLIBC_2.2.3) for package: anaconda
--> Processing Dependency: libpangocairo-1.0.so.0 for package: anaconda
--> Processing Dependency: libgobject-2.0.so.0 for package: anaconda
--> Processing Dependency: libdbus-1.so.3 for package: anaconda
--> Processing Dependency: libc.so.6(GLIBC_2.1.3) for package: anaconda
--> Processing Dependency: libc.so.6 for package: anaconda
--> Processing Dependency: libiscsi.so.0 for package: anaconda
--> Processing Dependency: libatk-1.0.so.0 for package: anaconda
--> Processing Dependency: libgdk_pixbuf-2.0.so.0 for package: anaconda
--> Processing Dependency: libgdk-x11-2.0.so.0 for package: anaconda
--> Processing Dependency: libXcomposite.so.1 for package: anaconda
--> Processing Dependency: libaudit.so.0 for package: anaconda
--> Processing Dependency: libz.so.1 for package: anaconda
--> Processing Dependency: libselinux.so.1 for package: anaconda
--> Processing Dependency: libc.so.6(GLIBC_2.8) for package: anaconda
--> Processing Dependency: libc.so.6(GLIBC_2.0) for package: anaconda
--> Processing Dependency: libglib-2.0.so.0 for package: anaconda
--> Processing Dependency: libm.so.6(GLIBC_2.0) for package: anaconda
--> Processing Dependency: libnm_glib.so.0 for package: anaconda
--> Processing Dependency: libgtk-x11-2.0.so.0 for package: anaconda
--> Processing Dependency: libsepol.so.1 for package: anaconda
--> Processing Dependency: libX11.so.6 for package: anaconda
--> Processing Dependency: libfontconfig.so.1 for package: anaconda
<<<<<SNIP>>>>>

Disabling the 32bit repo and rerunning I get:

[root@tlondon ~]# yum -x plymouth\* update
Loaded plugins: dellsysidplugin2, fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
 * rawhide: mirrors.kernel.org
Excluding Packages in global exclude list
Finished
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package NetworkManager.x86_64 1:0.7.0.99-1.fc11 set to be updated
---> Package NetworkManager-glib.x86_64 1:0.7.0.99-1.fc11 set to be updated
---> Package NetworkManager-gnome.x86_64 1:0.7.0.99-1.fc11 set to be updated
---> Package NetworkManager-vpnc.x86_64 1:0.7.0.99-1.fc11 set to be updated
---> Package anaconda.x86_64 0:11.5.0.24-3 set to be updated
--> Processing Dependency: python-cryptsetup >= 0.0.6 for package: anaconda
--> Running transaction check
---> Package python-cryptsetup.x86_64 0:0.0.6-1.fc11 set to be updated
--> Processing Conflict: NetworkManager conflicts NetworkManager-pptp < 1:0.7.0.99-1
--> Processing Conflict: NetworkManager conflicts NetworkManager-openvpn < 1:0.7.0.99-1
--> Finished Dependency Resolution
1:NetworkManager-0.7.0.99-1.fc11.x86_64 from 11koji has depsolving problems
  --> NetworkManager conflicts with NetworkManager-pptp
1:NetworkManager-0.7.0.99-1.fc11.x86_64 from 11koji has depsolving problems
  --> NetworkManager conflicts with NetworkManager-openvpn
Error: NetworkManager conflicts with NetworkManager-pptp
Error: NetworkManager conflicts with NetworkManager-openvpn
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
[root@tlondon ~]# 


Version-Release number of selected component (if applicable):
yum-metadata-parser-debuginfo-1.1.2-11.fc11.x86_64
yum-3.2.21-12.fc11.noarch
yum-utils-1.1.20-5.fc11.noarch
yum-plugin-fastestmirror-1.1.20-5.fc11.noarch
yum-metadata-parser-1.1.2-12.fc11.x86_64


How reproducible:
Seems like it....

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 seth vidal 2009-03-05 10:18:00 EST
can you run this test again with the 32bit repo enabled with: yum -d7 ?
Comment 2 Tom London 2009-03-05 10:24:21 EST
Created attachment 334137 [details]
outpup of "yum -d7 --enablerepo=11koji32 -x plymouth\* update"

Here is the output of "yum -d7 --enablerepo=11koji32 -x plymouth\* update "
Comment 3 Tom London 2009-03-05 10:28:05 EST
BTW, I "tripped" across this when I noticed that gnome-panel.x86_64 had pulled in gnome-session-xsession.i586.

I had filed that against gnome-panel: https://bugzilla.redhat.com/show_bug.cgi?id=488729

"Smells the same" to me, though.
Comment 4 seth vidal 2009-03-05 10:54:41 EST
Can you run:

python -c "import rpmUtils.arch; print rpmUtils.arch.getCanonArch()"

and report the output - something is odd
Comment 5 Tom London 2009-03-05 11:49:21 EST
[root@tlondon ~]# python -c "import rpmUtils.arch; print rpmUtils.arch.getCanonArch()"
ia32e
[root@tlondon ~]#
Comment 6 Tom London 2009-03-05 12:01:44 EST
[root@tlondon ~]# grep i586 /var/log/yum.log
Feb 26 15:27:49 Updated: gnome-session-xsession-2.25.91-4.fc11.i586
Mar 03 14:41:01 Updated: gnome-session-xsession-2.25.92-1.fc11.i586
[root@tlondon ~]# 

So this "started" on 26 February.

Here are some items from /var/log/yum.log:

Feb 24 07:10:40 Updated: redhat-rpm-config-9.0.3-7.fc11.noarch
Feb 25 06:37:59 Updated: rpm-libs-4.6.0-9.fc11.x86_64
Feb 25 06:38:09 Updated: rpm-4.6.0-9.fc11.x86_64
Feb 25 06:38:53 Updated: rpm-build-4.6.0-9.fc11.x86_64
Feb 25 06:38:53 Updated: rpm-python-4.6.0-9.fc11.x86_64
Feb 25 06:39:59 Updated: rpm-4.6.0-9.fc11.x86_64
Feb 26 06:30:44 Updated: rpm-libs-4.6.0-10.fc11.x86_64
Feb 26 06:30:51 Updated: rpm-4.6.0-10.fc11.x86_64
Feb 26 06:30:52 Updated: rpm-build-4.6.0-10.fc11.x86_64
Feb 26 06:30:53 Updated: rpm-python-4.6.0-10.fc11.x86_64
Feb 26 06:31:15 Updated: rpm-4.6.0-10.fc11.x86_64


Any of them of possibly interest?
Comment 7 seth vidal 2009-03-05 14:17:51 EST
do you have an /etc/rpm/platform file?

And no - rpm doesn't have anything to do with determining the update set.


With the 32bit repos enabled can you run:

yum list anaconda\*

The reason I'm asking is I can't get anaconda.i586 to ever show up as the update path unless the system is setarch to i686 or i586
Comment 8 Tom London 2009-03-05 14:27:40 EST
No, I don't have an /etc/rpm/platform file:

[tbl@tlondon rpm]$ ls /etc/rpm
macros.dist       macros.imgcreate  macros.prelink
macros.gstreamer  macros.jpackage   macros.qt4
[tbl@tlondon rpm]$ 

[root@tlondon ~]# yum --enablerepo=11koji32 list anaconda\*
Loaded plugins: dellsysidplugin2, fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
 * rawhide: mirrors.kernel.org
Installed Packages
anaconda.x86_64                            11.5.0.23-3                 installed
anaconda-yum-plugins.noarch                1:1.0-4.fc11                installed
Available Packages
anaconda.i586                              11.5.0.24-3                 11koji32 
anaconda.x86_64                            11.5.0.24-3                 11koji   
You have new mail in /var/spool/mail/root
[root@tlondon ~]# 

The first (anaconda-11.5.0.233-3) is bold black, the last (anaconda.11.5.0.24.3) is bold blue.
Comment 9 James Antill 2009-03-05 15:44:05 EST
Something is pretty weird, as I've just created a rawhide32 on my main box and get:

% yum list anaconda
[...]
Installed Packages
anaconda.x86_64                      11.4.1.63-1                   installed
Available Packages
anaconda.i586                        11.5.0.23-3                   rawhide32
anaconda.x86_64                      11.5.0.23-3                   rawhide  

% yum update anaconda
[...]
--> Running transaction check
---> Package anaconda.x86_64 0:11.5.0.23-3 set to be updated
Comment 10 James Antill 2009-03-05 15:52:00 EST
Could you try renaming your repo from 11koji32 to 11kojh32 ... it shouldn't do anything, but it's not a terrible stab in the dark.
Comment 11 James Antill 2009-03-05 16:10:12 EST
What is multilib_policy set to, as the attachment has:

---> Package anaconda.i586 0:11.5.0.24-3 set to be updated
---> Package anaconda.x86_64 0:11.5.0.24-3 set to be updated

...in it, which implies both are trying to be updated to, not just i586. Also what does:

yum list booty

...say?
Comment 12 Tom London 2009-03-05 17:09:56 EST
[root@tlondon ~]# yum list booty
Loaded plugins: dellsysidplugin2, fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
 * rawhide: mirrors.kernel.org
Installed Packages
booty.noarch                       0.108-2.fc11                        installed
[root@tlondon ~]#
Comment 13 Tom London 2009-03-05 17:15:18 EST
changing the name of the repo seems to have no effect: 

[root@tlondon yum.repos.d]# yum --enablerepo=11kojh32 -x plymouth\* update 
Loaded plugins: dellsysidplugin2, fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
 * rawhide: mirrors.kernel.org
11kojh32                                                 | 2.5 kB     00:00     
11kojh32/primary_db                                      | 7.7 MB     01:08     
11koji                                                   | 2.5 kB     00:00     
11koji/primary_db                                        | 7.6 MB     00:58     
Excluding Packages in global exclude list
Finished
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package NetworkManager.x86_64 1:0.7.0.99-1.fc11 set to be updated
---> Package NetworkManager-glib.x86_64 1:0.7.0.99-1.fc11 set to be updated
---> Package NetworkManager-gnome.x86_64 1:0.7.0.99-1.fc11 set to be updated
---> Package NetworkManager-openvpn.x86_64 1:0.7.0.99-1.fc11 set to be updated
---> Package NetworkManager-pptp.x86_64 1:0.7.0.99-1.fc11 set to be updated
---> Package NetworkManager-vpnc.x86_64 1:0.7.0.99-1.fc11 set to be updated
---> Package anaconda.i586 0:11.5.0.24-3 set to be updated
--> Processing Dependency: python-cryptsetup >= 0.0.6 for package: anaconda
--> Processing Dependency: libblkid.so.1 for package: anaconda
--> Processing Dependency: libc.so.6(GLIBC_2.2.3) for package: anaconda
--> Processing Dependency: libpangocairo-1.0.so.0 for package: anaconda
Comment 14 James Antill 2009-03-05 18:30:50 EST
Gah, I wanted to see where noarch packages were comming from ... I thought booty wasn't updated already from the attachment. Can you do "yum list '*.noarch'". And say where the noarch packages are coming from? (don't need to post all the output).
Comment 15 Tom London 2009-03-06 01:20:15 EST
[root@tlondon ~]# yum --enablerepo=11koji32 update lohit\*
Loaded plugins: dellsysidplugin2, fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
 * rawhide: mirror.lib.ucdavis.edu
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package lohit-bengali-fonts.noarch 0:2.3.8-1.fc11 set to be updated
---> Package lohit-fonts-common.noarch 0:2.3.8-1.fc11 set to be updated
---> Package lohit-gujarati-fonts.noarch 0:2.3.8-1.fc11 set to be updated
---> Package lohit-hindi-fonts.noarch 0:2.3.8-1.fc11 set to be updated
---> Package lohit-kannada-fonts.noarch 0:2.3.8-1.fc11 set to be updated
---> Package lohit-maithili-fonts.noarch 0:2.3.8-1.fc11 set to be updated
---> Package lohit-malayalam-fonts.noarch 0:2.3.8-1.fc11 set to be updated
---> Package lohit-marathi-fonts.noarch 0:2.3.8-1.fc11 set to be updated
---> Package lohit-nepali-fonts.noarch 0:2.3.8-1.fc11 set to be updated
---> Package lohit-oriya-fonts.noarch 0:2.3.8-1.fc11 set to be updated
---> Package lohit-punjabi-fonts.noarch 0:2.3.8-1.fc11 set to be updated
---> Package lohit-tamil-fonts.noarch 0:2.3.8-1.fc11 set to be updated
---> Package lohit-telugu-fonts.noarch 0:2.3.8-1.fc11 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                     Arch         Version            Repository    Size
================================================================================
Updating:
 lohit-bengali-fonts         noarch       2.3.8-1.fc11       11koji        73 k
 lohit-fonts-common          noarch       2.3.8-1.fc11       11koji        16 k
 lohit-gujarati-fonts        noarch       2.3.8-1.fc11       11koji        40 k
 lohit-hindi-fonts           noarch       2.3.8-1.fc11       11koji        43 k
 lohit-kannada-fonts         noarch       2.3.8-1.fc11       11koji        51 k
 lohit-maithili-fonts        noarch       2.3.8-1.fc11       11koji        43 k
 lohit-malayalam-fonts       noarch       2.3.8-1.fc11       11koji        35 k
 lohit-marathi-fonts         noarch       2.3.8-1.fc11       11koji        43 k
 lohit-nepali-fonts          noarch       2.3.8-1.fc11       11koji        43 k
 lohit-oriya-fonts           noarch       2.3.8-1.fc11       11koji        52 k
 lohit-punjabi-fonts         noarch       2.3.8-1.fc11       11koji        17 k
 lohit-tamil-fonts           noarch       2.3.8-1.fc11       11koji        31 k
 lohit-telugu-fonts          noarch       2.3.8-1.fc11       11koji        57 k

Transaction Summary
================================================================================
Install      0 Package(s)         
Update      13 Package(s)         
Remove       0 Package(s)         

Total download size: 545 k
Is this ok [y/N]: n
Exiting on user Command
Complete!
[root@tlondon ~]# 


So these appear to want to come from the 64bit repo.

On the other hand, if I try to update just anaconda:  

Dependencies Resolved

================================================================================
 Package                 Arch    Version                        Repository
                                                                           Size
================================================================================
Installing:
 anaconda                x86_64  11.5.0.25-1                    11koji    5.7 M
     replacing  booty.noarch 0.108-2.fc11

 anaconda                i586    11.5.0.25-1                    11koji32  5.7 M
     replacing  booty.noarch 0.108-2.fc11

Updating:
 NetworkManager-openvpn  x86_64  1:0.7.0.99-1.fc11              11koji    139 k
 NetworkManager-pptp     x86_64  1:0.7.0.99-1.fc11              11koji    122 k
 NetworkManager-vpnc     x86_64  1:0.7.0.99-1.fc11              11koji    116 k
Installing for dependencies:
 NetworkManager-glib     i586    1:0.7.0.99-1.fc11              11koji32  175 k
 atk                     i586    1.25.2-2.fc11                  11koji32  221 k


Why is booty.noarch listed twice?
Comment 16 Tom London 2009-03-06 01:29:09 EST
Checking in /var/cache/yum/11koji32/packages, it looks yum is sometimes pulling the noarch packages from the 32 bit repo:

[root@tlondon packages]# ls -lt
total 250300
-rw-r--r--. 1 root root    26004 2009-03-03 09:44 gnome-session-xsession-2.25.92-1.fc11.i586.rpm
-rw-r--r--. 1 root root   130735 2009-03-02 19:37 etherboot-zroms-kvm-5.4.4-13.fc11.noarch.rpm
-rw-r--r--. 1 root root    62535 2009-03-02 19:17 bochs-bios-data-2.3.8-0.6.git36989b0d2.fc11.noarch.rpm
-rw-r--r--. 1 root root    75152 2009-03-02 18:11 vgabios-0.6-0.5.b.fc11.noarch.rpm
-rw-r--r--. 1 root root   898818 2009-02-27 07:59 yum-3.2.21-11.fc11.noarch.rpm
-rw-r--r--. 1 root root   343467 2009-02-27 03:55 python-virtinst-0.400.1-3.fc11.noarch.rpm
-rw-r--r--. 1 root root   471405 2009-02-27 00:07 kernel-firmware-2.6.29-0.172.rc6.git4.fc11.noarch.rpm
-rw-r--r--. 1 root root    25923 2009-02-26 12:29 gnome-session-xsession-2.25.91-4.fc11.i586.rpm
-rw-r--r--. 1 root root   470072 2009-02-26 09:09 kernel-firmware-2.6.29-0.159.rc6.git3.fc11.noarch.rpm

<<<<< SNIP >>>>>
Comment 17 James Antill 2009-03-06 01:50:10 EST
Installing:
 anaconda                x86_64  11.5.0.25-1                    11koji    5.7 M
     replacing  booty.noarch 0.108-2.fc11

 anaconda                i586    11.5.0.25-1                    11koji32  5.7 M
     replacing  booty.noarch 0.108-2.fc11

...ahhh ha! ... so it's obsoletes related (yum list obsoletes).
 The interesting point is that repoquery says that anaconda-0:11.5.0.23-3.x86_64 doesn't obsolete booty, so this must be a new in koji thing?

 But anyway, it's actually normal behaviour to install both of the things that obsolete something you have installed ... we could _maybe_ change that to be arch. aware, but I'm not dying to (esp. as it's only a problem when you explicitly enable 32bit repos).
Comment 18 Tom London 2009-03-06 09:36:27 EST
Ah....

OK. This probably explains why I don't have a million i586 packages, and why I got the gnome-session-xsession.i586 package installed.

I'll close https://bugzilla.redhat.com/show_bug.cgi?id=488729, as it probably is the "same thing".

Also, I'll stop enabling both repos.

Thanks for the help.
Comment 19 Tom London 2009-03-06 09:40:14 EST
*** Bug 488729 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.