Bug 1477606 - Director doesn't create a default volume type by default
Director doesn't create a default volume type by default
Status: NEW
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
10.0 (Newton)
Unspecified Unspecified
medium Severity medium
: Upstream M2
: ---
Assigned To: Alan Bishop
Avi Avraham
Kim Nylander
: Improvement, Triaged
: 1241442 1537471 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-02 08:53 EDT by Chen
Modified: 2018-05-13 11:13 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot shows the error Unable to retrieve the default volume type (182.24 KB, image/png)
2017-08-02 08:53 EDT, Chen
no flags Details

  None (edit)
Description Chen 2017-08-02 08:53:44 EDT
Created attachment 1308212 [details]
Screenshot shows the error Unable to retrieve the default volume type

Description of problem:

Director doesn't create a default volume type by default.

# cinder type-list
+----+------+-------------+-----------+
| ID | Name | Description | Is_Public |
+----+------+-------------+-----------+
+----+------+-------------+-----------+

And cinder type-default will return an error

This will result in an error when creating volume from image via Horizon and the error message is

Error: Unable to retrieve the default volume type.

Version-Release number of selected component (if applicable):

OSP10

How reproducible:

100%

Steps to Reproduce:
1. Create an overcloud stack
2. Login to Horizon and create volume from image
3. You will notice the error message shown as in the attachment

Actual results:

No volume types are created after the successful installation

Expected results:

Director should create a default volume type by default

Additional info:
Comment 2 Alan Bishop 2017-09-22 09:58:18 EDT
There are two issues here. First is the customer issue, which is described in
the customer portal [1] and observed in the attachment [2]. The attachment
shows the Horizon UI displaying an error message ("Unable to retrieve the
default volume type.") on the screen where the user is trying to create a
volume from an image. The second issue is the fact that the Director does not
create a default volume type when deploying the overcloud. The premise is that
addressing the second issue will resolve the customer's issue. However, I
don't think this is true.

Cinder does not require the user define a default volume type, even when
multiple volume types have been defined. In fact, cinder doesn't require _any_
volume types be defined. In other words, the Director is not required to
define a default volume type because cinder does not require one.

Regarding the customer's issue, I was not able to reproduce the problem. I did
a fresh deployment of OSP-10, uploaded an image, and then used the Horizon UI
to create a volume from the image. The first thing I noted is "Type" widget
(which lets the user choose the volume type) offers only one option, and that
is "No volume type". I experimented by creating additional volume types, and
observed they would appear as options in the UI widget. But, compare this with
the customer's screenshot [2], where the "Type" widget appears to be blank. I
could not reproduce this behavior, nor did I ever see the "Unable to retrieve
the default volume type" error message.

I do not doubt the customer is experiencing a problem, but it seems related to
the Horizon UI rather than the underlying cinder behavior. I suggest another BZ
be opened that focuses on the customer's issue with Horizon. I think this BZ
should be closed NOTABUG. It simply is not necessary for the Director to
define a default volume type.

[1] https://access.redhat.com/support/cases/01902709
[2] https://bugzilla.redhat.com/attachment.cgi?id=1308212
Comment 3 Alan Bishop 2017-10-13 12:22:08 EDT
Please ACK if this can be closed per my comment #2.
Comment 4 Alan Bishop 2017-11-10 12:29:54 EST
Update: While I was not able to reproduce the Horizon behavior, I am informed that a default cinder volume type really should be assigned.

I'll work on that issue with this BZ, but consider opening another bug if there's a separate problem related to Horizon's behavior.
Comment 7 Christian Schwede (cschwede) 2018-01-24 09:20:23 EST
*** Bug 1537471 has been marked as a duplicate of this bug. ***
Comment 9 Thiago da Silva 2018-03-09 09:50:44 EST
*** Bug 1537471 has been marked as a duplicate of this bug. ***
Comment 12 Eric Harney 2018-03-09 09:55:12 EST
*** Bug 1241442 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.