Bug 1478276 - separating attach tier and add brick
separating attach tier and add brick
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.12
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: hari gowtham
bugs@gluster.org
:
Depends On: 1376326
Blocks: 1478273 1478275
  Show dependency treegraph
 
Reported: 2017-08-04 03:48 EDT by hari gowtham
Modified: 2017-10-26 10:35 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.12.0
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1376326
Environment:
Last Closed: 2017-09-05 13:38:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hari gowtham 2017-08-04 03:48:47 EDT
+++ This bug was initially created as a clone of Bug #1376326 +++

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Worker Ant on 2016-09-15 02:36:47 EDT ---

REVIEW: http://review.gluster.org/15503 (tier: separation of attach tier from add brick) posted (#1) for review on master by hari gowtham (hari.gowtham005@gmail.com)

--- Additional comment from hari gowtham on 2016-09-19 05:35:45 EDT ---

Description of problem:
currently attach tier uses the same code as add brick. it has be separated so that we can support add brick on tiered volume.

Version-Release number of selected component (if applicable):


How reproducible:
no change in the testing part.both add brick and attach tier command has to
work same as before. 

Steps to Reproduce:
1.create a volume.
2.try adding a brick/ attaching a hot tier
3.

Actual results:
add brick/attach tier successful 

Expected results:
add brick/attach tier successful (same result)

Additional info:
changes are in code level. functionality is not affected.

--- Additional comment from Worker Ant on 2016-09-20 06:08:14 EDT ---

REVIEW: http://review.gluster.org/15503 (tier: separation of attach tier from add brick) posted (#2) for review on master by hari gowtham (hari.gowtham005@gmail.com)

--- Additional comment from Worker Ant on 2016-09-20 06:53:07 EDT ---

REVIEW: http://review.gluster.org/15503 (tier: separation of attach tier from add brick) posted (#3) for review on master by hari gowtham (hari.gowtham005@gmail.com)

--- Additional comment from Worker Ant on 2016-09-22 07:54:50 EDT ---

REVIEW: http://review.gluster.org/15503 (tier: separation of attach tier from add brick) posted (#4) for review on master by hari gowtham (hari.gowtham005@gmail.com)

--- Additional comment from Worker Ant on 2016-09-30 07:30:11 EDT ---

REVIEW: http://review.gluster.org/15503 (tier: separation of attach tier from add brick) posted (#5) for review on master by hari gowtham (hari.gowtham005@gmail.com)

--- Additional comment from Worker Ant on 2016-10-12 08:10:09 EDT ---

REVIEW: http://review.gluster.org/15503 (tier: separation of attach tier from add brick) posted (#6) for review on master by hari gowtham (hari.gowtham005@gmail.com)

--- Additional comment from Worker Ant on 2016-10-13 06:08:31 EDT ---

REVIEW: http://review.gluster.org/15503 (tier: separation of attach tier from add brick) posted (#7) for review on master by hari gowtham (hari.gowtham005@gmail.com)

--- Additional comment from Worker Ant on 2016-10-20 08:46:57 EDT ---

REVIEW: http://review.gluster.org/15503 (tier: separation of attach tier from add brick) posted (#8) for review on master by hari gowtham (hari.gowtham005@gmail.com)

--- Additional comment from Worker Ant on 2016-10-26 08:14:04 EDT ---

REVIEW: http://review.gluster.org/15503 (tier: separation of attach tier from add brick) posted (#9) for review on master by hari gowtham (hari.gowtham005@gmail.com)

--- Additional comment from Worker Ant on 2016-10-27 03:17:20 EDT ---

REVIEW: http://review.gluster.org/15503 (tier: separation of attach tier from add brick) posted (#10) for review on master by hari gowtham (hari.gowtham005@gmail.com)

--- Additional comment from Worker Ant on 2017-03-07 05:24:54 EST ---

REVIEW: https://review.gluster.org/15503 (tier: separation of attach tier from add brick) posted (#13) for review on master by hari gowtham (hari.gowtham005@gmail.com)

--- Additional comment from Worker Ant on 2017-04-03 05:06:13 EDT ---

REVIEW: https://review.gluster.org/15503 (tier: separation of attach tier from add brick) posted (#14) for review on master by hari gowtham (hari.gowtham005@gmail.com)

--- Additional comment from Worker Ant on 2017-04-11 09:00:49 EDT ---

REVIEW: https://review.gluster.org/15503 (tier: separation of attach tier from add brick) posted (#15) for review on master by hari gowtham (hari.gowtham005@gmail.com)

--- Additional comment from Worker Ant on 2017-05-19 06:09:09 EDT ---

REVIEW: https://review.gluster.org/15503 (tier: separation of attach tier from add brick) posted (#16) for review on master by hari gowtham (hari.gowtham005@gmail.com)

--- Additional comment from Worker Ant on 2017-05-22 05:32:22 EDT ---

REVIEW: https://review.gluster.org/15503 (tier: separation of attach tier from add brick) posted (#17) for review on master by hari gowtham (hari.gowtham005@gmail.com)

--- Additional comment from Worker Ant on 2017-05-22 06:32:47 EDT ---

REVIEW: https://review.gluster.org/15503 (tier: separation of attach-tier from add brick) posted (#18) for review on master by hari gowtham (hari.gowtham005@gmail.com)

--- Additional comment from Worker Ant on 2017-05-22 07:28:10 EDT ---

REVIEW: https://review.gluster.org/15503 (tier: separation of attach-tier from add-brick) posted (#19) for review on master by hari gowtham (hari.gowtham005@gmail.com)

--- Additional comment from Worker Ant on 2017-05-26 04:05:35 EDT ---

REVIEW: https://review.gluster.org/15503 (tier: separation of attach-tier from add-brick) posted (#20) for review on master by hari gowtham (hari.gowtham005@gmail.com)

--- Additional comment from Worker Ant on 2017-07-04 07:57:26 EDT ---

REVIEW: https://review.gluster.org/17693 (tier: separation of attach-tier from add-brick) posted (#1) for review on experimental by hari gowtham (hari.gowtham005@gmail.com)

--- Additional comment from Worker Ant on 2017-07-05 06:56:03 EDT ---

COMMIT: https://review.gluster.org/17693 committed in experimental by Amar Tumballi (amarts@redhat.com) 
------
commit 0b3f47372ffbe1c5c07e217bc1730933b8c00b7c
Author: hari gowtham <hgowtham@redhat.com>
Date:   Tue Jul 4 16:16:37 2017 +0530

    tier: separation of attach-tier from add-brick
    
    PROBLEM: Both attach tier and add brick have the same RPC
    and set of code. This becomes a hurdle while tring to implement
    add brick on a tiered volume.
    
    FIX: This patch separates the add brick and attach tier
    giving them separate RPCs.
    
    Conflicts:
    
    	xlators/mgmt/glusterd/src/glusterd-messages.h
    
    Change-Id: Iec57e972be968a9ff00b15b507e56a4f6dc398a2
    BUG: 1376326
    Signed-off-by: hari gowtham <hgowtham@redhat.com>
    Reviewed-on: https://review.gluster.org/17693
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Tested-by: hari gowtham <hari.gowtham005@gmail.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Amar Tumballi <amarts@redhat.com>

--- Additional comment from Worker Ant on 2017-07-31 06:16:43 EDT ---

REVIEW: https://review.gluster.org/15503 (tier: separation of attach-tier from add-brick) posted (#21) for review on master by hari gowtham (hari.gowtham005@gmail.com)

--- Additional comment from Worker Ant on 2017-08-01 07:08:09 EDT ---

COMMIT: https://review.gluster.org/15503 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit e5db980504bc4ace037ea806ad89a1ca897150d5
Author: hari gowtham <hgowtham@redhat.com>
Date:   Mon Jan 23 16:38:00 2017 +0530

    tier: separation of attach-tier from add-brick
    
    PROBLEM: Both attach tier and add brick have the same RPC
    and set of code. This becomes a hurdle while tring to implement
    add brick on a tiered volume.
    
    FIX: This patch separates the add brick and attach tier
    giving them separate RPCs.
    
    Change-Id: Iec57e972be968a9ff00b15b507e56a4f6dc398a2
    BUG: 1376326
    Signed-off-by: hari gowtham <hgowtham@redhat.com>
    Reviewed-on: https://review.gluster.org/15503
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Tested-by: hari gowtham <hari.gowtham005@gmail.com>
    Reviewed-by: Samikshan Bairagya <samikshan@gmail.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
Comment 1 Worker Ant 2017-08-04 03:51:44 EDT
REVIEW: https://review.gluster.org/17974 (tier: separation of attach-tier from add-brick) posted (#1) for review on release-3.12 by hari gowtham (hari.gowtham005@gmail.com)
Comment 2 Worker Ant 2017-08-04 16:34:07 EDT
COMMIT: https://review.gluster.org/17974 committed in release-3.12 by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit 098801ba723d8dae49ea104144d007f23a8e0a4f
Author: hari gowtham <hgowtham@redhat.com>
Date:   Mon Jan 23 16:38:00 2017 +0530

    tier: separation of attach-tier from add-brick
    
    PROBLEM: Both attach tier and add brick have the same RPC
    and set of code. This becomes a hurdle while tring to implement
    add brick on a tiered volume.
    
    FIX: This patch separates the add brick and attach tier
    giving them separate RPCs.
    
    >Change-Id: Iec57e972be968a9ff00b15b507e56a4f6dc398a2
    >BUG: 1376326
    >Signed-off-by: hari gowtham <hgowtham@redhat.com>
    >Reviewed-on: https://review.gluster.org/15503
    >Smoke: Gluster Build System <jenkins@build.gluster.org>
    >Tested-by: hari gowtham <hari.gowtham005@gmail.com>
    >Reviewed-by: Samikshan Bairagya <samikshan@gmail.com>
    >CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    
    Signed-off-by: hari gowtham <hgowtham@redhat.com>
    Change-Id: Iec57e972be968a9ff00b15b507e56a4f6dc398a2
    BUG: 1478276
    Reviewed-on: https://review.gluster.org/17974
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Tested-by: hari gowtham <hari.gowtham005@gmail.com>
    Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
Comment 3 Shyamsundar 2017-09-05 13:38:34 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.12.0, please open a new bug report.

glusterfs-3.12.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-September/000082.html
[2] https://www.gluster.org/pipermail/gluster-users/

Note You need to log in before you can comment on or make changes to this bug.