Bug 1478334 - Sorting of events in the events page is wrong (latest on the bottom)
Sorting of events in the events page is wrong (latest on the bottom)
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
4.2.0
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-4.2.0
: ---
Assigned To: Alexander Wels
samuel macko
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-04 06:50 EDT by Petr Matyáš
Modified: 2017-12-20 06:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-20 06:10:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: UX
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 81226 None None None 2017-09-01 07:38 EDT

  None (edit)
Description Petr Matyáš 2017-08-04 06:50:31 EDT
Description of problem:
Opening events tab in webadmin, I would expect to find latest events on top, but no, they are on the very bottom of the page. And to make my surprise even bigger, using pagination goes to older events, which wouldn't be wrong if the sorting order of items would be reversed. In that case though it would have to have latest items on the last page on the bottom.

Version-Release number of selected component (if applicable):
ovirt-engine-webadmin-portal-4.2.0-0.0.master.20170803140556.git1e7d0dd.el7.centos.noarch

How reproducible:
always

Steps to Reproduce:
1. open events tab
2.
3.

Actual results:
sorting is weird and wrong, latest on bottom, going through pages goes to older events which are again sorted badly with latest from that part on the bottom

Expected results:
latest on top (on every page)

Additional info:
Comment 1 Greg Sheremeta 2017-08-28 09:30:43 EDT

*** This bug has been marked as a duplicate of bug 1478687 ***
Comment 2 samuel macko 2017-09-04 09:48:41 EDT
Verified in ovirt version 4.2.0-0.0.master.20170903205106.gitb17261a.el7.centos.

Verified by following the reproducer.
Comment 3 Sandro Bonazzola 2017-12-20 06:10:08 EST
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.