Bug 1478687 - [UI] - Events in the engine appear in reverse order
[UI] - Events in the engine appear in reverse order
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
4.2.0
x86_64 Linux
unspecified Severity high (vote)
: ovirt-4.1.6
: 4.1.6.2
Assigned To: Alexander Wels
Petr Matyáš
: Regression
Depends On:
Blocks: 1486513
  Show dependency treegraph
 
Reported: 2017-08-06 02:08 EDT by Michael Burman
Modified: 2017-09-19 06:03 EDT (History)
11 users (show)

See Also:
Fixed In Version: ovirt-engine-4.1.6.2
Doc Type: Bug Fix
Doc Text:
Cause: A regression bug caused system events to be sorted chronologically, earliest events at the top. Fix: Events are now properly sorted, latest at the top.
Story Points: ---
Clone Of:
: 1486513 (view as bug list)
Environment:
Last Closed: 2017-09-19 06:03:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: UX
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.1+
rule-engine: ovirt‑4.2+
rule-engine: blocker+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 81226 master MERGED webadmin: fix sort order for event list model. 2017-08-30 10:53 EDT
oVirt gerrit 81228 ovirt-engine-4.1 MERGED webadmin: fix sort order for event list model. 2017-08-30 11:07 EDT

  None (edit)
Description Michael Burman 2017-08-06 02:08:00 EDT
Description of problem:
[UI] - Events tab doesn't refreshed or updated with any latest changes done on the system.

It looks like the main Events tab and the Notification events tab stopped from being updated with latest changes done on the system.

I'm performing actions and i don't see any events reported or added to the events tab.

Version-Release number of selected component (if applicable):
4.2.0-0.0.master.20170803140556.git1e7d0dd.el7.centos

How reproducible:
Seems to be always on latest master.

Steps to Reproduce:
1. Perform changes in the engine - run VM, migrate, save networks on host, stop VM and so on..

Actual results:
No events added to the event tab.

Expected results:
Should work as expected
Comment 1 Red Hat Bugzilla Rules Engine 2017-08-07 15:02:35 EDT
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 2 Michael Burman 2017-08-16 01:26:48 EDT
4.1.5-4 version affected by this bug as well.
Event log isn't being refreshed in real time. There is a long delay between the action that was currently done and between what is being displayed in the event log.
Comment 3 Michael Burman 2017-08-16 01:34:17 EDT
Just to be clear, when i say delay, it's a 6-7 days delay!
Raising severity as it's affecting the admin work and he has no clue if operation has been succeeded in real time.
This bug should be fixed for 4.1.5 as well.
Comment 4 Gianluca Cecchi 2017-08-28 04:11:10 EDT
I confirm after updating from 4.1.3 to 4.1.5, now events tab, both in main view and in detailed views (eg select VM and then its events), events appear in reversed order: newer at bottom.
Comment 5 Greg Sheremeta 2017-08-28 09:22:14 EDT
This appears to be something wrong with the query. We haven't changed any UI code in 4.1.z related to events.
Comment 6 Greg Sheremeta 2017-08-28 09:30:43 EDT
*** Bug 1478334 has been marked as a duplicate of this bug. ***
Comment 7 Oved Ourfali 2017-08-29 11:48:15 EDT
Vojtech did some changes around it in bug 1445235.
One patch was pushed to 4.1.5, and another to 4.1.6.
But, 4.1.5 has a change in behavior that's for sure.
Comment 8 Greg Sheremeta 2017-08-30 09:55:27 EDT
Yes, I was incorrect in Comment 5.
Comment 9 Oved Ourfali 2017-08-30 12:22:22 EDT
*** Bug 1486513 has been marked as a duplicate of this bug. ***
Comment 10 Marina 2017-08-30 17:37:24 EDT
Note, this also affects the bottom window events, which you cannot sort manually by clicking on the column.
Comment 11 samuel macko 2017-09-01 07:19:25 EDT
Verified in Red Hat Virtualization Manager Version: 4.1.6.1-0.1.el7

Tested:
 1. Create new VM
 2. Run VM
 3. Create snapshot of VM
 4. Power off VM
 5. Remove VM

Results: 	
 VM ... was created by ...
 Network Interface ... was plugged to VM ...
 Interface ... was added to VM ...
 Add-Disk operation of ... was initiated on VM ...
 The disk ... was successfully added to VM ...
 VM ... was started by ...
 VM ... started on Host ...
 Snapshot 'snap-test' creation for VM '...' was ...
 The disk 'snapshot_memory' was successfully added.
 The disk 'snapshot_metadata' was successfully added.
 Snapshot 'snap-test' creation for VM '...' has been completed.
 VM ... powered off by ...
 VM ... is down. 
 VM ... was successfully removed.
Comment 12 samuel macko 2017-09-01 07:53:57 EDT
Updated title.

Correct bug for events order is https://bugzilla.redhat.com/show_bug.cgi?id=1481144

This bug is regarding refresh of events tab.
Comment 13 Michael Burman 2017-09-01 09:42:59 EDT
Samuel , this bug shouldn't be verified as it failedQA on 4.1.6.1

Note that this report and BZ 1481144 are the same bug and you shouldn't have change it's summary. Thi sis the same issue and Greg mentioned in comment#8 in BZ 1481144
Comment 14 Michael Burman 2017-09-01 09:51:06 EDT
The issue still exist on 4.1.6.1
Comment 15 Oved Ourfali 2017-09-01 09:58:17 EDT
I don't think it was part of the build.
Was it?
Comment 16 Greg Sheremeta 2017-09-01 11:23:38 EDT
Correct, it'll be in the next 4.1.6 build.
Comment 17 Petr Matyáš 2017-09-08 06:06:16 EDT
Verified on ovirt-engine-4.1.6.2-0.1.el7.noarch

Note You need to log in before you can comment on or make changes to this bug.