Bug 1478626 - segfault in qpdf
segfault in qpdf
Status: CLOSED DUPLICATE of bug 1478537
Product: Fedora
Classification: Fedora
Component: qpdf (Show other bugs)
25
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Zdenek Dohnal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-05 06:12 EDT by slartibart70
Modified: 2017-08-07 02:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-07 02:44:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description slartibart70 2017-08-05 06:12:04 EDT
Hi all,

i did an update of fedora25 with updates-testing repos, 
qpdf was updated from version 6.0.0.3.fc25 to 6.0.0.4.fc25

Now, my usb-attached laserprinter won't print any more, including the linux testpage.

The reason of this bug can be found in dmesg output:
pdftopdf[3197]: segfault at 10 ip 00007f91fba17f87 sp 00007ffffd1df140 error 6 in libc-2.24.so[7f91fb994000+1bc000]


After downgrading to 6.0.0.3 all is fine again.
Just wanted to let you know for any QA necessary ... :-)
Comment 1 Zdenek Dohnal 2017-08-07 02:44:17 EDT
Hi,

thank you for reporting this issue, it is same as #1478537, closing as duplicate.

*** This bug has been marked as a duplicate of bug 1478537 ***

Note You need to log in before you can comment on or make changes to this bug.