Bug 1478537 - qpdf-libs-6.0.0-6.fc26-x86_64 from updates-testing breaks printing
Summary: qpdf-libs-6.0.0-6.fc26-x86_64 from updates-testing breaks printing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: qpdf
Version: 26
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Zdenek Dohnal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1478459 1478626 1478920 1479260 1479326 1479495 1479562 1479784 1479865 1480048 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-04 18:44 UTC by Bob Schultz
Modified: 2017-09-04 15:15 UTC (History)
22 users (show)

Fixed In Version: qpdf-6.0.0-7.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-09 15:59:19 UTC
Type: Bug


Attachments (Terms of Use)
File: backtrace (69.72 KB, text/plain)
2017-08-10 10:26 UTC, Nils Tonnätt
no flags Details

Description Bob Schultz 2017-08-04 18:44:45 UTC
Description of problem:
Updates-testing qpdf-libs-6.0.0-6.fc26-x86_64 breaks printing. Printers stopped and filter failed msg. in status.

Version-Release number of selected component (if applicable):

qpdf-libs-6.0.0-6.fc26-x86_64
How reproducible:


Steps to Reproduce:
1.Update to qpdf-libs-6.0.0-6.fc26-x86_64
2.Print
3.Print fails--printer stopped, "filter failed" in status

Actual results:


Expected results:
Print normally

Additional info:
Failed on two independent systems with update. Downgrade of qpdf fixed problem.
Printer is networked postscript Konica-Minolta 4750DN lpd setup.

Comment 1 Bob Schultz 2017-08-04 19:02:49 UTC
Printer setup is using manufacturer's M4750PX.ppd

Comment 2 xvr 2017-08-04 20:02:14 UTC
Exactly the same problem here - it seems that qpdf-libs-6.0.0-6.fc26-x86_64 breaks the cups filter pdftopdf (see journalctl -b, ... pdftopdf crashed on signal 11, and ... pdftopdf dumped core) - pdftopdf is linked to libqpdf.so.17.
Downgrading to qpdf-libs-6.0.0-5 fixed the issue.

Comment 3 Zdenek Dohnal 2017-08-07 06:43:19 UTC
*** Bug 1478459 has been marked as a duplicate of this bug. ***

Comment 4 Zdenek Dohnal 2017-08-07 06:44:17 UTC
*** Bug 1478626 has been marked as a duplicate of this bug. ***

Comment 5 Alessio 2017-08-07 07:34:46 UTC
> Downgrading to qpdf-libs-6.0.0-5 fixed the issue.

I can confirm that downgrading to qpdf-libs-6.0.0-5 my configured printers now work.

Comment 6 Zdenek Dohnal 2017-08-07 08:07:46 UTC
Patches for CVEs broke other things. I'll revert the changes and I will report upstream about it.

Comment 7 Fedora Update System 2017-08-07 08:54:09 UTC
qpdf-6.0.0-7.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-8aef53994c

Comment 8 Zdenek Dohnal 2017-08-07 13:44:21 UTC
*** Bug 1478920 has been marked as a duplicate of this bug. ***

Comment 9 Robert Locke 2017-08-07 20:50:47 UTC
Confirming that the downgrade (to 6.0.0-6.fc26) fixes printing for me too using networked HP Laserjet p2055dn.

Comment 10 Robert Locke 2017-08-07 20:57:24 UTC
Argh, downgrading to 6.0.0-5.fc26 fixes - typo, sorry....

Comment 11 Fedora Update System 2017-08-08 01:23:57 UTC
qpdf-6.0.0-7.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-8aef53994c

Comment 12 Zdenek Dohnal 2017-08-08 09:42:09 UTC
*** Bug 1479260 has been marked as a duplicate of this bug. ***

Comment 13 Alessio 2017-08-08 10:04:40 UTC
Updating to qpdf-6.0.0-7.fc26 I'm able to print.

Comment 14 Yaniv Kaul 2017-08-08 10:18:48 UTC
Raising severity to High - I can't print. Will test with the packages from comment 11 to report if it fixes my problem.

Comment 15 Yaniv Kaul 2017-08-08 10:24:40 UTC
(In reply to Yaniv Kaul from comment #14)
> Raising severity to High - I can't print. Will test with the packages from
> comment 11 to report if it fixes my problem.

Upgraded qpdf-libs from -6 to -7 did NOT fix the problem for me.  I'm trying to print to a Canon 3580.

Comment 16 Zdenek Dohnal 2017-08-08 10:40:44 UTC
Does downgrading to qpdf -5 release fix the problem? Or does it still ends with segfault or other error? -7 release should be same as -5 release, which worked fine.

Comment 17 Zdenek Dohnal 2017-08-08 11:49:06 UTC
*** Bug 1479326 has been marked as a duplicate of this bug. ***

Comment 18 Yaniv Kaul 2017-08-08 12:04:54 UTC
(In reply to Zdenek Dohnal from comment #16)
> Does downgrading to qpdf -5 release fix the problem? Or does it still ends
> with segfault or other error? -7 release should be same as -5 release, which
> worked fine.

After reboot (yay!) it works well. Perhaps some service restart would have worked too. So now I can confirm I can print again. Thanks!

Comment 19 Zdenek Dohnal 2017-08-08 12:49:15 UTC
(In reply to Yaniv Kaul from comment #18)
> 
> After reboot (yay!) it works well. Perhaps some service restart would have
> worked too. So now I can confirm I can print again. Thanks!

Happy to hear that :)

Comment 20 Zdenek Dohnal 2017-08-08 16:16:18 UTC
*** Bug 1479495 has been marked as a duplicate of this bug. ***

Comment 21 Daniel 2017-08-08 17:45:36 UTC
I’m also facing this problem and also after upgrading qpdf.

Mageia solved this exact problem a few days ago by rebuilding CUPS against the newer version of qpdf. See https://bugs.mageia.org/show_bug.cgi?id=21444

Comment 22 Donald O. 2017-08-08 18:20:53 UTC
Hi Daniel,

I upgraded qpdf and since then it works. However before I uses bugzilla I tried to fix the problem with

'grep cupsd /var/log/audit/audit.log | audit2allow -M mypol
semodule -i mypol.pp'

this didn't fix the problem directly, however perhaps together with the qpdf umgrade.

Comment 23 Erik Schilling 2017-08-08 20:02:10 UTC
Upgrading qpdf fixed the problem on my dads computer without the need of any restarting.

Thanks for the quick fix!

Comment 24 Bob Schultz 2017-08-08 23:22:40 UTC
qpdf-6.0.0-7.fc26 works ok here on multiple computers.

Comment 25 Zdenek Dohnal 2017-08-09 06:01:24 UTC
*** Bug 1479562 has been marked as a duplicate of this bug. ***

Comment 26 bastelnerk 2017-08-09 10:48:41 UTC
Upgrading to -7 using

sudo dnf --enablerepo=updates-testing upgrade qpdf-libs

fixed the fedora 26 printing problem "filter error" for me. Thanks!

Comment 27 Zdenek Dohnal 2017-08-09 13:30:32 UTC
*** Bug 1479784 has been marked as a duplicate of this bug. ***

Comment 28 Fedora Update System 2017-08-09 15:59:19 UTC
qpdf-6.0.0-7.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 29 Zdenek Dohnal 2017-08-10 05:53:37 UTC
*** Bug 1479865 has been marked as a duplicate of this bug. ***

Comment 30 Donald O. 2017-08-10 07:54:10 UTC
thanks!

Comment 31 Nils Tonnätt 2017-08-10 10:26:16 UTC
Similar problem has been detected:

I tried to print a pdf file with a Dell 1710n laser printer. The print job just canceled itself. dmesg showed a segfault.
The problem is indepedent of the used driver (ppd file or generic driver).

reporter:       libreport-2.9.1
backtrace_rating: 4
cmdline:        Dell-Laser-Printer-1710n 3 nils Fax 1 InputSlot=Default number-up=1 PrinterResolution=FromPrintoutMode PageSize=A4 noCollate PrintoutMode=High.Gray Duplex=None ColorModel=FromPrintoutMode job-uuid=urn:uuid:39eae061-7314-3652-7c76-ebb8c5b627bb job-originating-host-name=localhost date-time-at-creation= date-time-at-processing= time-at-creation=1502314054 time-at-processing=1502314054 /var/spool/cups/d00003-001
crash_function: operator new
executable:     /usr/lib/cups/filter/pdftopdf
journald_cursor: s=9232ec80a7184bdfbf46cfd7fe0d1dfd;i=12f6d;b=610475979ab84d1f9c959cd4e1ffaa77;m=a2bfcb58a;t=55658bf904464;x=13a03377cb0500c2
kernel:         4.11.11-300.fc26.x86_64
package:        cups-filters-1.13.4-2.fc26
reason:         pdftopdf killed by signal 11
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            4

Comment 32 Nils Tonnätt 2017-08-10 10:26:28 UTC
Created attachment 1311687 [details]
File: backtrace

Comment 33 Zdenek Dohnal 2017-08-10 10:36:09 UTC
Did you update qpdf-libs to 6.0.0-7 release?

Comment 34 Nils Tonnätt 2017-08-10 10:47:07 UTC
No, I will try it later. I thought abrt would show me if a bug is already reported…

Comment 35 Sven Anders 2017-08-10 12:11:24 UTC
For me it didn't worked with 6.0.0-7 that was installed by the dist-upgrade.
I downgraded to 6.0.0-5 and it worked. Then I upgraded to 6.0.0-7 again and
it still works. A bit strange...?!

Comment 36 Zdenek Dohnal 2017-08-10 12:40:57 UTC
Didn't you restart cups or computer when you updated from -5 to -7? Restart after update worked for some people.

Comment 37 Sven Anders 2017-08-10 12:52:57 UTC
No, I didn't restarted anything. Just downgrading to -5 worked.
The stange thing is, that I'm upgraded to -7 just for testing and now it works with the new version too...
(For testing reasons I restarted cups, but it still works...)

Never mind, I just want to inform you about this strange behaviour. Maybe something in the -5 packages changed a value/config and now it works correctly with -7 too...

Comment 38 Zdenek Dohnal 2017-08-10 13:10:47 UTC
-7 release is revert of -6 release, which means it is same as -5. You probably had some data cached, which used older -6 release, and it caused problems even with -7 release.

Comment 39 Sven Anders 2017-08-10 13:25:09 UTC
Ok, this makes sense...

Comment 40 Zdenek Dohnal 2017-08-11 13:46:07 UTC
Hi everyone,

would you mind testing this update https://bodhi.fedoraproject.org/updates/cups-filters-1.13.4-3.fc26%20qpdf-6.0.0-8.fc26 ? This update puts back patches for CVEs in qpdf, which were in qpdf-libs-6.0.0-6.fc26 version, but it created binary incompatibility, which caused segfaults in cups-filters. It should be solved by rebuild of cups-filters against new qpdf-libs release (cups-filters rebuild is part of update). I didn't set auto-push to stable on this update, because I want to push it manually after I get positive feedback about its functionality.

Comment 41 Nils Tonnätt 2017-08-11 15:23:34 UTC
Revision 8 works fine. Thank you very much!

Comment 42 Zdenek Dohnal 2017-08-14 10:53:11 UTC
*** Bug 1479784 has been marked as a duplicate of this bug. ***

Comment 43 Zdenek Dohnal 2017-09-04 15:15:09 UTC
*** Bug 1480048 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.