Bug 1478790 - Can't delete/remove an unmanaged network with long name
Can't delete/remove an unmanaged network with long name
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network (Show other bugs)
4.1.5.1
x86_64 Linux
medium Severity high (vote)
: ovirt-4.1.6
: ---
Assigned To: Leon Goldberg
Meni Yakove
:
Depends On:
Blocks: 1458407
  Show dependency treegraph
 
Reported: 2017-08-07 01:49 EDT by Michael Burman
Modified: 2017-09-19 06:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-19 06:02:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.1+


Attachments (Terms of Use)
engine log (969.40 KB, application/x-gzip)
2017-08-07 01:49 EDT, Michael Burman
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 80469 master MERGED backend: replace network name with vdsm name when needed 2017-08-18 01:32 EDT
oVirt gerrit 80813 ovirt-engine-4.1 MERGED backend: replace network name with vdsm name when needed 2017-08-21 04:02 EDT

  None (edit)
Description Michael Burman 2017-08-07 01:49:13 EDT
Created attachment 1309916 [details]
engine log

Description of problem:
Can't delete/remove an unmanaged network with long name.

When trying to remove an unmanaged network from the host we failing with:

2017-08-07 08:43:54,545+03 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.HostSetupNetworksVDSCommand] (default task-7) [ece72b9b-c1f8-4dba-a90f-25020591992d] Command 'HostSetupNetworksVDSCommand(HostName = navy-vds1.qa.lab.tlv.redhat.com, HostSetupNetworksVdsCommandParameters:{hostId='931c94f3-b452-4597-9989-8d6b48e232cb', vds='Host[navy-vds1.qa.lab.tlv.redhat.com,931c94f3-b452-4597-9989-8d6b48e232cb]', rollbackOnFailure='true', connectivityTimeout='120', networks='[]', removedNetworks='[long-name%network5555555]', bonds='[]', removedBonds='[]', clusterSwitchType='LEGACY'})' execution failed: VDSGenericException: VDSErrorException: Failed to HostSetupNetworksVDS, error = Cannot delete network u'long-name%network5555555': It doesn't exist in the system, code = 27
2017-08-07 08:43:54,546+03 INFO  [org.ovirt.engine.core.bll.network.host.HostSetupNetworksCommand] (default task-7) [ece72b9b-c1f8-4dba-a90f-25020591992d] Host setup networks finished. Lock released. Monitoring can run now for host 'navy-vds1.qa.lab.tlv.redhat.com' from data-center 'DC1'
2017-08-07 08:43:54,546+03 ERROR [org.ovirt.engine.core.bll.network.host.HostSetupNetworksCommand] (default task-7) [ece72b9b-c1f8-4dba-a90f-25020591992d] Command 'org.ovirt.engine.core.bll.network.host.HostSetupNetworksCommand' failed: EngineException: org.ovirt.engine.core.vdsbroker.vdsbroker.VDSErrorException: VDSGenericException: VDSErrorException: Failed to HostSetupNetworksVDS, error = Cannot delete network u'long-name%network5555555': It doesn't exist in the system, code = 27 (Failed with error ERR_BAD_BRIDGE and code 27)
2017-08-07 08:43:54,559+03 INFO  [org.ovirt.engine.core.bll.network.host.HostSetupNetworksCommand] (default task-7) [ece72b9b-c1f8-4dba-a90f-25020591992d] Lock freed to object 'EngineLock:{exclusiveLocks='[HOST_NETWORK931c94f3-b452-4597-9989-8d6b48e232cb=HOST_NETWORK]', sharedLocks=''}'

Version-Release number of selected component (if applicable):
4.1.5.1-0.1.el7
4.2.0-0.0.master.20170806164941.git514c1c9.el7.centos

How reproducible:
100

Steps to Reproduce:
1. Create network with long name - more then 15 characters
2. Attach the network to the host via setup networks dialog
3. Remove the network from the DC
4. Try to remove the unmanaged network from the host via setup networks

Actual results:
Failed with - Failed with error ERR_BAD_BRIDGE and code 27.
Need to remove it manually from the host with brctl command.

Expected results:
Should work as expected
Comment 1 Michael Burman 2017-08-27 01:49:00 EDT
Dan, not sure this can be verified, after removing the 'unmanaged' via the UI, the network still appears to be on the host - 

[root@zeus-vds1 ~]# brctl show
bridge name     bridge id               STP enabled     interfaces
;vdsmdummy;             8000.000000000000       no
DC3_manage_net          8000.90e2ba0dc6f0       no              ens1f0
one6eab3e6a9574         8000.000000000000       no
one8a4927720a94         8000.000000000000       no

And in vdsm-client as well
one8a4927720a94": {
            "iface": "one8a4927720a94", 
"ports": []

 "one6eab3e6a9574": {
            "iface": "one6eab3e6a9574", 

"ports": []

Engine complaining that network one6eab3e6a9574 is missing on the host. 
Not sure if it's the same bug or now it's on vdsm side. Please advice
Comment 2 Michael Burman 2017-08-27 03:26:00 EDT
(In reply to Michael Burman from comment #1)
> Dan, not sure this can be verified, after removing the 'unmanaged' via the
> UI, the network still appears to be on the host - 
> 
> [root@zeus-vds1 ~]# brctl show
> bridge name     bridge id               STP enabled     interfaces
> ;vdsmdummy;             8000.000000000000       no
> DC3_manage_net          8000.90e2ba0dc6f0       no              ens1f0
> one6eab3e6a9574         8000.000000000000       no
> one8a4927720a94         8000.000000000000       no
> 
> And in vdsm-client as well
> one8a4927720a94": {
>             "iface": "one8a4927720a94", 
> "ports": []
> 
>  "one6eab3e6a9574": {
>             "iface": "one6eab3e6a9574", 
> 
> "ports": []
> 
> Engine complaining that network one6eab3e6a9574 is missing on the host. 
> Not sure if it's the same bug or now it's on vdsm side. Please advice

It is possible that i had left overs from before the fix and those unmanaged networks remained on the host since then. I will re test my self.
Comment 3 Michael Burman 2017-08-28 09:41:46 EDT
Verified on - 4.1.6-0.1.el7

Note You need to log in before you can comment on or make changes to this bug.