Bug 14788 - Files disagree between old style /etc/rc.d/ and ex-new style /etc/
Summary: Files disagree between old style /etc/rc.d/ and ex-new style /etc/
Status: CLOSED DUPLICATE of bug 15475
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-28 13:18 UTC by Olivier Baudron
Modified: 2014-03-17 02:15 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-28 13:18:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Olivier Baudron 2000-07-28 13:18:32 UTC
In initscripts-5.35-1,

/etc/inittab assumes rc files are in /etc/rc.d/  (extract below) :
    # System initialization.
    si::sysinit:/etc/rc.d/rc.sysinit

whereas
/etc/rc.d/rc.sysinit assumes rc files are in /etc/  (extract below)
    # Rerun ourselves through initlog
    if [ -z "$IN_INITLOG" ]; then
     [ -f /sbin/initlog ] && exec /sbin/initlog $INITLOG_ARGS -r     
     /etc/rc.sysinit
    fi

Comment 1 Bill Nottingham 2000-08-22 14:58:36 UTC
This is more a matter of documenting what we're doing.

*** This bug has been marked as a duplicate of 15475 ***


Note You need to log in before you can comment on or make changes to this bug.