Bug 15475 - sysvinitfiles doc to be updated
sysvinitfiles doc to be updated
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.0
i386 Linux
low Severity low
: ---
: ---
Assigned To: Bill Nottingham
:
: 14788 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-05 10:26 EDT by giulioo
Modified: 2014-03-16 22:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-22 10:58:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description giulioo 2000-08-05 10:26:43 EDT
1) It seems you decided to stick with /etc/rc.d/init.d for now and 
make /etc/init.d just a link, so it should say

 /etc/rc.d/init.d/<servicename>
instead of
 /etc/init.d/<servicename>

since all the rpms use directly /etc/rc.d/init.d in their %files and not 
the link.


2) It should document "condrestart", that you added to all of the init 
scripts to conditionally restart services. 


3) The doc makes the example of

case $1 in

	start)
		<all the stuff here>


but all of your latest init scripts use:

start () {
	<all the stuff here>.
}


case $1 in
	start) 
	start
...


Which is the preferred way if any?
Comment 1 Bill Nottingham 2000-08-22 10:58:34 EDT
*** Bug 14788 has been marked as a duplicate of this bug. ***
Comment 2 Bill Nottingham 2000-08-22 11:35:31 EDT
The second way is better, because that way if you implement restart as:

  restart)
	stop
	start

it doesn't run two more shell invocations. More of this stuff will
be documented in initscripts-5.48-1.h

Note You need to log in before you can comment on or make changes to this bug.