Bug 147883 - hwdata incorrect for PCI ID 0x1102 0x0006
hwdata incorrect for PCI ID 0x1102 0x0006
Status: CLOSED DUPLICATE of bug 147787
Product: Fedora
Classification: Fedora
Component: hwdata (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-11 20:07 EST by Francisco Moraes
Modified: 2014-03-16 22:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-12 00:38:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Francisco Moraes 2005-02-11 20:07:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Description of problem:
The hwdata pcitable lists the Creative Sound Blaster Live (Dell) EMU10K1X card as supported by the snd-emu10k1 driver, which is incorrect.

The correct driver is snd-emu10k1x, which I contributed to the ALSA project and which should become part of 2.6.11 kernel.

If this cannot be done until the kernel supports it, the entry for 0x1102 0x0006 should be removed instead of pointing to snd-emu10k1 as this causes kudzu to load the incorrect driver on my machine.

Version-Release number of selected component (if applicable):
2.6.10-741

How reproducible:
Always

Steps to Reproduce:
1. Install FC3 on a computer with the Dell SB Live (EMU10K1X) card
2. lsmod | grep snd-emu10k1 and notice the wrong driver is loaded
  

Actual Results:  snd-emu10k1 was loaded by kudzu even though it doesn't support the card.

Expected Results:  No driver should be loaded or the correct driver (snd-emu10k1x) should be used.

Additional info:
Comment 1 Bill Nottingham 2005-02-12 00:38:35 EST

*** This bug has been marked as a duplicate of 147787 ***

Note You need to log in before you can comment on or make changes to this bug.