Bug 1478915 - Nova not using mpath device when using unity cinder plugin for dell_emc
Nova not using mpath device when using unity cinder plugin for dell_emc
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
11.0 (Ocata)
All Linux
high Severity high
: ---
: 11.0 (Ocata)
Assigned To: Gorka Eguileor
Avi Avraham
: Unconfirmed, ZStream
Depends On: 1443612
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-07 09:35 EDT by Jaison Raju
Modified: 2017-09-13 07:49 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-25 09:28:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3150381 None None None 2017-08-14 02:19 EDT

  None (edit)
Description Jaison Raju 2017-08-07 09:35:54 EDT
Description of problem:
After configuring multipath as per doc for iscsi unity cinder driver , nova is not able to find mpath device for the volume .
The instance ends up getting single path device.


Version-Release number of selected component (if applicable):
python-os-brick-1.11.0-1.el7ost.noarch
RHOS11


How reproducible:
Always in customer environment

Steps to Reproduce:
1.
2.
3.

Actual results:
nova-compute logs that mpath device is not visible although the device is visible in multipath -ll .

Expected results:
nova-compute uses the mpath device for the corresponding volume.

Additional info:
nova-compute.log
2017-08-06 22:38:26.394 256626 WARNING os_brick.initiator.linuxscsi [req-29b5393b-cbec-468d-ac81-7f7fe666ead4 57ebc072672d48eca08779cec03c3b67 eceeb89ddbaa44bb8fb5db2f935ae9fd - - -] Couldn't find multipath device /dev/mapper/360060160222044002bd07e5933aec3cb

# virsh dumpxml instance-00000009 |grep disk
        <nova:disk>4</nova:disk>
    <disk type='block' device='disk'>
      <source dev='/dev/disk/by-path/pci-0000:81:00.0-fc-0x500009735018609f-lun-2'/>
      <alias name='virtio-disk0'/>
    </disk>
    <disk type='block' device='disk'>
      <source dev='/dev/disk/by-path/ip-192.168.0.1:3260-iscsi-iqn.1992-04.com.emc:cx.apm00xxxxxx-lun-1'/>
      <alias name='virtio-disk1'/>
    </disk>
Comment 8 Jaison Raju 2017-08-25 09:29:06 EDT
From what we see, the problem is that the multipath doesn't create any of these 2 symlinks "/dev/mapper/<WWN>" or "/dev/disk/by-id/dm-uuid-mpath-<WWN>",
which are the one os-brick is looking for.

Although in coming releases in Ocata, os-brick will no longer use that mechanism to detect the multipaths.
Once we test & pass this new package via the following bugs, you can confirm the new mechanism will work .
https://bugzilla.redhat.com/show_bug.cgi?id=1484431
https://bugzilla.redhat.com/show_bug.cgi?id=1443612

Note You need to log in before you can comment on or make changes to this bug.