This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 147914 - pygtk2-devel pyobject.h uses keywords in function prototypes
pygtk2-devel pyobject.h uses keywords in function prototypes
Status: CLOSED DUPLICATE of bug 144236
Product: Fedora
Classification: Fedora
Component: pygtk2 (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-12 13:58 EST by charles harris
Modified: 2013-03-13 00:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-14 16:30:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description charles harris 2005-02-12 13:58:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
The pygobject.h file uses the keyword 'typename' in function
prototypes. the offending entries are on lines 140 and 147. This gives
errors when I am compiling files that include this file. Changeing the
name fixes the problem.

Version-Release number of selected component (if applicable):
pygtk-devel-2.4.0-1

How reproducible:
Always

Steps to Reproduce:
1.install matplotlib from source.
2.
3.
    

Additional info:
Comment 1 David Juran 2005-02-22 11:29:27 EST
And of course this also hits RHEL4...
Comment 2 ajs 2005-04-08 13:12:45 EDT
This is fixed in PyGTK 2.4.1.  Can we get an update?

This is the same bug as https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=144236
Comment 3 John (J5) Palmieri 2005-04-14 16:30:29 EDT

*** This bug has been marked as a duplicate of 144236 ***

Note You need to log in before you can comment on or make changes to this bug.