Bug 1479341 - bodhi-client ≥ 2.9.0 hard-requires bash-completion
bodhi-client ≥ 2.9.0 hard-requires bash-completion
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bodhi (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Randy Barlow
Fedora Extras Quality Assurance
: Regression, Reopened
: 1481074 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-08 07:56 EDT by Petr Pisar
Modified: 2017-09-02 16:48 EDT (History)
4 users (show)

See Also:
Fixed In Version: bodhi-2.9.0-3.fc27 bodhi-2.9.0-4.fc26 bodhi-2.9.1-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-02 16:48:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2017-08-08 07:56:59 EDT
bodhi-client-2.9.0-1.fc27 and bodhi-client-2.9.0-2.fc27 requires bash-completion:

# rpm -q --requires bodhi-client-2.9.0-2.fc27 | grep completion
bash-completion

This is undesired behavior as it forces users to have bash completion in use. I personally don't like it because it breaks file completion in many cases for me.

Please revert the change back to weak dependency as used to be in bodhi-client-2.8.1-1.fc27.
Comment 1 Randy Barlow 2017-08-08 09:30:09 EDT
We can make it depend on filesystem instead.
Comment 2 Fedora Update System 2017-08-08 10:12:04 EDT
bodhi-2.9.0-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-5344219d81
Comment 3 Fedora Update System 2017-08-08 10:12:18 EDT
bodhi-2.9.0-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-5344219d81
Comment 4 Fedora Update System 2017-08-08 10:27:52 EDT
bodhi-2.9.0-3.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-6c94d5aee2
Comment 5 Fedora Update System 2017-08-11 20:20:57 EDT
bodhi-2.9.0-3.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-5344219d81
Comment 6 Fedora Update System 2017-08-13 00:02:58 EDT
bodhi-2.9.0-4.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-6c94d5aee2
Comment 7 Zing 2017-08-13 22:50:25 EDT
*** Bug 1481074 has been marked as a duplicate of this bug. ***
Comment 8 Fedora Update System 2017-08-14 17:51:39 EDT
bodhi-2.9.0-4.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2017-08-15 18:39:13 EDT
bodhi-2.9.1-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-5344219d81
Comment 10 Fedora Update System 2017-08-18 16:21:30 EDT
bodhi-2.9.1-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-5344219d81
Comment 11 Fedora Update System 2017-09-02 16:48:45 EDT
bodhi-2.9.1-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.