Bug 1479543 - SELinux prevents "gluster nfs-ganesha enable" from succeeding
SELinux prevents "gluster nfs-ganesha enable" from succeeding
Status: CLOSED DUPLICATE of bug 1470146
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: nfs-ganesha (Show other bugs)
3.2
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kaleb KEITHLEY
Manisha Saini
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-08 14:57 EDT by John Call
Modified: 2017-08-08 19:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-08 19:28:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from ausearch - please see 3 lines above/below Tue Aug 8 13:58:26 2017 (11.03 KB, text/x-vhdl)
2017-08-08 14:58 EDT, John Call
no flags Details
gdeploy - backend-setup (221 bytes, text/plain)
2017-08-08 14:59 EDT, John Call
no flags Details
gdeploy - volume create (420 bytes, text/plain)
2017-08-08 15:00 EDT, John Call
no flags Details
gdeploy - ganesha setup (284 bytes, text/plain)
2017-08-08 15:00 EDT, John Call
no flags Details

  None (edit)
Description John Call 2017-08-08 14:57:23 EDT
Description of problem:
Trying to enable nfs-ganesha via "gluster nfs-ganesha enable" fails when SELinux is enforcing.


Version-Release number of selected component (if applicable):
RHGS 3.2 / Glusterfs 3.8.4


How reproducible:
Basic install and used gdeploy to setup backend, create volume, and attempt to create ganesha cluster.


Actual results:
[root@gluster-1 ~]# gluster nfs-ganesha enable --mode=script
This will take a few minutes to complete. Please wait ..
nfs-ganesha: failed: Failed to set up HA config for NFS-Ganesha. Please check the log file for details

[root@gluster-1 ~]# setenforce 0

[root@gluster-1 ~]# gluster nfs-ganesha enable --mode=script
This will take a few minutes to complete. Please wait ..
nfs-ganesha : success



Additional info:
gdeploy files will be attached
output from ausearch command will be attached -- please see above (fail) and below (success) timestamp "time->Tue Aug  8 13:58:26 2017"
Comment 2 John Call 2017-08-08 14:58 EDT
Created attachment 1310810 [details]
output from ausearch - please see 3 lines above/below Tue Aug  8 13:58:26 2017

output from ausearch - please see 3 lines above/below Tue Aug  8 13:58:26 2017
Comment 3 John Call 2017-08-08 14:59 EDT
Created attachment 1310811 [details]
gdeploy - backend-setup
Comment 4 John Call 2017-08-08 15:00 EDT
Created attachment 1310812 [details]
gdeploy - volume create
Comment 5 John Call 2017-08-08 15:00 EDT
Created attachment 1310813 [details]
gdeploy - ganesha setup
Comment 6 John Call 2017-08-08 19:28:42 EDT

*** This bug has been marked as a duplicate of bug 1470146 ***

Note You need to log in before you can comment on or make changes to this bug.