Bug 1479562 - Crash when printing PDF
Crash when printing PDF
Status: CLOSED DUPLICATE of bug 1478537
Product: Fedora
Classification: Fedora
Component: cups-filters (Show other bugs)
26
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Zdenek Dohnal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-08 15:47 EDT by Tomasz Torcz
Modified: 2017-08-09 02:01 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-09 02:01:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomasz Torcz 2017-08-08 15:47:23 EDT
Description of problem:
When I try to print pdf – “lpr file.pdf” – filter pdftopdf crashes.
       Storage: /var/lib/systemd/coredump/core.pdftopdf.4.de3e9867e74f40ea931e716e6e5d8e28.63783.1502220133000000.lz4
       Message: Process 63783 (pdftopdf) of user 4 dumped core.                                                                                                              
                                                                                                                                                                             
                Stack trace of thread 63783:                                                                                                                                 
                #0  0x00007f17fd6a619f _int_malloc (libc.so.6)                                                                                                               
                #1  0x00007f17fd6a99b8 malloc (libc.so.6)                                                                                                                    
                #2  0x00007f17fdfab418 _Znwm (libstdc++.so.6)                                                                                                                
                #3  0x00007f17fe04010a _ZNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEE9_M_mutateEmmPKcm (libstdc++.so.6)
                #4  0x00007f17fe040e8b _ZNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEE10_M_replaceEmmPKcm (libstdc++.so.6)                                             
                #5  0x00007f17ffe1f43e _ZN15FileInputSource11setFilenameEPKc (libqpdf.so.17)                                                                                 
                #6  0x00007f17ffe35013 _ZN4QPDF11processFileEPKcS1_ (libqpdf.so.17)                                                                                                          #7  0x000000bd44400cd8 _ZN23QPDF_PDFTOPDF_Processor12loadFilenameEPKc (pdftopdf)                                                                             
                #8  0x000000bd443f75f4 main (pdftopdf)                                                                                                                                       #9  0x00007f17fd63d4da __libc_start_main (libc.so.6)                                                                                                         
                #10 0x000000bd443f782a _start (pdftopdf)


Reading symbols from /usr/lib/cups/filter/pdftopdf...Reading symbols from /usr/lib/debug/usr/lib/cups/filter/pdftopdf.debug...done.                                 [21/1885]
done.
[New LWP 63783]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
Core was generated by `HP-LaserJet-Professional-M1132-MFP 1572 root Przesyłka z chin.pdf 1 finishings'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0  _int_malloc (av=av@entry=0x7f17fd9e8ae0 <main_arena>, bytes=bytes@entry=31) at malloc.c:3517
3517              bck->fd = unsorted_chunks (av);
(gdb) bt
#0  _int_malloc (av=av@entry=0x7f17fd9e8ae0 <main_arena>, bytes=bytes@entry=31) at malloc.c:3517
#1  0x00007f17fd6a99b8 in __GI___libc_malloc (bytes=bytes@entry=31) at malloc.c:2890
#2  0x00007f17fdfab418 in operator new (sz=31) at ../../../../libstdc++-v3/libsupc++/new_op.cc:50
#3  0x00007f17fe04010a in std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >::_M_mutate (this=this@entry=0xbd464ab298, __pos=0,
    __len1=__len1@entry=0, __s=0x7ffe16bcfbc2 "/var/spool/cups/d01572-001", __len2=26)
    at /usr/src/debug/gcc-7.1.1-20170622/obj-x86_64-redhat-linux/x86_64-redhat-linux/libstdc++-v3/include/bits/basic_string.tcc:317
#4  0x00007f17fe040e8b in std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >::_M_replace (this=this@entry=0xbd464ab298, __pos=__pos@entry=0,
    __len1=0, __s=__s@entry=0x7ffe16bcfbc2 "/var/spool/cups/d01572-001", __len2=<optimized out>)
    at /usr/src/debug/gcc-7.1.1-20170622/obj-x86_64-redhat-linux/x86_64-redhat-linux/libstdc++-v3/include/bits/basic_string.tcc:466
#5  0x00007f17ffe1f43e in std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >::assign (__s=0x7ffe16bcfbc2 "/var/spool/cups/d01572-001",
    this=0xbd464ab298) at /usr/include/c++/7/bits/basic_string.h:1388
#6  std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >::operator= (__s=0x7ffe16bcfbc2 "/var/spool/cups/d01572-001", this=0xbd464ab298)
    at /usr/include/c++/7/bits/basic_string.h:667
#7  FileInputSource::setFilename (this=this@entry=0xbd464ab280, filename=filename@entry=0x7ffe16bcfbc2 "/var/spool/cups/d01572-001") at libqpdf/FileInputSource.cc:17
#8  0x00007f17ffe35013 in QPDF::processFile (this=this@entry=0xbd464abad0, filename=filename@entry=0x7ffe16bcfbc2 "/var/spool/cups/d01572-001", password=password@entry=0x0)
    at libqpdf/QPDF.cc:132
#9  0x000000bd44400cd8 in QPDF_PDFTOPDF_Processor::loadFilename (this=0xbd464b1f10, name=0x7ffe16bcfbc2 "/var/spool/cups/d01572-001")
    at filter/pdftopdf/qpdf_pdftopdf_processor.cc:427
#10 0x000000bd443f75f4 in main (argc=7, argv=0x7ffe16bcd8d8) at filter/pdftopdf/pdftopdf.cc:928


2017-08-08T20:54:24+0200 mother.pipebreaker.pl cupsd[1083]: Started filter /usr/lib/cups/filter/pdftopdf (PID 54996)
2017-08-08T20:54:24+0200 mother.pipebreaker.pl cupsd[1083]: Started filter /usr/lib/cups/filter/gstoraster (PID 54997)
2017-08-08T20:54:24+0200 mother.pipebreaker.pl cupsd[1083]: Started filter /usr/lib/cups/filter/hpcups (PID 54998)
2017-08-08T20:54:24+0200 mother.pipebreaker.pl cupsd[1083]: Started backend /usr/lib/cups/backend/hp (PID 54999)
2017-08-08T20:54:24+0200 mother.pipebreaker.pl cupsd[1083]: REQUEST localhost - - "POST /printers/HP-LaserJet-Professional-M1132-MFP HTTP/1.1" 200 202628 Send-Document succe
2017-08-08T20:54:24+0200 mother.pipebreaker.pl cupsd[1083]: STATE: -marker-supply-low-warning
2017-08-08T20:54:24+0200 mother.pipebreaker.pl cupsd[1083]: pdftopdf: Last filter determined by the PPD: hpcups; FINAL_CONTENT_TYPE: application/vnd.cups-raster => pdftopdf 
2017-08-08T20:54:24+0200 mother.pipebreaker.pl cupsd[1083]: OUTFORMAT=\"(null)\", so output format will be CUPS/PWG Raster
2017-08-08T20:54:25+0200 mother.pipebreaker.pl cupsd[1083]: PID 54996 (/usr/lib/cups/filter/pdftopdf) crashed on signal 11.
2017-08-08T20:54:25+0200 mother.pipebreaker.pl cupsd[1083]: Hint: Try setting the LogLevel to "debug" to find out more.
2017-08-08T20:54:25+0200 mother.pipebreaker.pl cupsd[1083]: Can\'t detect file type


Version-Release number of selected component (if applicable):
cups-filters-1.13.4-2.fc26.x86_64
Comment 1 Scott Tsai 2017-08-08 23:00:19 EDT
This crash is related to the qpdf-libs 6.0.0-5 => 6.0.0-6 update.
Downgrading to qpdf-libs-6.0.0-5 ("dnf downgrade qpdf-libs") can avoid the crash.
Comment 2 Zdenek Dohnal 2017-08-09 02:01:24 EDT
Or updating to qpdf-libs-6.0.0-7 from updates-testing repository. I do not know why bodhi still keeps this critical update in "submitted to stable" state. I am deeply sorry for inconvenience. Closing as duplicate.

*** This bug has been marked as a duplicate of bug 1478537 ***

Note You need to log in before you can comment on or make changes to this bug.