Bug 1479710 - [brick-mux-cli]: Requesting for a clear warning on the recommendation during toggling of brick-mux option
[brick-mux-cli]: Requesting for a clear warning on the recommendation during ...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: cli (Show other bugs)
3.3
x86_64 Linux
unspecified Severity urgent
: ---
: RHGS 3.3.0
Assigned To: Samikshan Bairagya
nchilaka
:
Depends On:
Blocks: 1417151 1479749
  Show dependency treegraph
 
Reported: 2017-08-09 04:57 EDT by Rahul Hinduja
Modified: 2017-09-21 01:04 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.8.4-39
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1479749 (view as bug list)
Environment:
Last Closed: 2017-09-21 01:04:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rahul Hinduja 2017-08-09 04:57:27 EDT
Description of problem:

Brick Multiplex option: cluster.brick-multiplex => on/off => Default Off

Recommendation:

Brick compatibility is determined at volume start, and depends on volume options shared between bricks. When multiplexing is enabled, Red Hat recommends restarting volumes whenever volume configuration is changed in order to maintain the compatibility of the bricks grouped under a single process. 

Problem: 

The recommendation is rightly mentioned in the documentaion. However since the option is available for admins to use, it would be good to warn the admin at cli validation level and print the following message: 

1. When multiplexing is enabled/disabled, it is recommended to restart the volumes in order to maintain compatibility of bricks. 
2. This is only supported for containerized use cases.
Do you want to proceed (y/n)

Because if user enables/disables this option without restarting the bricks we might end up in unknown issues. 


Version-Release number of selected component (if applicable):
=============================================================

glusterfs-3.8.4-38.el7rhgs.x86_64

Steps to Reproduce:
===================

gluster volume set volume cluster.brick-multiplex on/off

Actual results:
===============

volume set is successful without warning.

Expected results:
=================

It would be good to warn or inform the user about recommendation.
Comment 4 Samikshan Bairagya 2017-08-09 05:22:23 EDT
Downstream patch: https://code.engineering.redhat.com/gerrit/#/c/114793/
Comment 6 nchilaka 2017-08-09 06:03:38 EDT
Also, should we be telling that brick mux  is for CNS environment ?
Comment 9 nchilaka 2017-08-09 11:14:20 EDT
test on 3.8.4-39
seeing below warning, which looks good
[root@dhcp35-45 ~]# gluster v get all all
gOption                                  Value                                   
------                                  -----                                   
cluster.server-quorum-ratio             51                                      
cluster.enable-shared-storage           disable                                 
cluster.op-version                      31101                                   
cluster.brick-multiplex                 disable                                 
cluster.max-bricks-per-process          0                                       
[root@dhcp35-45 ~]# gluster v set all cluster.max-bricks-per-process 1
volume set: failed: Brick-multiplexing is not enabled. Please enable brick multiplexing before trying to set this option.
[root@dhcp35-45 ~]# gluster v set all cluster.brick-multiplex on
Brick-multiplexing is supported only for container workloads (CNS/CRS). Also it is advised to make sure that either all volumes are in stopped state or no bricks are running before this option is modified.Do you still want to continue? (y/n) n
Aborted by user.
[root@dhcp35-45 ~]# gluster v set all cluster.brick-multiplex on
Brick-multiplexing is supported only for container workloads (CNS/CRS). Also it is advised to make sure that either all volumes are in stopped state or no bricks are running before this option is modified.Do you still want to continue? (y/n) y
volume set: success
[root@dhcp35-45 ~]# gluster v set all cluster.brick-multiplex off
Brick-multiplexing is supported only for container workloads (CNS/CRS). Also it is advised to make sure that either all volumes are in stopped state or no bricks are running before this option is modified.Do you still want to continue? (y/n) y
volume set: success
[root@dhcp35-45 ~]# rpm -qa|grep gluster
glusterfs-client-xlators-3.8.4-39.el7rhgs.x86_64
glusterfs-rdma-3.8.4-39.el7rhgs.x86_64
glusterfs-cli-3.8.4-39.el7rhgs.x86_64
glusterfs-libs-3.8.4-39.el7rhgs.x86_64
glusterfs-events-3.8.4-39.el7rhgs.x86_64
glusterfs-fuse-3.8.4-39.el7rhgs.x86_64
python-gluster-3.8.4-39.el7rhgs.noarch
glusterfs-debuginfo-3.8.4-39.el7rhgs.x86_64
glusterfs-server-3.8.4-39.el7rhgs.x86_64
glusterfs-3.8.4-39.el7rhgs.x86_64
glusterfs-geo-replication-3.8.4-39.el7rhgs.x86_64
glusterfs-api-3.8.4-39.el7rhgs.x86_64
[root@dhcp35-45 ~]# 



Hence moving to verified
Comment 12 errata-xmlrpc 2017-09-21 01:04:21 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2774

Note You need to log in before you can comment on or make changes to this bug.