Bug 1479723 - maintenance_interval is different from the value in the configuration option
maintenance_interval is different from the value in the configuration option
Status: CLOSED DUPLICATE of bug 1486928
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-networking-odl (Show other bugs)
12.0 (Pike)
Unspecified Unspecified
high Severity high
: beta
: 12.0 (Pike)
Assigned To: Mike Kolesnik
Itzik Brown
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-09 05:31 EDT by Itzik Brown
Modified: 2017-10-18 04:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-18 04:41:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1709580 None None None 2017-08-09 05:31 EDT
OpenStack gerrit 496125 None None None 2017-09-03 01:35 EDT

  None (edit)
Description Itzik Brown 2017-08-09 05:31:26 EDT
Description of problem:
I'm using the default maintenance_interval:

# grep maintenance_interval /var/log/neutron/server.log
2017-08-09 09:22:25.953 727534 DEBUG oslo_service.service [-] ml2_odl.maintenance_interval = 300 log_opt_values /usr/lib/python2.7/site-packages/oslo_config/cfg.py:2887
2017-08-09 09:22:26.004 727534 DEBUG oslo_service.service [-] ml2_odl.maintenance_interval = 300 log_opt_values /usr/lib/python2.7/site-packages/oslo_config/cfg.py:2887

But the full sync happens every 30 seconds:

# grep full_sync /var/log/neutron/server.log
2017-08-09 09:23:25.498 727534 INFO networking_odl.journal.periodic_task [req-eebad18b-31d6-4fc5-a0f8-b358e54fc2c2 - - - - -] Starting full_sync phase of periodic task maintenance.
2017-08-09 09:23:25.513 727534 INFO networking_odl.journal.periodic_task [req-eebad18b-31d6-4fc5-a0f8-b358e54fc2c2 - - - - -] Finished full_sync phase of maintenance task.
2017-08-09 09:23:55.503 727534 INFO networking_odl.journal.periodic_task [req-eebad18b-31d6-4fc5-a0f8-b358e54fc2c2 - - - - -] Starting full_sync phase of periodic task maintenance.
2017-08-09 09:23:55.518 727534 INFO networking_odl.journal.periodic_task [req-eebad18b-31d6-4fc5-a0f8-b358e54fc2c2 - - - - -] Finished full_sync phase of maintenance task.
2017-08-09 09:24:25.505 727534 INFO networking_odl.journal.periodic_task [req-eebad18b-31d6-4fc5-a0f8-b358e54fc2c2 - - - - -] Starting full_sync phase of periodic task maintenance.
2017-08-09 09:24:25.520 727534 INFO networking_odl.journal.periodic_task [req-eebad18b-31d6-4fc5-a0f8-b358e54fc2c2 - - - - -] Finished full_sync phase of maintenance task.
2017-08-09 09:24:55.507 727534 INFO networking_odl.journal.periodic_task [req-eebad18b-31d6-4fc5-a0f8-b358e54fc2c2 - - - - -] Starting full_sync phase of periodic task maintenance.
2017-08-09 09:24:55.522 727534 INFO networking_odl.journal.periodic_task [req-eebad18b-31d6-4fc5-a0f8-b358e54fc2c2 - - - - -] Finished full_sync phase of maintenance task.
2017-08-09 09:25:25.509 727534 INFO networking_odl.journal.periodic_task [req-eebad18b-31d6-4fc5-a0f8-b358e54fc2c2 - - - - -] Starting full_sync phase of periodic task maintenance.
2017-08-09 09:25:25.525 727534 INFO networking_odl.journal.periodic_task [req-eebad18b-31d6-4fc5-a0f8-b358e54fc2c2 - - - - -] Finished full_sync phase of maintenance task.
2017-08-09 09:25:55.512 727534 INFO networking_odl.journal.periodic_task [req-eebad18b-31d6-4fc5-a0f8-b358e54fc2c2 - - - - -] Starting full_sync phase of periodic task maintenance.
2017-08-09 09:25:55.527 727534 INFO networking_odl.journal.periodic_task [req-eebad18b-31d6-4fc5-a0f8-b358e54fc2c2 - - - - -] Finished full_sync phase of maintenance task.
2017-08-09 09:26:25.523 727534 INFO networking_odl.journal.periodic_task [req-eebad18b-31d6-4fc5-a0f8-b358e54fc2c2 - - - - -] Starting full_sync phase of periodic task maintenance.
2017-08-09 09:26:25.540 727534 INFO networking_odl.journal.periodic_task [req-eebad18b-31d6-4fc5-a0f8-b358e54fc2c2 - - - - -] Finished full_sync phase of maintenance task.
2017-08-09 09:26:55.521 727534 INFO networking_odl.journal.periodic_task [req-eebad18b-31d6-4fc5-a0f8-b358e54fc2c2 - - - - -] Starting full_sync phase of periodic task maintenance.
2017-08-09 09:26:55.538 727534 INFO networking_odl.journal.periodic_task [req-eebad18b-31d6-4fc5-a0f8-b358e54fc2c2 - - - - -] Finished full_sync phase of maintenance task.
2017-08-09 09:27:25.516 727534 INFO networking_odl.journal.periodic_task [req-eebad18b-31d6-4fc5-a0f8-b358e54fc2c2 - - - - -] Starting full_sync phase of periodic task maintenance.
2017-08-09 09:27:25.530 727534 INFO networking_odl.journal.periodic_task [req-eebad18b-31d6-4fc5-a0f8-b358e54fc2c2 - - - - -] Finished full_sync phase of maintenance task.
2017-08-09 09:27:55.519 727534 INFO networking_odl.journal.periodic_task [req-eebad18b-31d6-4fc5-a0f8-b358e54fc2c2 - - - - -] Starting full_sync phase of periodic task maintenance.
2017-08-09 09:27:55.534 727534 INFO networking_odl.journal.periodic_task [req-eebad18b-31d6-4fc5-a0f8-b358e54fc2c2 - - - - -] Finished full_sync phase of maintenance task.



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Mike Kolesnik 2017-10-18 04:41:11 EDT

*** This bug has been marked as a duplicate of bug 1486928 ***

Note You need to log in before you can comment on or make changes to this bug.