Bug 1486928 - maintenance_interval is not being honored by journal maintenance thread
Summary: maintenance_interval is not being honored by journal maintenance thread
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-networking-odl
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 12.0 (Pike)
Assignee: Mike Kolesnik
QA Contact: Itzik Brown
URL:
Whiteboard:
: 1479723 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-30 19:45 UTC by Sai Sindhur Malleni
Modified: 2018-10-18 07:19 UTC (History)
5 users (show)

Fixed In Version: python-networking-odl-11.0.1-0.20170831202719.81010b8.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
N/A
Last Closed: 2017-12-13 21:59:22 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1709580 0 None None None 2017-10-18 07:27:43 UTC
OpenStack gerrit 496125 0 None None None 2017-08-30 19:48:32 UTC
Red Hat Product Errata RHEA-2017:3462 0 normal SHIPPED_LIVE Red Hat OpenStack Platform 12.0 Enhancement Advisory 2018-02-16 01:43:25 UTC

Description Sai Sindhur Malleni 2017-08-30 19:45:26 UTC
Description of problem:


Version-Release number of selected component (if applicable):
python-networking-odl-11.0.0-0.20170806093629.2e78dca.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy OSP12 with networking-odl 
2. Changing the value of maintenance_interval has no affect


Actual results:
The maintenance thread continues to run at default interval even if the maintenance_interval option is changed

Expected results:
The maintenance thread should honor the maintenance_interval config option

Additional info:
The code is python-networking-odl-11.0.0-0.20170806093629.2e78dca.el7ost.noarch still doesn't carry https://review.openstack.org/#/c/496125/

We need to merge this upstream backport and also release a new downstream RPM with the change.

Comment 1 Sai Sindhur Malleni 2017-08-30 19:47:14 UTC
Description of problem: The maintenance_interval option is not being honored by the journaling thread.

Comment 2 Mike Kolesnik 2017-09-03 12:15:33 UTC
I see this has been merged upstream over the weekend, will be monitoring when it hits the downstream RPM.

Comment 3 Mike Kolesnik 2017-10-18 08:41:11 UTC
*** Bug 1479723 has been marked as a duplicate of this bug. ***

Comment 6 Itzik Brown 2017-11-05 11:11:24 UTC
Checked with:
python-networking-odl-11.0.1-0.20171017155938.a0cb8d9.el7ost.noarch

Changed maintenance_interval=420 under ml2_odl in /etc/neutron/plugin.ini.
Checked that the maintenance happens every 7 minutes.

Comment 9 errata-xmlrpc 2017-12-13 21:59:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462


Note You need to log in before you can comment on or make changes to this bug.