This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1479784 - CUPS crashes on printing any file on F26 fully updated (with no qpdf installed)
CUPS crashes on printing any file on F26 fully updated (with no qpdf installed)
Status: CLOSED DUPLICATE of bug 1478537
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
26
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Zdenek Dohnal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-09 08:00 EDT by Gerard Fernandes
Modified: 2017-08-14 06:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-09 09:30:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerard Fernandes 2017-08-09 08:00:38 EDT
Description of problem: CUPS crashes on attempting to print any file. More specifically, _pdftopdf_ crashes.

There seems to be a related report, but that seems to indicate the problem is in _qpdf_, that I do not have installed on my machine.


Version-Release number of selected component (if applicable): 2.2.2.6.FC26


How reproducible: Always


Steps to Reproduce:
1. Open any PDF file in the default PDF viewer on Gnome
2. Cntrl-P to print, click print
3. Fails - the Printers dialog shows the job failed with a filter failure.

Actual results:
Consistently fails to print. Definitely a CUPS/driver problem as this same printer works on Win-10.


Expected results:
Should print (used to print until a few days back).


Additional info:
Printer is a Samsung 242x network monochrome laser, attached to the same internal home network as the computer I'm printing from.

Removing and adding the printer again has no effect - still fails.
Removing and re-installing the printer PPD has no effect - still fails.
Comment 1 Gerard Fernandes 2017-08-09 08:02:17 EDT
journald log:
===========================
Aug 09 12:40:38 achiles.home.lan cupsd[1949]: Printer model: Samsung M262x 282x Foomatic/pxlmono
Aug 09 12:40:38 achiles.home.lan cupsd[1949]: Job title: 11+Maths_10-11_M6QDE1_Test1.pdf
Aug 09 12:40:38 achiles.home.lan cupsd[1949]: File(s) to be printed:
Aug 09 12:40:38 achiles.home.lan cupsd[1949]: <STDIN>
Aug 09 12:40:38 achiles.home.lan cupsd[1949]: Ghostscript extra search path (\'GS_LIB\'): /usr/share/cups/fonts
Aug 09 12:40:38 achiles.home.lan cupsd[1949]: Printing system options:
Aug 09 12:40:38 achiles.home.lan cupsd[1949]: Pondering option \'number-up=1\'
Aug 09 12:40:38 achiles.home.lan cupsd[1949]: Unknown option number-up=1.
Aug 09 12:40:38 achiles.home.lan cupsd[1949]: Pondering option \'noCollate\'
Aug 09 12:40:38 achiles.home.lan cupsd[1949]: Unknown boolean option \"noCollate\".
Aug 09 12:40:38 achiles.home.lan cupsd[1949]: Pondering option \'job-uuid=urn:uuid:48ecd97d-a197-3676-48ee-b793b3cb8186\'
Aug 09 12:40:38 achiles.home.lan cupsd[1949]: Unknown option job-uuid=urn:uuid:48ecd97d-a197-3676-48ee-b793b3cb8186.
Aug 09 12:40:38 achiles.home.lan cupsd[1949]: Pondering option \'job-originating-host-name=localhost\'
Aug 09 12:40:38 achiles.home.lan cupsd[1949]: Unknown option job-originating-host-name=localhost.
Aug 09 12:40:38 achiles.home.lan cupsd[1949]: Pondering option \'date-time-at-creation=\'
Aug 09 12:40:38 achiles.home.lan cupsd[1949]: Unknown option date-time-at-creation=.
Aug 09 12:40:38 achiles.home.lan cupsd[1949]: Pondering option \'date-time-at-processing=\'
Aug 09 12:40:38 achiles.home.lan cupsd[1949]: Unknown option date-time-at-processing=.
Aug 09 12:40:38 achiles.home.lan cupsd[1949]: Pondering option \'time-at-creation=1502278838\'
Aug 09 12:40:38 achiles.home.lan cupsd[1949]: Unknown option time-at-creation=1502278838.
Aug 09 12:40:38 achiles.home.lan cupsd[1949]: Pondering option \'time-at-processing=1502278838\'
Aug 09 12:40:38 achiles.home.lan cupsd[1949]: Unknown option time-at-processing=1502278838.
Aug 09 12:40:38 achiles.home.lan cupsd[1949]: CM Color Calibration Mode in CUPS: Off
Aug 09 12:40:38 achiles.home.lan cupsd[1949]: Options from the PPD file:
Aug 09 12:40:38 achiles.home.lan cupsd[1949]: Pondering option \'InputSlot=Default\'
Aug 09 12:40:38 achiles.home.lan cupsd[1949]: Pondering option \'PageSize=A4\'
Aug 09 12:40:38 achiles.home.lan cupsd[1949]: Pondering option \'PrintoutMode=High\'
Aug 09 12:40:38 achiles.home.lan cupsd[1949]: Pondering option \'PrinterResolution=FromPrintoutMode\'
Aug 09 12:40:38 achiles.home.lan cupsd[1949]: Pondering option \'Duplex=DuplexNoTumble\'
Aug 09 12:40:38 achiles.home.lan cupsd[1949]: ================================================
Aug 09 12:40:38 achiles.home.lan cupsd[1949]: File: <STDIN>
Aug 09 12:40:38 achiles.home.lan cupsd[1949]: ================================================
Aug 09 12:40:38 achiles.home.lan systemd[1]: Created slice system-systemd\x2dcoredump.slice.
Aug 09 12:40:38 achiles.home.lan systemd[1]: Started Process Core Dump (PID 3249/UID 0).
Aug 09 12:40:38 achiles.home.lan audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='uni
Aug 09 12:40:38 achiles.home.lan cupsd[1949]: Cannot process \"<STDIN>\": Unknown filetype.
Aug 09 12:40:38 achiles.home.lan cupsd[1949]: Process is dying with \"Could not print file <STDIN>
Aug 09 12:40:38 achiles.home.lan cupsd[1949]: \", exit stat 2
Aug 09 12:40:38 achiles.home.lan cupsd[1949]: Cleaning up...
Aug 09 12:40:38 achiles.home.lan cupsd[1949]: PID 3246 (/usr/lib/cups/filter/pdftopdf) crashed on signal 11.
Aug 09 12:40:38 achiles.home.lan cupsd[1949]: Hint: Try setting the LogLevel to "debug" to find out more.
Aug 09 12:40:38 achiles.home.lan cupsd[1949]: PID 3247 (/usr/lib/cups/filter/foomatic-rip) stopped with status 2.
Aug 09 12:40:38 achiles.home.lan cupsd[1949]: Hint: Try setting the LogLevel to "debug" to find out more.
Aug 09 12:40:38 achiles.home.lan systemd-coredump[3250]: Process 3246 (pdftopdf) of user 4 dumped core.
                                                         
                                                         Stack trace of thread 3246:
                                                         #0  0x00007fab42cc319f _int_malloc (libc.so.6)
                                                         #1  0x00007fab42cc69b8 malloc (libc.so.6)
                                                         #2  0x00007fab42cac0dd __fopen_internal (libc.so.6)
                                                         #3  0x00007fab454a3c80 _ZN5QUtil10safe_fopenEPKcS1_ (libqpdf.so.17)
                                                         #4  0x00007fab4543c452 _ZN15FileInputSource11setFilenameEPKc (libqpdf.so.17)
                                                         #5  0x00007fab45452013 _ZN4QPDF11processFileEPKcS1_ (libqpdf.so.17)
                                                         #6  0x000055bd2e3b7cd8 _ZN23QPDF_PDFTOPDF_Processor12loadFilenameEPKc (pdftopdf)
                                                         #7  0x000055bd2e3ae5f4 main (pdftopdf)
                                                         #8  0x00007fab42c5a4da __libc_start_main (libc.so.6)
                                                         #9  0x000055bd2e3ae82a _start (pdftopdf)
Aug 09 12:40:38 achiles.home.lan audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit
Aug 09 12:40:39 achiles.home.lan abrt-server[3256]: Deleting problem directory ccpp-2017-08-09-12:40:39.139746-805 (dup of ccpp-2017-08-09-10
Aug 09 12:40:39 achiles.home.lan cupsd[1949]: Resolved as \"lpd://192.168.1.120:515/auto\"...
Aug 09 12:40:39 achiles.home.lan cupsd[1949]: STATE: -connecting-to-device,offline-report
Aug 09 12:40:39 achiles.home.lan cupsd[1949]: Executing backend \"/usr/lib/cups/backend/lpd\"...
Aug 09 12:40:39 achiles.home.lan cupsd[1949]: STATE: +connecting-to-device
Aug 09 12:40:39 achiles.home.lan cupsd[1949]: Looking up \"192.168.1.120\"...
Aug 09 12:40:39 achiles.home.lan cupsd[1949]: STATE: -connecting-to-device
Aug 09 12:40:39 achiles.home.lan cupsd[1949]: 192.168.1.120=192.168.1.120
Aug 09 12:40:39 achiles.home.lan cupsd[1949]: backendWaitLoop(snmp_fd=6, addr=0x561e8f12d108, side_cb=0x561e8db5ab90)
Aug 09 12:40:39 achiles.home.lan cupsd[1949]: PID 3248 (/usr/lib/cups/backend/dnssd) exited with no errors.
Aug 09 12:40:39 achiles.home.lan cupsd[1949]: Job stopped due to filter errors; please consult the error_log file for details.
Aug 09 12:40:39 achiles.home.lan abrt-notification[3301]: Process 5507 (pdftopdf) crashed in malloc()
Aug 09 12:40:40 achiles.home.lan cupsd[1949]: Unloading...
Comment 2 Gerard Fernandes 2017-08-09 08:03:15 EDT
CUPS version
==============
Last metadata expiration check: 2:20:39 ago on Wed 09 Aug 2017 10:35:54 BST.
Installed Packages
Name         : cups
Epoch        : 1
Version      : 2.2.2
Release      : 6.fc26
Arch         : x86_64

QPDF not installed
=====================
Last metadata expiration check: 2:20:39 ago on Wed 09 Aug 2017 10:35:54 BST.
Installed Packages
Name         : cups
Epoch        : 1
Version      : 2.2.2
Release      : 6.fc26
Arch         : x86_64
Comment 3 Gerard Fernandes 2017-08-09 08:04:17 EDT
 
 QPDF not installed
 =====================
> Last metadata expiration check: 2:20:39 ago on Wed 09 Aug 2017 10:35:54 BST.
> Installed Packages
> Name         : cups
> Epoch        : 1
> Version      : 2.2.2
> Release      : 6.fc26
> Arch         : x86_64

should read:

*Available Packages*
Name         : qpdf
Version      : 6.0.0
Release      : 6.fc26
Arch         : x86_64
Size         : 46 k
Comment 4 Zdenek Dohnal 2017-08-09 09:30:32 EDT
Hi Gerard,

it is problem with component qpdf, precisely with its subpackage qpdf-libs (you can see that you have qpdf-libs installed from stacktrace), which you have installed with cups-filters and cups-filters is installed with cups. So when you update qpdf-libs to release in updates-testing repository or downgrade to previous release. Closing as duplicate.

*** This bug has been marked as a duplicate of bug 1478537 ***
Comment 5 Gerard Fernandes 2017-08-09 10:10:52 EDT
Thats right - I was looking for package "qpdf" and not "qpdf-libs".

Downgrading "qpdf-libs" results in the printer working again.

Thanks very much!
Comment 6 Zdenek Dohnal 2017-08-14 06:53:11 EDT
Resolution NOTABUG stands for issue, which is not bug. This issue was really a bug, but it was same as #1478537. That's why resolution was "duplicate". Changing back to duplicate.

*** This bug has been marked as a duplicate of bug 1478537 ***

Note You need to log in before you can comment on or make changes to this bug.