Bug 1480072 - [UI] - Cannot read property 'document' of null - When moving from DC>QoS to any another section
[UI] - Cannot read property 'document' of null - When moving from DC>QoS to a...
Status: CLOSED DUPLICATE of bug 1478887
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
4.2.0
x86_64 Linux
unspecified Severity medium (vote)
: ---
: ---
Assigned To: bugs@ovirt.org
Pavel Stehlik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-10 01:43 EDT by Michael Burman
Modified: 2017-08-13 17:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-13 17:54:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: UX
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ui log (35.02 KB, application/x-gzip)
2017-08-10 01:43 EDT, Michael Burman
no flags Details
record1 (898.66 KB, application/x-gzip)
2017-08-10 01:46 EDT, Michael Burman
no flags Details

  None (edit)
Description Michael Burman 2017-08-10 01:43:13 EDT
Created attachment 1311536 [details]
ui log

Description of problem:
[UI] - Cannot read property 'document' of null - When moving from DC>QoS to any another section.

A ui exception is thrown when moving from DC>QoS to any other section in the webamdin portal. 

2017-08-10 08:35:26,371+03 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-5) [] Permutation name: ACE2D63A1980E87AF16B317C1BE4C334
2017-08-10 08:35:26,371+03 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-5) [] Uncaught exception: com.google.gwt.event.shared.UmbrellaException: Exception caught: (TypeError) : Cannot read property 'document' of null
        at java.lang.Throwable.Throwable(Throwable.java:70) [rt.jar:1.8.0_131]
        at java.lang.RuntimeException.RuntimeException(RuntimeException.java:32) [rt.jar:1.8.0_131]
        at com.google.web.bindery.event.shared.UmbrellaException.UmbrellaException(UmbrellaException.java:64) [gwt-servlet.jar:]
        at com.google.gwt.event.shared.UmbrellaException.UmbrellaException(UmbrellaException.java:25) [gwt-servlet.jar:]
        at com.google.gwt.event.shared.HandlerManager.$fireEvent(HandlerManager.java:117) [gwt-servlet.jar:]
        at com.google.gwt.event.logical.shared.ResizeEvent.fire(ResizeEvent.java:40) [gwt-servlet.jar:]
        at com.google.gwt.user.client.Window.onResize(Window.java:862) [gwt-servlet.jar:]
        at Unknown.eval(webadmin-0.js)

Version-Release number of selected component (if applicable):
4.2.0-0.0.master.20170809175855.git1082d9d.el7.centos

How reproducible:
100%

Steps to Reproduce:
1. Enter the webadmin UI and go to DC > QoS
2. Go to any other section - Compute, Network, Storage and so on

Actual results:
A ui exception is thrown

Expected results:
No exceptions.
Comment 1 Michael Burman 2017-08-10 01:46 EDT
Created attachment 1311537 [details]
record1
Comment 2 Greg Sheremeta 2017-08-13 17:54:08 EDT

*** This bug has been marked as a duplicate of bug 1478887 ***

Note You need to log in before you can comment on or make changes to this bug.