Bug 1480106 - Mouse Speed behaviour in Gnome altered after updating to RHEL 7.4
Mouse Speed behaviour in Gnome altered after updating to RHEL 7.4
Status: CLOSED DUPLICATE of bug 1478397
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-settings-daemon (Show other bugs)
7.4
x86_64 Linux
unspecified Severity low
: rc
: ---
Assigned To: Rui Matos
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-10 03:44 EDT by Nikola
Modified: 2017-08-16 10:20 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-16 10:20:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nikola 2017-08-10 03:44:30 EDT
Description of problem:
Just updated from RHEL 7.3 to RHEL 7.4

Problem 1 - Setting the 'Mouse Speed' in Gnome Settings for Mouse & Touchpad is broken. No matter what slider value is set, the speed of the pointer does not change at all.
Considering I have three screens to move through, I will either become very strong or very tired very soon.

Problem 2 - While thinking of switching to my laptop Touchpad while I figure the mouse problem out, and discover that 'Two-finger Scrolling' is now inverted??!! Scrolling down moves the page up and vice-versa. Why? Are the majority of users pilots?

Version-Release number of selected component (if applicable):
gnome-desktop3-3.22.2-2.el7.x86_64
kernel 3.10.0-693.el7.x86_64


How reproducible:
Easy

Steps to Reproduce:
1. Update to RHEL 7.4
2. Change Mouse Speed to any slider value
3. Observe that nothing changes
4. Use a laptop touchpad and try scrolling with the two-finger method
5. Enjoy the confusion for a few moments

Actual results:
as described above

Expected results:
Mouse speed should be affected by the slider settings.
Two-finger scrolling with the laptop touchpad should be reverted back to the 'natural' way of scrolling, i.e. down for down and up for up.

Additional info:
Let me know if you'll need more details.
I might have selected an inappropriate Product Component - please triage properly in case of a mistake.
Comment 2 Nikola 2017-08-10 05:21:11 EDT
UPDATE:
Ooops, Please ignore the second problem - found the new setting "Natural Scrolling" for the touchpad is responsible for the inverted scrolling.

The speed of the pointer is still a valid issue though. 

(I have modified the bug summary description)
Comment 3 Rui Matos 2017-08-16 10:20:20 EDT

*** This bug has been marked as a duplicate of bug 1478397 ***

Note You need to log in before you can comment on or make changes to this bug.