Bug 1478397 - unable to change mouse settings via gui tool
Summary: unable to change mouse settings via gui tool
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: mutter
Version: 7.4
Hardware: x86_64
OS: Linux
high
medium
Target Milestone: rc
: ---
Assignee: Florian Müllner
QA Contact: Desktop QE
URL:
Whiteboard:
: 1480106 1480372 1486435 1492643 1513622 (view as bug list)
Depends On:
Blocks: 1420851 1477211 1479818 1513622 1515138
TreeView+ depends on / blocked
 
Reported: 2017-08-04 13:38 UTC by Joe Wright
Modified: 2019-04-16 14:59 UTC (History)
21 users (show)

Fixed In Version: mutter-3.26.1-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1513622 1515138 (view as bug list)
Environment:
Last Closed: 2018-04-10 12:57:41 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3166951 None None None 2017-11-14 16:15:34 UTC
Red Hat Product Errata RHBA-2018:0770 None None None 2018-04-10 12:59:16 UTC

Description Joe Wright 2017-08-04 13:38:23 UTC
Description of problem:
- After updating to 7.4, the mouse settings have no effect when changed

Version-Release number of selected component (if applicable):
7.4 GA

How reproducible:


Steps to Reproduce:
1. press the "super" key on the keyboard
2. locate "Settings" in the applications panel 
3. Choose the "Mouse and Touchpad" icon
4. Attempt to make changes to mouse settings

Actual results:
- Changing settings in the "Mouse and Touchpad" have no effect whasoever

Expected results:
- Mouse behavior changes based on the configured settings

Additional info:

Comment 10 Rui Matos 2017-08-16 14:20:20 UTC
*** Bug 1480106 has been marked as a duplicate of this bug. ***

Comment 11 Rui Matos 2017-08-16 14:20:39 UTC
*** Bug 1480372 has been marked as a duplicate of this bug. ***

Comment 12 Laurent Wandrebeck 2017-08-29 08:54:24 UTC
Confirmed here. CentOS 7.4.
Used to work fine in 7.3 (I’m left handed, main button is the right one to me).
Update to 7.4, main button became the left one, and gnome app does not change anything.

Comment 13 Jiri Koten 2017-08-29 13:45:38 UTC
Changing mouse settings in control center doesn't work with the default evdev drivers, but is working fine with libinput driver.

To use libinput in X.Org the xorg-x11-drv-libinput driver is required.

Comment 14 Vladimir Benes 2017-08-29 19:48:50 UTC
*** Bug 1486435 has been marked as a duplicate of this bug. ***

Comment 23 Tomas Pelka 2017-11-16 09:45:27 UTC
*** Bug 1513622 has been marked as a duplicate of this bug. ***

Comment 26 Michael DePaulo 2017-11-30 14:59:13 UTC
As Jiri Koten instructed, I fixed this issue for a RHEL 7.4 user by installing the package:
xorg-x11-drv-libinput
It pulled in the dependency:
libinput

We did not have to reboot; we only had to log out of gnome & log back in. Although libinput does install udev rules.

Note that xorg-x11-drv-libinput provides:
/usr/share/X11/xorg.conf.d/40-libinput.conf
If you have an xorg.conf or xorg.conf.d file with:
Section "InputClass"
It might interefere.

Comment 27 Peter Hutterer 2017-12-19 03:54:16 UTC
> It pulled in the dependency:
> libinput

That is correct behaviour, the xorg-x11-drv-libinput driver is a thin wrapper around libinput itself which does all the heavy lifting.

> We did not have to reboot; we only had to log out of gnome & log back in. Although libinput does install udev rules.

For your use-case the udev rules don't matter too much and after the next reboot (or plugging in of devices) they will apply. 


> Note that xorg-x11-drv-libinput provides:
> /usr/share/X11/xorg.conf.d/40-libinput.conf
> If you have an xorg.conf or xorg.conf.d file with:
> Section "InputClass"
> It might interefere.

The default ordering of the drivers in RHEL7 is that xorg-x11-drv-synaptics sorts higher than xorg-x11-drv-libinput and thus takes precedence. This was chosen because libinput's touchpad behaviour is somewhat different to synaptics' and we didn't want users to have to adjust to a new behaviour. This doesn't apply in the same extent the mouse/keyboard behaviour, so libinput sorts higher than xorg-x11-drv-evdev and thus overrides that driver if installed.

Comment 28 Michael Boisvert 2018-01-04 18:45:07 UTC
I am able to successfully adjust all mouse settings in GNOME 3.26 via GUI, including the important Left/Right primary button.

Comment 29 Peter Hutterer 2018-01-10 09:00:58 UTC
*** Bug 1492643 has been marked as a duplicate of this bug. ***

Comment 33 errata-xmlrpc 2018-04-10 12:57:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0770

Comment 35 David Jones 2019-04-16 14:59:32 UTC
After applying this fix, I'm able to change the setting, but it uses the opposite button from the one I set it to, i.e. left = right. Perhaps there's a login error in the code so it thinks that "left button" means "left side". This is on Gnome. It's running in a VM, which may be relevant. 

It's unfortunate that libinput adoption has taken so long, and not just on RHEL. Several distros were using Synaptic long after it became a dead project, including Ubuntu. Endless touchpad malfunctions had me ready to abandon Linux distros as Laptop OSes, generally, but then I discovered libinput. I've had no issues since switching to libinput, after two years of use.


Note You need to log in before you can comment on or make changes to this bug.