Bug 148038 - startx glibc detected malloc memory corruption Aborted xmodmap sysmodmap
startx glibc detected malloc memory corruption Aborted xmodmap sysmodmap
Status: CLOSED DUPLICATE of bug 138458
Product: Fedora
Classification: Fedora
Component: xinitrc (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-14 21:18 EST by Umk
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:08:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Umk 2005-02-14 21:18:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
I'm having a problem running X when logged in as a regular user. I see
the "Fedora Core" screen but loading halts after "The Panel" icon
shows. I have included the contents of /var/log/Xorg.0.log below.

If I log in as root and run startx I don't have a problem.

--------------
X Protocol Version 11, Revision 0, Release 6.8.1
Build Operating System: Linux 2.4.21-14.ELsmp i686 [ELF]
Current Operating System: Linux localhost.localdomain 2.6.10-1.760_FC3
#1 Wed Feb 2 00:14:23 EST 2005 i686
Build Date: 20 October 2004
Build Host: tweety.build.redhat.com

Before reporting problems, check http://wiki.X.Org
to make sure that you have the latest version.
Module Loader present
OS Kernel: Linux version 2.6.10-1.760_FC3 (bhcompile bugs build redhat
com) (gcc version 3.4.2 20041017 (Red Hat 3.4.2-6.fc3)) #1 Wed Feb 2
00:14:23 EST 2005
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Feb 9 19:24:10 2005
(==) Using config file: "/etc/X11/xorg.conf"
Could not init font path element /usr/X11R6/lib/X11/fonts/Speedo/,
removing from list!
*** glibc detected *** malloc(): memory corruption: 0x09d9a8a8 ***
/etc/X11/xinit/xinitrc-common: line 45: 4413 Aborted xmodmap "$sysmodmap"
Agent pid 4427
SESSION_MANAGER=local/localhost.localdomain:/tmp/.ICE-unix/4408

Version-Release number of selected component (if applicable):
X Protocol Version 11, Revision 0, Release 6.8.1

How reproducible:
Always

Steps to Reproduce:
1. Start PC
2. Login as standard user
3. X startup freezes
    

Additional info:

This is the relevant section in my xinitrc-common:
if [ -z "$XKB_IN_USE" ]; then
  [ -r "$sysmodmap" ] && xmodmap "$sysmodmap"
  [ -r "$usermodmap" ] && xmodmap "$usermodmap"
fi

sysmodmap resolves to:
sysmodmap=/etc/X11/Xmodmap

Contents of Xmodmap:
! /etc/X11/Xmodmap
!
! global Xmodmap file -- used by both xdm and xinit (startx)

! keycode and keysym remapping should generally be used only if the X
! server config file has been configured to disable the XKEYBOARD
! extension

! i386 and alpha
! keycode 22 = BackSpace
! keycode 107 = Delete           

! powerpc
! keycode 59 = BackSpace
! keycode 125 = Delete

! sparc
! keycode 50 = BackSpace
! keycode 73 = Delete

! Euro sign support
! keycode 26 = e E currency
! keycode 54 = c C cent
! keycode 113 = Mode_switch Mode_switch Multi_key
Comment 1 Mike A. Harris 2005-02-16 17:11:57 EST

*** This bug has been marked as a duplicate of 138458 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:08:11 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.