Bug 1480988 - View archive link for ops projects does not take to kibana-ops [NEEDINFO]
View archive link for ops projects does not take to kibana-ops
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging (Show other bugs)
3.5.1
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.6.z
Assigned To: Jeff Cantrill
Anping Li
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-13 07:10 EDT by Ruben Romero Montes
Modified: 2017-10-25 09:04 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: There was no configuration to distinguish which Kibana instance to use. Consequence: User's were always routed to the same instance Fix: Add an annotation to the operations namespace which has the kibana hostname Result: User's are routed to the Kibana instance specified in the annotation if it exists on the project.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-25 09:04:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
juzhao: needinfo? (sdodson)


Attachments (Terms of Use)
ops ui, no search result (123.29 KB, image/png)
2017-09-14 23:00 EDT, Junqi Zhao
no flags Details
logging 3.5 kibana-ops UI (270.67 KB, image/png)
2017-09-14 23:14 EDT, Junqi Zhao
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Github openshift/openshift-ansible/pull/5219 None None None 2017-08-30 08:49 EDT
Github openshift/openshift-ansible/pull/5266 None None None 2017-08-30 08:54 EDT
Github openshift/origin-web-common/pull/158 None None None 2017-08-30 08:49 EDT
Github openshift/origin-web-console/pull/1968 None None None 2017-08-25 13:31 EDT
Github openshift/origin-web-console/pull/1990 None None None 2017-08-30 09:35 EDT

  None (edit)
Description Ruben Romero Montes 2017-08-13 07:10:11 EDT
Description of problem:
Having installed the aggregated logging with both clusters ES and ES-OPS. When selecting a pod running on a project that should be forwarded to ES-OPS instance (e.g. default namespace), then clicking on the "View archive" link the user is forwarded to the Kibana instance instead of the Kibana-ops instance.

Version-Release number of selected component (if applicable):
openshift v3.5.5.31

How reproducible:
Always

Steps to Reproduce:
1. Install aggregated logging with ops cluster enabled (openshift_logging_use_ops)
2. Access Openshift web console with a cluster-admin user
3. Access default namespace, select any pod and click on "View archive"

Actual results:
User is always redirected to what is configured on loggingPublicURL always, regardless where the logs are actually sent.

Expected results:
User to be forwarded to either kibana or kibana-ops route depending on the pod's namespace (default, openshift, openshift-infra)

Additional info:
Currently Openshift console only has one configuration variable for aggregated logging, which is loggingPublicURL and there's no way to distinguish between es and es-ops cluster from the console.
Comment 8 openshift-github-bot 2017-08-29 12:24:08 EDT
Commit pushed to master at https://github.com/openshift/origin-web-console

https://github.com/openshift/origin-web-console/commit/bac757fc0e920768bf9a08924c77468cfe113e82
bug 1480988. Use project annotation to determine kibana url for ops namespaces
Comment 10 Junqi Zhao 2017-09-14 05:18:54 EDT
Jeff
Do the fixes are in
elasticsearch-cloud-kubernetes-2.4.4.01_redhat_1-1.el7 and
openshift-elasticsearch-plugin-2.4.4.13__redhat_1-1.el7
Comment 11 Junqi Zhao 2017-09-14 23:00 EDT
Created attachment 1326267 [details]
ops ui, no search result
Comment 12 Junqi Zhao 2017-09-14 23:14 EDT
Created attachment 1326268 [details]
logging 3.5 kibana-ops UI
Comment 13 Junqi Zhao 2017-09-14 23:17:58 EDT
ops projects take to kibana-ops UI now, but there is no search result
Take default project pod "docker-registry-1-w24p1" for example

Clicked the "View archive" link from web console, and browser navigated to kibana-ops UI. info was "Discover:"project.default.9479f0f2-9821-11e7-926c-fa163e21c504.* is not a configured pattern. Using the default index pattern: *.all"". After a while this info disappeared, and "No results found" shown in page, see the attached picture "ops ui, no search result".

I think the root cause is there are not Available Fields under .all  index. see the attached "logging 3.5 kibana-ops UI", logging 3.5 kibana-ops UI has Available Fields under .all index.
Comment 14 Jeff Cantrill 2017-09-21 14:26:39 EDT
The fact you dont see results is a separate issue from this which was you are not getting to the ops instance of Kibana.  In regards to #13, that may be related to https://bugzilla.redhat.com/show_bug.cgi?id=1473153
Comment 15 Jeff Cantrill 2017-09-21 14:28:28 EDT
Wrong bug reference in #c14
Comment 17 Junqi Zhao 2017-09-27 20:34:58 EDT
@Scott,

Is atomic-openshift-3.6 package ready? It needs atomic-openshift-3.6 package to fix this defect.
Comment 19 Anping Li 2017-10-16 02:27:33 EDT
It redirect to ops kibana with atomic-openshift-master-3.6.173.0.49.  So move to verified.

Note: The ops-kibana print the following warning message.  that is as expected. 

Discover: "project.default.2e270631-ad78-11e7-8dba-fa163e8efe63.*" is not a configured pattern. Using the default index pattern: ".operations.*"
Comment 21 errata-xmlrpc 2017-10-25 09:04:36 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3049

Note You need to log in before you can comment on or make changes to this bug.