Bug 1481205 - libreport: Do not redefine log
Summary: libreport: Do not redefine log
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libreport
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: abrt
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-14 11:14 UTC by Mikhail
Modified: 2017-09-21 23:52 UTC (History)
18 users (show)

Fixed In Version: glibc-2.26.90-5.fc28 glibc-2.26-3.fc27 libreport-2.9.1-3.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-21 23:52:53 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1484585 None None None Never

Internal Links: 1484585

Description Mikhail 2017-08-14 11:14:47 UTC
Description of problem:
package abrt-java-connector-1.1.0-8.fc24.x86_64 requires librpm.so.7()(64bit), but none of the providers can be installed


# dnf update
Fedora - Rawhide - Developmental packages for the next Fedora release                                                                                                              846 kB/s |  65 MB     01:18    
Fedora - Rawhide - Debug                                                                                                                                                           1.6 MB/s |  14 MB     00:08    
google-chrome-unstable                                                                                                                                                              33 kB/s | 3.9 kB     00:00    
home:mhsabbagh (Fedora_Rawhide)                                                                                                                                                    2.0 kB/s | 1.4 kB     00:00    
RPM Fusion for Fedora Rawhide - Free                                                                                                                                               528 kB/s | 675 kB     00:01    
RPM Fusion for Fedora Rawhide - Nonfree                                                                                                                                            875 kB/s | 158 kB     00:00    
Last metadata expiration check: 0:00:00 ago on Mon 14 Aug 2017 04:08:26 PM +05.
Dependencies resolved.

 Problem 1: cannot install both rpm-libs-4.13.90-0.git14002.2.fc27.x86_64 and rpm-libs-4.13.0.1-41.fc27.x86_64
  - package abrt-java-connector-1.1.0-8.fc24.x86_64 requires librpm.so.7()(64bit), but none of the providers can be installed
  - cannot install the best update candidate for package rpm-libs-4.13.0.1-41.fc27.x86_64
  - cannot install the best update candidate for package abrt-java-connector-1.1.0-8.fc24.x86_64
 Problem 2: problem with installed package abrt-java-connector-1.1.0-8.fc24.x86_64
  - package abrt-java-connector-1.1.0-8.fc24.x86_64 requires librpm.so.7()(64bit), but none of the providers can be installed
  - cannot install both rpm-libs-4.13.90-0.git14002.2.fc27.x86_64 and rpm-libs-4.13.0.1-41.fc27.x86_64
  - package PackageKit-1.1.6-7.fc27.x86_64 requires librpm.so.8()(64bit), but none of the providers can be installed
  - cannot install the best update candidate for package PackageKit-1.1.6-2.fc27.x86_64
===================================================================================================================================================================================================================
 Package                                                Arch                                      Version                                                         Repository                                  Size
===================================================================================================================================================================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 rpm-libs                                               x86_64                                    4.13.90-0.git14002.2.fc27                                       rawhide                                    319 k
Skipping packages with broken dependencies:
 PackageKit                                             x86_64                                    1.1.6-7.fc27                                                    rawhide                                    581 k
 abrt-java-connector                                    x86_64                                    1.1.0-8.fc24                                                    rawhide                                     41 k

Transaction Summary
===================================================================================================================================================================================================================
Skip  3 Packages

Nothing to do.
Complete!

Comment 1 Jan Kurik 2017-08-15 08:13:00 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 27 development cycle.
Changing version to '27'.

Comment 2 Wallace Hermano 2017-08-20 20:31:27 UTC
[root@jupiter wallace]# cat /etc/fedora-release 
Fedora release 26 (Twenty Six)
[root@jupiter wallace]# dnf clean all
30 files removed
[root@jupiter wallace]# dnf install dnf-plugin-system-upgrade
Fedora 26 - x86_64 - Updates                                                                                                                                                       3.9 MB/s |  10 MB     00:02    
Fedora 26 - x86_64                                                                                                                                                                 4.8 MB/s |  53 MB     00:11    
Last metadata expiration check: 0:00:02 ago on Sun 20 Aug 2017 05:28:42 PM -03.
Package python3-dnf-plugin-system-upgrade-2.0.2-1.fc26.noarch is already installed, skipping.
Dependencies resolved.
Nothing to do.
Complete!
[root@jupiter wallace]# dnf -v system-upgrade download --refresh --releasever=rawhide
Loaded plugins: builddep, config-manager, copr, debug, debuginfo-install, download, generate_completion_cache, needs-restarting, playground, repoclosure, repograph, repomanage, reposync, system-upgrade
DNF version: 2.6.3
cachedir: /var/cache/dnf
Before you continue ensure that your system is fully upgraded by running "dnf --refresh upgrade". Do you want to continue [y/N]: y
Fedora rawhide - x86_64 - Updates                                                                                                                                                  4.4 MB/s |  65 MB     00:14    
not found updateinfo for: Fedora rawhide - x86_64 - Updates
updates: using metadata from Sat 19 Aug 2017 08:56:51 AM -03.
Fedora rawhide - x86_64                                                                                                                                                            4.5 MB/s |  65 MB     00:14    
not found updateinfo for: Fedora rawhide - x86_64
fedora: using metadata from Sat 19 Aug 2017 08:56:51 AM -03.
Last metadata expiration check: 0:00:26 ago on Sun 20 Aug 2017 05:30:02 PM -03.
Completion plugin: Generating completion cache...
--> Starting dependency resolution
--> Finished dependency resolution
Error: 
 Problem: problem with installed package abrt-java-connector-1.1.0-8.fc24.x86_64
  - package abrt-java-connector-1.1.0-8.fc24.x86_64 requires librpm.so.7()(64bit), but none of the providers can be installed
  - rpm-libs-4.13.0.1-5.fc26.x86_64 does not belong to a distupgrade repository
[root@jupiter wallace]#

Comment 3 Matej Habrnal 2017-08-21 12:06:58 UTC
Error from build logs:

In file included from /usr/include/abrt/libabrt.h:17:0,
                 from /builddir/build/BUILD/abrt-java-connector-230b72697c7c43db747b2644b17cb2685d1539de/src/internal_libabrt.h:26,
                 from /builddir/build/BUILD/abrt-java-connector-230b72697c7c43db747b2644b17cb2685d1539de/test/unittests/check_abrt_java_connector.c:2:
/usr/include/bits/mathcalls.h:104:1: error: expected declaration specifiers or '...' before numeric constant
 __MATHCALL_VEC (log,, (_Mdouble_ __x));
 ^
/usr/include/bits/mathcalls.h:104:1: error: expected declaration specifiers or '...' before string constant
 __MATHCALL_VEC (log,, (_Mdouble_ __x));
 ^
/usr/include/bits/mathcalls.h:104:1: error: expected declaration specifiers or '...' before numeric constant
 __MATHCALL_VEC (log,, (_Mdouble_ __x));
 ^
/usr/include/bits/mathcalls.h:104:1: error: expected declaration specifiers or '...' before '__func__'
 __MATHCALL_VEC (log,, (_Mdouble_ __x));
 ^
In file included from /usr/include/libreport/libreport_types.h:22:0,
                 from /usr/include/libreport/global_configuration.h:23,
                 from /usr/include/libreport/internal_libreport.h:93,
                 from /usr/include/abrt/libabrt.h:17,
                 from /builddir/build/BUILD/abrt-java-connector-230b72697c7c43db747b2644b17cb2685d1539de/src/internal_libabrt.h:26,
                 from /builddir/build/BUILD/abrt-java-connector-230b72697c7c43db747b2644b17cb2685d1539de/test/unittests/check_abrt_java_connector.c:2:
/usr/include/bits/mathcalls.h:104:1: error: expected declaration specifiers or '...' before numeric constant
 __MATHCALL_VEC (log,, (_Mdouble_ __x));
 ^
/usr/include/bits/mathcalls.h:104:1: error: expected declaration specifiers or '...' before numeric constant
 __MATHCALL_VEC (log,, (_Mdouble_ __x));
 ^

Comment 4 Florian Weimer 2017-08-21 15:22:53 UTC
Sorry, I misread the build log.  The root cause is this:

/usr/include/libreport/internal_libreport.h:#define log(...)         log_standard(LOG_WARNING, __FILE__, __LINE__, __func__, __VA_ARGS__)

This should be fixed in libreport.

Comment 5 Fedora Update System 2017-09-04 08:05:27 UTC
abrt-2.10.3-2.fc26 libreport-2.9.1-3.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-3f68f150f6

Comment 6 Fedora Update System 2017-09-04 22:50:15 UTC
abrt-2.10.3-2.fc26, libreport-2.9.1-3.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-3f68f150f6

Comment 7 Fedora Update System 2017-09-07 08:31:36 UTC
abrt-2.10.3-3.fc26 libreport-2.9.1-3.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-3f68f150f6

Comment 8 Fedora Update System 2017-09-08 00:23:42 UTC
abrt-2.10.3-3.fc26, libreport-2.9.1-3.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-3f68f150f6

Comment 9 Fedora Update System 2017-09-21 23:52:53 UTC
abrt-2.10.3-3.fc26, libreport-2.9.1-3.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.