Bug 1484585 - Cannot install abrt-java-connector due to broken dependencies
Summary: Cannot install abrt-java-connector due to broken dependencies
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: abrt-java-connector
Version: rawhide
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
Assignee: Jakub Filak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1493090
TreeView+ depends on / blocked
 
Reported: 2017-08-23 23:30 UTC by David Hill
Modified: 2017-09-20 15:25 UTC (History)
8 users (show)

Fixed In Version: abrt-java-connector-1.1.0-13.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-20 12:15:21 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1481205 unspecified CLOSED libreport: Do not redefine log 2020-10-14 00:28:05 UTC

Internal Links: 1481205

Description David Hill 2017-08-23 23:30:43 UTC
Description of problem:
Cannot install abrt-java-connector due to broken dependencies

[root@otto ~]# yum install abrt-java-connector
Last metadata expiration check: 1:59:56 ago on Wed 23 Aug 2017 05:28:04 PM EDT.
Error: 
 Problem: conflicting requests
  - package abrt-java-connector-1.1.0-8.fc24.x86_64 requires librpm.so.7()(64bit), but none of the providers can be installed
  - problem with installed package grub2-pc-1:2.02-10.fc27.x86_64
  - package grub2-pc-1:2.02-10.fc27.x86_64 requires grub2-tools = 1:2.02-10.fc27, but none of the providers can be installed
  - package grub2-tools-1:2.02-10.fc27.x86_64 requires librpm.so.8()(64bit), but none of the providers can be installed
  - cannot install both rpm-libs-4.13.0.1-4.fc26.x86_64 and rpm-libs-4.13.90-0.git14002.6.fc28.x86_64
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstalable packages)

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Fedora Update System 2017-09-10 14:13:09 UTC
abrt-java-connector-1.1.0-13.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-2a110b5a82

Comment 2 Peter Robinson 2017-09-10 14:14:13 UTC
Build is fixed and is now built against the latest rpm in rawhide

Comment 3 Fedora Update System 2017-09-10 18:24:04 UTC
abrt-java-connector-1.1.0-13.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-2a110b5a82

Comment 4 Kamil Páral 2017-09-20 12:15:21 UTC

*** This bug has been marked as a duplicate of bug 1493090 ***

Comment 5 Kamil Páral 2017-09-20 13:07:37 UTC
Removing the dependency, because this has been fixed clearly even without it, and it's causing us issues with blocker bug tracking.

Comment 6 Fedora Update System 2017-09-20 15:25:31 UTC
abrt-java-connector-1.1.0-13.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.