Bug 14821 - KDE splash screen hangs on initial login
Summary: KDE splash screen hangs on initial login
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdebase   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard: Winston rc1
Keywords:
: 14954 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-28 20:28 UTC by Matthew Miller
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-01 19:40:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matthew Miller 2000-07-28 20:28:59 UTC
Whenever someone selects the KDE environment (either via gdm or kdm),
ksplash gets to 83% and then hangs. The environment seems actually
functional. As soon as the user runs a different program, the percentage
jumps to 100% and the splash screen goes away.

Comment 1 Glen Foster 2000-07-30 22:06:45 UTC
This defect is considered MUST-FIX for Winston Release-Candidate #1

Comment 2 Gene Czarcinski 2000-07-31 06:55:08 UTC
For me, this does not occur on just the "first" login.  It happens every time. 
I get to "83%" and hang.  I then use "ctl-alt-backspace" to get out.  When I try
again, it does the same thing.

Also, it does the same thing when done from startx.

Also, the "User Configuration" "green light" never goes on when it starts on the
Session.

Gene

Comment 3 Matthew Miller 2000-07-31 15:47:52 UTC
If I leave the splash screen at 83% and kill X with ctrl-alt-backspace, the same
problem happens the next time I log in. However, if I ignore the splash screen
and start another app (making the splash go away) and then log out normally,
when I log in again, there isn't a problem.

Comment 4 Gene Czarcinski 2000-07-31 16:40:17 UTC
OK, I give up -- how do you start another app??

When I get hung in the startup screen, the only thing I have is the startup
screen and a grey background -- no panels, no icons, no mouse-click menus, no
nothing.

Gene

Comment 5 Matthew Miller 2000-07-31 18:25:48 UTC
Interesting. I get the full KDE environment -- panels, menus, everything.

Comment 6 Gene Czarcinski 2000-08-01 08:46:57 UTC
I wonder if this is some sort of time problem (race condition).  I get the same
results on two systems tested: (1) a dual processor PII 400MHz with ATI Rage Pro
video and (2) a dual processor PIII 600MHz with TNT2 video ... both woith 256MB
ram.

Comment 7 Gene Czarcinski 2000-08-01 10:33:55 UTC
OK, did some additional testing --

1. Running pinstripe (workstation gnome & kde install) under vmware, I got
results similar to those of mattdm ... everything came up but splash screen hung
at 83% and disappears when I started a terminal.

2. Running on real hardware (dual PII 400MHz) but with the up kernel, I got
slightly different results ... screen when grey and the splash panel started BUT
completed to 100% and then disappeared.  HOWEVER, no panel, no anything but a
clear grey screen. (ctl-alt-backspace to get out).  Note that the Desktop and
User Configuration "lights" did NOT go on.

This is very confusing.

Comment 8 Gene Czarcinski 2000-08-01 14:22:47 UTC
And on yet another vmware system running as a guest on a rhl 6.2 PIII 600MHz
dual processor, kde fails the same way it does on real hardware.

Comment 9 Bernhard Rosenkraenzer 2000-08-01 19:40:42 UTC
*** Bug 14954 has been marked as a duplicate of this bug. ***

Comment 10 Bernhard Rosenkraenzer 2000-08-01 19:56:27 UTC
Fixed in rawhide by going back to kde 1 for now (kde 2 will be back).
The problem is an odd bug in the session management code; currently looking at
it (and fixing in CVS).


Note You need to log in before you can comment on or make changes to this bug.