Bug 1482133 - User can't change his password with smbpasswd
Summary: User can't change his password with smbpasswd
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: samba
Version: 7.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Andreas Schneider
QA Contact: Andrej Dzilský
URL:
Whiteboard:
Depends On:
Blocks: 1484713
TreeView+ depends on / blocked
 
Reported: 2017-08-16 14:19 UTC by Andrej Dzilský
Modified: 2018-04-10 17:29 UTC (History)
5 users (show)

Fixed In Version: samba-4.6.2-10.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1484713 (view as bug list)
Environment:
Last Closed: 2018-04-10 17:28:22 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0937 None None None 2018-04-10 17:29:42 UTC

Comment 3 Andreas Schneider 2017-08-18 07:48:02 UTC
*** Bug 1482816 has been marked as a duplicate of this bug. ***

Comment 11 Andreas Schneider 2017-08-23 14:34:12 UTC
smbpasswd was not only broken for local users but also the remote case was broken because there was no way to set the domain name. This has been also addressed!

Comment 14 Andrej Dzilský 2017-10-27 14:40:54 UTC
Bug verified and covered by one of our tests.

Bug is fixed on latest 7.4 and 7.5 versions of Samba.

Comment 18 errata-xmlrpc 2018-04-10 17:28:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0937


Note You need to log in before you can comment on or make changes to this bug.