Bug 1482616 - No desktop keyring for LXQt desktop
Summary: No desktop keyring for LXQt desktop
Alias: None
Product: Fedora
Classification: Fedora
Component: lxqt-wallet
Version: rawhide
Hardware: Unspecified
OS: Unspecified
Target Milestone: ---
Assignee: Zamir SUN
QA Contact: Fedora Extras Quality Assurance
Depends On: 1520087 1581463
TreeView+ depends on / blocked
Reported: 2017-08-17 17:50 UTC by Quentin Tayssier
Modified: 2019-05-08 10:16 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed: 2019-05-08 09:09:12 UTC
Type: Bug

Attachments (Terms of Use)

Description Quentin Tayssier 2017-08-17 17:50:26 UTC
Description of problem:
Desktop environment cannot store and retrieve passwords (keyring functionality).

Version-Release number of selected component (if applicable):

How reproducible: Features not avalaible.

Expected results:
Feature avalaible.

Additional info:
Tested during LXQt testday.

LXQt is not a release-blocking desktop but feature should be avalaible.

This test case is associated with the Fedora_27_Final_Release_Criteria#default-application-functionality release criterion:
Saving passwords to and retrieving passwords from the default keyring must work for all release-blocking desktops.

Comment 1 Raphael Groner 2017-08-18 20:30:50 UTC
It should be possible to use very application that's based on qtkeychain or directly kf5-kwallet. There's a special package lxqt-wallet to provide kwallet like functionality also to native LXQt applications.

Comment 2 Raphael Groner 2018-07-28 19:41:29 UTC
Reporter, is this still an issue?

Comment 3 Raphael Groner 2018-09-01 08:06:41 UTC
Zamir, could you take a look into this?

Comment 4 panina 2018-10-19 09:32:55 UTC
I'm running fedora 28 LXQT 32-bit, and have no GUI wallet.
Probably related is that lxqt-openssh-askpass doesn't start when using ssh.

Comment 5 Zamir SUN 2019-01-11 16:30:17 UTC
(In reply to panina from comment #4)
> I'm running fedora 28 LXQT 32-bit, and have no GUI wallet.
> Probably related is that lxqt-openssh-askpass doesn't start when using ssh.

Can you provide some steps how I can reproduce this?

And, does it work for you in Fedora 29?


Comment 6 panina 2019-04-30 12:01:34 UTC
The old machine, with 32-bit, was a bit of a messy installation, so I wasn't sure I could reproduce it.
I've now installed Fedora LXQT 64-bit on another machine. Fresh installation of Fedora 29, and the problem exists here as well.

It seems to me to be a bad handling of the SSH_ASKPASS variable. lxqt-openssh-askpass is installed, and is in the SSH_ASKPASS variable. Still no dialog, ssh asks for password on the cli instead.
I've also tried installing openssh-askpass, but that did nothing for the issue.

So, current steps to reproduce:
Install Fedora LXQT 29, create an ssh-key with a password, and use ssh.

The other machine uses kwallet, which works for the ssh keys. However, kwallet prompts for password upon startup, and doesn't unlock on login. It needs to be unlocked separately. That step is annoying enough for me to not want to use it on the new machine - I'll probably use some cli-based keyring instead.

Comment 7 Zamir SUN 2019-05-02 09:47:03 UTC
Thanks for the steps. I'll try in a freshly installed VM and see if I can get some ideas.

Comment 8 Zamir SUN 2019-05-08 09:09:12 UTC
Hi all,

1. ssh-askpass won't use the GUI if you are ssh from the terminal.

2. As for the status of lxqt_wallet, from the readme I think it requires other apps to support it explicitly

"This project is designed to be used by other projects simply by adding the source folder in the build system and start using it."


So based on this information, I think the issues described here are all not bugs.

I'm closing as not a bug. If you have evidence to prove I have some misunderstanding for the way lxqt_wallet works, feel free to re-open this.

Comment 9 panina 2019-05-08 09:39:58 UTC
The situation described in this stackexchange link is, as far as I can understand, someone ssh'ing into a server, and then ssh'ing into a third system.

The situation I have described here is when I open a terminal window in kxqt, and then using ssh.
On any other graphical environment, I get an askpass dialog, and an option to store the ssh key passphrase in the keyring. That's what the ssh-askpass applications are for.

Comment 10 Zamir SUN 2019-05-08 10:16:56 UTC
Yes before I close this bug, I tried the same steps as you did.
I also tried to ssh from XFCE to a server, and the xfce askpass agent will not come out as well.

If I do as 'setsid ssh mytestmachine' the lxqt-openssh-askpass comes out as expected, so as in XFCE. But even in this scenario, lxqt-openssh-askpass did not ask for saving password, and so as in XFCE.

Did you ever successful in using ssh to other machines and lxqt-openssh-askpass comes out before? If so, can you provide the version? Fedora release version should be sufficient.

If not, I think this is more like a feature request instead of a bug.

Note You need to log in before you can comment on or make changes to this bug.