Bug 1482835 - glusterd fails to start
Summary: glusterd fails to start
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: 3.12
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: Atin Mukherjee
QA Contact:
URL:
Whiteboard:
: 1482844 (view as bug list)
Depends On: 1472267
Blocks: 1449867 1482844 1482857
TreeView+ depends on / blocked
 
Reported: 2017-08-18 08:04 UTC by Atin Mukherjee
Modified: 2017-10-26 14:36 UTC (History)
11 users (show)

Fixed In Version: glusterfs-3.12.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1472267
Environment:
Last Closed: 2017-09-05 17:39:07 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Atin Mukherjee 2017-08-18 08:04:59 UTC
+++ This bug was initially created as a clone of Bug #1472267 +++

Consider the case where the storage node is stopped and on restart the storage node gets a new ip_address or hostname or one of the peer's network interface is not up. In this case glusterd is not starting. 

glusterd logs gives error as "glusterd resolve brick failed in restore".

--- Additional comment from Atin Mukherjee on 2017-07-24 00:50:08 EDT ---

patch : https://review.gluster.org/#/c/17813/

--- Additional comment from Worker Ant on 2017-07-26 07:08:54 EDT ---

REVIEW: https://review.gluster.org/17813 (glusterd : glusterd fails to start when  peer's network interface is down) posted (#4) for review on master by Gaurav Yadav (gyadav@redhat.com)

--- Additional comment from Worker Ant on 2017-07-26 13:45:29 EDT ---

REVIEW: https://review.gluster.org/17813 (glusterd : glusterd fails to start when  peer's network interface is down) posted (#5) for review on master by Gaurav Yadav (gyadav@redhat.com)

--- Additional comment from Worker Ant on 2017-07-28 00:47:29 EDT ---

COMMIT: https://review.gluster.org/17813 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit 1477fa442a733d7b1a5ea74884cac8f29fbe7e6a
Author: Gaurav Yadav <gyadav@redhat.com>
Date:   Tue Jul 18 16:23:18 2017 +0530

    glusterd : glusterd fails to start when  peer's network interface is down
    
    Problem:
    glusterd fails to start on nodes where glusterd tries to come up even
    before network is up.
    
    Fix:
    On startup glusterd tries to resolve brick path which is based on
    hostname/ip, but in the above scenario when network interface is not
    up, glusterd is not able to resolve the brick path using ip_address or
    hostname With this fix glusterd will use UUID to resolve brick path.
    
    Change-Id: Icfa7b2652417135530479d0aa4e2a82b0476f710
    BUG: 1472267
    Signed-off-by: Gaurav Yadav <gyadav@redhat.com>
    Reviewed-on: https://review.gluster.org/17813
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Prashanth Pai <ppai@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>

Comment 1 Worker Ant 2017-08-18 08:05:29 UTC
REVIEW: https://review.gluster.org/18061 (glusterd : glusterd fails to start when  peer's network interface is down) posted (#1) for review on release-3.12 by Atin Mukherjee (amukherj@redhat.com)

Comment 2 Atin Mukherjee 2017-08-21 04:54:24 UTC
*** Bug 1482844 has been marked as a duplicate of this bug. ***

Comment 3 Worker Ant 2017-08-21 14:29:03 UTC
COMMIT: https://review.gluster.org/18061 committed in release-3.12 by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit a6608cf7b62de850502c582a638cf0d5fc2cad9a
Author: Gaurav Yadav <gyadav@redhat.com>
Date:   Tue Jul 18 16:23:18 2017 +0530

    glusterd : glusterd fails to start when  peer's network interface is down
    
    Problem:
    glusterd fails to start on nodes where glusterd tries to come up even
    before network is up.
    
    Fix:
    On startup glusterd tries to resolve brick path which is based on
    hostname/ip, but in the above scenario when network interface is not
    up, glusterd is not able to resolve the brick path using ip_address or
    hostname With this fix glusterd will use UUID to resolve brick path.
    
    >Reviewed-on: https://review.gluster.org/17813
    >Smoke: Gluster Build System <jenkins@build.gluster.org>
    >Reviewed-by: Prashanth Pai <ppai@redhat.com>
    >CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    >Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    >(cherry picked from commit 1477fa442a733d7b1a5ea74884cac8f29fbe7e6a)
    
    Change-Id: Icfa7b2652417135530479d0aa4e2a82b0476f710
    BUG: 1482835
    Signed-off-by: Gaurav Yadav <gyadav@redhat.com>
    Reviewed-on: https://review.gluster.org/18061
    Tested-by: Atin Mukherjee <amukherj@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>

Comment 4 Shyamsundar 2017-09-05 17:39:07 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.12.0, please open a new bug report.

glusterfs-3.12.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-September/000082.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.