Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 1483085 - [abrt] volumeicon: asound_get_volume(): volumeicon killed by signal 6
[abrt] volumeicon: asound_get_volume(): volumeicon killed by signal 6
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: volumeicon (Show other bugs)
27
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:9f8b28e7213a2a8dcb4f72a2b7f...
:
: 1490095 1560197 1563371 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-18 13:47 EDT by deadrat
Modified: 2018-04-11 12:31 EDT (History)
10 users (show)

See Also:
Fixed In Version: volumeicon-0.5.1-1.fc28 volumeicon-0.5.1-1.fc27
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-07 18:14:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (11.78 KB, text/plain)
2017-08-18 13:47 EDT, deadrat
no flags Details
File: cgroup (289 bytes, text/plain)
2017-08-18 13:47 EDT, deadrat
no flags Details
File: core_backtrace (1.78 KB, text/plain)
2017-08-18 13:47 EDT, deadrat
no flags Details
File: cpuinfo (1.05 KB, text/plain)
2017-08-18 13:47 EDT, deadrat
no flags Details
File: dso_list (7.62 KB, text/plain)
2017-08-18 13:47 EDT, deadrat
no flags Details
File: environ (1.68 KB, text/plain)
2017-08-18 13:47 EDT, deadrat
no flags Details
File: limits (1.29 KB, text/plain)
2017-08-18 13:47 EDT, deadrat
no flags Details
File: maps (34.15 KB, text/plain)
2017-08-18 13:47 EDT, deadrat
no flags Details
File: open_fds (301 bytes, text/plain)
2017-08-18 13:47 EDT, deadrat
no flags Details
File: proc_pid_status (1.26 KB, text/plain)
2017-08-18 13:47 EDT, deadrat
no flags Details
File: var_log_messages (313 bytes, text/plain)
2017-08-18 13:47 EDT, deadrat
no flags Details

  None (edit)
Description deadrat 2017-08-18 13:47:32 EDT
Description of problem:
added as startup item of i3wm, but fails to start. 

Version-Release number of selected component:
volumeicon-0.4.6-9.fc26

Additional info:
reporter:       libreport-2.9.1
backtrace_rating: 4
cmdline:        volumeicon
crash_function: asound_get_volume
executable:     /usr/bin/volumeicon
journald_cursor: s=f393b9041ea14b1e9d5280afb62099d8;i=5301;b=994bb3b5375149e799d4ca11d0344230;m=ecb23b1;t=555b1f6ac3362;x=5421cb06749cbd8
kernel:         4.11.11-300.fc26.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (1 frames)
 #4 asound_get_volume at alsa_backend.c:86

Potential duplicate: bug 725613
Comment 1 deadrat 2017-08-18 13:47:39 EDT
Created attachment 1315330 [details]
File: backtrace
Comment 2 deadrat 2017-08-18 13:47:41 EDT
Created attachment 1315331 [details]
File: cgroup
Comment 3 deadrat 2017-08-18 13:47:43 EDT
Created attachment 1315332 [details]
File: core_backtrace
Comment 4 deadrat 2017-08-18 13:47:45 EDT
Created attachment 1315333 [details]
File: cpuinfo
Comment 5 deadrat 2017-08-18 13:47:47 EDT
Created attachment 1315334 [details]
File: dso_list
Comment 6 deadrat 2017-08-18 13:47:49 EDT
Created attachment 1315335 [details]
File: environ
Comment 7 deadrat 2017-08-18 13:47:51 EDT
Created attachment 1315336 [details]
File: limits
Comment 8 deadrat 2017-08-18 13:47:54 EDT
Created attachment 1315337 [details]
File: maps
Comment 9 deadrat 2017-08-18 13:47:56 EDT
Created attachment 1315338 [details]
File: open_fds
Comment 10 deadrat 2017-08-18 13:47:58 EDT
Created attachment 1315339 [details]
File: proc_pid_status
Comment 11 deadrat 2017-08-18 13:47:59 EDT
Created attachment 1315340 [details]
File: var_log_messages
Comment 12 Alick Zhao 2017-08-28 23:16:47 EDT
Seems fixed in upstream [1], but the one in fedora haven't been updated for a while.

[1] https://github.com/Maato/volumeicon/issues/32
Comment 13 klier.daniel.19 2017-09-10 04:03:37 EDT
*** Bug 1490095 has been marked as a duplicate of this bug. ***
Comment 14 Dusty Mabe 2017-09-20 10:08:58 EDT
can we get this fixed? I'm hitting this in fedora 25 now:

+[dustymabe@media ~]$ rpm -q volumeicon 
volumeicon-0.4.6-8.fc24.x86_64
+[dustymabe@media ~]$ volumeicon 
volumeicon: alsa_backend.c:86: asound_get_volume: Assertion `m_elem != NULL' failed.
Aborted (core dumped)
Comment 15 deadrat 2017-12-10 17:22:10 EST
Looks like the upstream has released 0.5.1 and we are still using 0.4.6 in F27.
Comment 16 Panagiotis (Peter) A. Vretanos 2017-12-23 21:30:56 EST
Similar problem has been detected:

Rebooted machine. Clicked my username and entered password on login screen.  Error occured while KDE was starting up.

reporter:       libreport-2.9.3
backtrace_rating: 4
cmdline:        /usr/bin/volumeicon
crash_function: asound_get_volume
executable:     /usr/bin/volumeicon
journald_cursor: s=6b33631b6ab440e790e3044f56a466ca;i=92c3;b=807f072ef97047d6bcaa003d3042e1b4;m=1f2cf63;t=56107e5aefde5;x=4b8b3cf8108aabd4
kernel:         4.14.7-300.fc27.x86_64
package:        volumeicon-0.4.6-11.fc27
reason:         volumeicon killed by SIGABRT
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1310
Comment 17 Alick Zhao 2018-01-01 19:25:23 EST
So I built the updated release 0.5.1 on Fedora Copr [1]. It no longer crash upon start up of fvwm for me.

[1] https://copr.fedorainfracloud.org/coprs/alick/volumeicon/
Comment 18 Dusty Mabe 2018-01-02 08:41:16 EST

Alick, would you like to take over the package? If we can't get the maintainer to respond then you can follow this: 

https://fedoraproject.org/wiki/Policy_for_nonresponsive_package_maintainers
Comment 19 Alick Zhao 2018-01-14 20:02:16 EST
(In reply to Dusty Mabe from comment #18)
> 
> Alick, would you like to take over the package? If we can't get the
> maintainer to respond then you can follow this: 
> 
> https://fedoraproject.org/wiki/Policy_for_nonresponsive_package_maintainers

I am following the procedure. The tracking bug is at https://bugzilla.redhat.com/show_bug.cgi?id=1530114
Comment 20 Andy Mender 2018-02-01 03:39:27 EST
Similar problem has been detected:

Desktop Environment: Xfce4
Install procedure: Xfce4 desktop option from the netinstall .iso

Problem description:
Volumeicon crashes while the Xfce4 session starts, but it can be restarted from a terminal emulator successfully.

Steps to reproduce:
Install Fedora 27 from the most recent amd64 netinstall .iso,
select the Xfce4 desktop option and log in as a regular user to the Xfce4 session.

reporter:       libreport-2.9.3
backtrace_rating: 4
cmdline:        volumeicon
crash_function: asound_get_volume
executable:     /usr/bin/volumeicon
journald_cursor: s=e2c241d2c3da42369c947e968eb07bda;i=efdd;b=1f5948c5d9044ab291c6219535b27dc8;m=3981865;t=563ddc4d38976;x=7445c20f583ae443
kernel:         4.14.14-300.fc27.x86_64
package:        volumeicon-0.4.6-11.fc27
reason:         volumeicon killed by SIGABRT
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 21 István Varga 2018-03-24 13:32:22 EDT
*** Bug 1560197 has been marked as a duplicate of this bug. ***
Comment 22 Fedora Update System 2018-04-02 17:39:22 EDT
volumeicon-0.5.1-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-b8fc721764
Comment 23 Fedora Update System 2018-04-02 17:39:46 EDT
volumeicon-0.5.1-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-ebbc9efd81
Comment 24 Alick Zhao 2018-04-02 22:56:59 EDT
Will there be a build for Fedora 26 too?
Comment 25 Fedora Update System 2018-04-03 11:52:28 EDT
volumeicon-0.5.1-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-ebbc9efd81
Comment 26 Fedora Update System 2018-04-03 11:58:31 EDT
volumeicon-0.5.1-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-b8fc721764
Comment 27 István Varga 2018-04-03 14:10:19 EDT
*** Bug 1563371 has been marked as a duplicate of this bug. ***
Comment 28 Fedora Update System 2018-04-07 18:14:04 EDT
volumeicon-0.5.1-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.
Comment 29 Fedora Update System 2018-04-11 12:31:33 EDT
volumeicon-0.5.1-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.