Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1483327 - [kernel] virtual guest using video device QXL does not reach GDM
Summary: [kernel] virtual guest using video device QXL does not reach GDM
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 26
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-20 14:08 UTC by Joachim Frieben
Modified: 2018-03-01 08:15 UTC (History)
10 users (show)

Fixed In Version: kernel-4.15.4-200.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-01 08:15:55 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Linux Kernel 196777 0 None None None 2017-08-26 08:28:48 UTC

Description Joachim Frieben 2017-08-20 14:08:51 UTC
Description of problem:
When booting current Fedora 26 as a virtual guest in gnome-boxes, the system does not reach GDM. It gets stuck during the graphical boot procedure. After removing boot option "rhgb", the system gets frozen after attempting to launch the graphical login manager GDM.

Version-Release number of selected component (if applicable):
kernel-4.12.5-300.fc26

How reproducible:
Always

Steps to Reproduce:
1. Boot current Fedora 26 virtual guest in gnome-boxes.

Actual results:
System gets stuck during the graphical boot procedure.

Expected results:
System launches GDM successfully.

Additional info:
- After adding boot option "nomodeset", the system launches GDM on Xorg successfully.
- After changing the video device from "qxl" to "virtio", the system launches GDM on Wayland successfully.

Comment 1 Chuck Ebbert 2017-08-21 15:35:01 UTC
Probably the same as Rawhide bug 1465148

Try removing "rhgb" from the normal boot options, see if it works without disabling modeset. You may not get past the login screen though.

Comment 2 Joachim Frieben 2017-08-21 20:59:57 UTC
As reported in bug 1464780 for the Fedora development tree, removing "rhgb" allows the system to launch GDM, albeit unsuccessfully: the screen gets frozen. Moreover, after booting into runlevel 3 without option "rhgb", startx launches a GNOME on Xorg session successfully while using the QXL video driver.

Comment 3 Joachim Frieben 2017-08-21 21:06:33 UTC
(In reply to Chuck Ebbert from comment #1)
This situation was already addressed in the initial report.

Comment 4 Joachim Frieben 2017-09-13 16:50:39 UTC
With kernel-4.12.12-300.fc26, the system still hangs at the graphical boot screen. After removing kernel option "rhgb", the system now launches the graphical login manager successfully. However, the screen exhibits a strong flicker.

Comment 5 Laura Abbott 2018-02-28 03:54:44 UTC
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale. The kernel moves very fast so bugs may get fixed as part of a kernel update. Due to this, we are doing a mass bug update across all of the Fedora 26 kernel bugs.
 
Fedora 26 has now been rebased to 4.15.4-200.fc26.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 27, and are still experiencing this issue, please change the version to Fedora 27.
 
If you experience different issues, please open a new bug report for those.


Note You need to log in before you can comment on or make changes to this bug.