Bug 14837 - PPP interface "failing" on boot (timeout?)
PPP interface "failing" on boot (timeout?)
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: initscripts (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
: 16920 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-29 05:03 EDT by Reuben Farrelly
Modified: 2014-03-16 22:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-02 14:05:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Reuben Farrelly 2000-07-29 05:03:10 EDT
I have a ppp interface set up to come up on boot, and this works pretty 
much as expected (the link does actually come up on boot).
Unfortunately the initscripts seem to have some sort of timeout somewhere 
which does not give my modem enough time to negotiate and establish a 
connection.  This means that the startup script will timeout and consider 
the interface to have failed, and it then skips on past starting up other 
services and tasks as listed.
The interface comes up and is fully ready about 5 seconds after the 
initscripts have decided that there was a problem, and all works fairly 
normally after that.

Could the timeout before the initscripts decide that an interface has 
failed to come up be either lengthened or user specified, perhaps in the 
ifcfg-* files?
Comment 1 Henri Schlereth 2000-08-02 00:36:03 EDT
Exists in RH6.2. Dials in background and connects.
Comment 2 Reuben Farrelly 2000-09-02 14:05:16 EDT
Yes you're correct, but this behaviour is not ideal when other daemons in the 
startup (for example ntpd) are started _before_ the PPP link is fully up and 
routing.   This is because any other service which relies on DNS resolution 
when it starts does not get a satisfactory resolve and thus sometimes fails 
(unless of course there is access to DNS via another link).

In this case pppd being backgrounded after 30s is of no use whatsoever.  The 
ability to control this behaviour would be nice.



Comment 3 Bill Nottingham 2001-01-29 19:43:15 EST
This will be fixed as of initscripts-5.60-1; there
is a BOOTTIMEOUT option.
Comment 4 Bill Nottingham 2001-01-29 19:44:10 EST
*** Bug 16920 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.